'Error Opening Midi-Out Device'

I get this error on record

Hi there.

I use N-Track 4.2.1 with an Alesis MultiMix 8 which works fine with other sound recording software on my clean-install dedicated XP machine (3.4Ghz P4, Gig RAM etc.)

However, when I press record in N-Track, I get an ‘Error Opening Midi-Out Device’ error. This also happens when I get play. Although I can just click ok and bypass it, it unsyncs the input which results in a very distorted playback.

I don’t need Midi. I don’t like midi.

Is there any way I can disable midi in n-Track or even just fix this problem?

Thanks!


James Coster
james@blue-shift.net

Check/change what your midi output is currently set to under:

File/settings/prefs/midi settings/midi devices button

You should be able to select your soundcard midi out and just leave it at that, even if you have no intention of using midi.

I only have the option of Microsoft Midi Mapper

The “Midi Mapper” is not a software: it refers to the software that you have selected in the control panel under the Audio settings.

Quote (JCoster @ July 04 2006,07:23)
I only have the option of Microsoft Midi Mapper

Go to your windows control panel/sound and audio devices/audio. What does it say against Midi music playback?

What other options do you have if you click on the little arrow combo box?

PS what soundcard do you have?

Set your recording mode “switch” on the toolbar to AUDIO only. The icon will show a microphone. The other two modes are BOTH MIDI and audio (this icon has a mic and a piano keyboard). The last mode is MIDI only. The icon shows only a piano keyboard in that mode.

Switching to AUDIO ONLY will make n-Track stop looking for your MIDI I/O when starting and stopping playback/recording.

D

Check to see what output the metronome is set to. If it’s set to MIDI and enabled then recording and/or playback will cause n-tracks to attempt opening the MIDI out. This will cause problems if you have no MIDI device.

On that note, the metronome can cause problems if it’s output device is set to MIDI Mapper, the n-tracks MIDI device in the preferences is set to a named device (not MIDI Mapper), but that device is the same device set in the Windows Control Panel as the device to use to system MIDI playback. n-tracks tries to open “your MIDI device” and “MIDI Mapper” at the same time. Since “your MIDI device” and “MIDI Mapper” are the same device you’ll get an error trying to open the MIDI device. Make sure both point the “exactly” the same device or two devices that you know for sure are not the same device.