A problem editing.....

technical

Hey i’ve been having a problem with my ntrack. I record tracks ad then i try to select certain parts to remove or copy and it’s only selecting the whole track. I 've pretty much tried everything with this and nothing seems to be working. It’s letting me click and drag off of the tracks but when i try to select a part of the track to cut out or copy it won’t let me. If anyone knows how i can fix this or is also having theis problem please let me know. Thanks.

Hmmm.

If you point into a displayed wave and click on it and drag to the right, staying within the track, what do you see? Do you see a selected section of the track (highlighted by a different shade)?

If so, try this:

Edit->Cut (or Control-X).

Go to another track with empty space, click and drag where you want the cut section to go, and then Edit->Paste (or Control-V).

Note that this does NOT affect the recorded wave files. It only affects N’s idea of what to play when & where.

Also, after cutting & pasting like this, you can adjust the edges of the edit points by dragging the “end handles” – the little white square boxes at the edges.

That’s the easiest way to do cut-paste editing, but note that if you want to do this, you generally need to use the grid to keep parts in alignment. When moving a selection vertically only (from one track to another, but at the same point in time) the grid doesn’t have to be set up with the song tempo. When moving a selection in horizontally (changing the time), it’s almost impossible to do well unless the grid is set up to align with the timing of the song. The easiest way to do that is to make a click track to begin with and record to the click. However, it is possible to set up a grid after the fact. Tedious but possible.

Only got a few minutes - have to go - but a couple of thoughts…

Grid?

Also, are you sure you’ve not enabled the track-dragging mode (by clicking on the 4 headed arrow icon on the tool bar?

Ah, good point Mark! Be sure to use the arrow tool (in the toolbar at the top of the screen).

<!–QuoteBegin>

Quote
Also, are you sure you’ve not enabled the track-dragging mode (by clicking on the 4 headed arrow icon on the tool bar?


Heh. I remember figuring that one out… I’m one of those curious George types. As soon as the new program opens I start clicking crap to see what happens. IT dude hated my guts for a long time! :D

Me: "Hey IT dude, my PC is locked up!"
IT dude: "What were you doing when it locked up?"
Me: "Oh, clicking all the toolbar icons one after the other to see what’d happen."
IT dude: "Argh!!!"

D – :D

i wish it were that easy. it’s not the four arrow thing i’m using the right cursor it’s just when i click on a track and drag it nothing is happening it just keeps selecting the whole track. so i can’t delete a certain part i have to clone the track and then shift it around which is too much work.

Shift lock key down, by any chance?

Otherwise, sounds like a bug. Sometimes uninstalling and reinstalling fixes things.

It seems to work normally here. Latest build 2003. What build are you running?

D