Alchemy and an issue...

I just want to start with that n-Track customer support is one of the best I have ever dealt with! They give very quick responses and offer the best help possible within their ability!

The issue I’m having seems to be a conflict between the synth app Alchemy and Animoog on my iPhone 5. I have been casually using Alchemy for a while, downloaded n-Track and discovered the world of inter app MIDI!!! However, in my exploration of synth apps I discovered a problem that n-Track customer support can’t assist with, because Alchemy is “no longer supported by Camel Audio.” They can’t download the app to recreate the issue I’m having.

What’s happening is when I go to add Alchemy as an instrument, I click on the Alchemy icon in the list and Animoog opens up, not Alchemy. All other apps open as expected, but Alchemy won’t open unless I uninstall Animoog. I have tried uninstalling N-Track Studio Pro, uninstalling Alchemy, but nothing works, so I guess I’m fishing to see if anyone else has this issue and possibly has a fix.

I really love Alchemy and paid for Animoog which is also a great synth app. I never purchased anything with Alchemy, so I wouldn’t be upset if I can’t us it in n-Track Studio Pro, but there are some drum and synth patches that are virtually one of a kind in Alchemy, that I really want to use. Do any of you guys have suggestions as to what synth app (currently available in iTunes app store)close to Alchemy? I have already purchased Animoog (obviously), Magellen JR, SunrizerXS, but what else is there?

Also, I purchased Native Instruments iMaschine which is an amazing drum machine app, but unfortunately doesn’t support inter app MIDI (or if it does it’s very weak), so do you guys have any suggestions for a strong drum machine a with strong sound selection. I already tried a few which were not what I was looking for. Sample Tank seemed like a decent all around app, but is expensive, large in size and has too many in app purchases to deal with LOL

Thanks for reading my lengthy 1st post (I did try a few searches prior to starting a thread).

I have done this with a PC where I needed to.
Not sure about other operating systems.
It make no assurance this will work, but probably worth a try, provided you can and are willing to reinstall if it goes terribly wrong.
The computer is confusing the two programs and this may be because they share
similar names or access to “operational” files - files that are designed to do a particular job for many different programs.

Here’s what you could try.
Find the executable.
On a PC that may be a .dll
ar .exe.
Let’s say it is named Allchemy is named AL.exe.
Rename that file AL.OLD.
This file will be used to restore the program if things don’t work
Copy the file and this time name it ALKME.EXE.
You now have two copies of the same program.
To start the Alcheme program you will now need to start a program named ALKME.
Use the process that you currently use but substitute the new name.
For instance NTrank will have to do a new search for instruments or whatever.

This Might work, or it could hang the computer because the program has coding that requires the original name.
If that happens, change the origional file back to its origional name and see if things are no worse than before.
You might have to uninstall and reinstall.
please remember I make no warrenty that this will work or cause other problems.
All I can say is it Might work. I have had it work with Windows operating system on a PC.

Thanks for the reply, but unfortunately this is not for the PC. I am using the program on an iPhone and it is not “jail broken,” so I don’t think I can access those files.

Any suggestions on synth apps close or similar to Alchemy in case I can’t sort things out? How about a powerful drum machine app that has inter app MIDI capabilities?