Alesis Multimix 16 firewire

Drop-outs with firewire mixer

After reading all the posts about Alesis Multimix firewire mixers I decided to go ahead and purchase one since there seemed to be good success with those mixers and NTrack. I got everything set up and, for the most part, things work almost as expected. I’m able to record multiple tracks, etc. However, the only problem is that I sometimes get drop-outs during playback and recording and I’m not exactly sure why. Here’s the setup:

Alesis Multimix 16 Firewire mixer
Dell Lattitude D520 (Intel Core 2 @ 2Ghz, 2GB RAM, Hitachi HTS 60GB 7200RPM HD)
PCMCIA Firewire card

I realize this is a laptop, but it seems like it should be powerful enough to handle the i/o necessary without drop-outs. I was using the integrated sound card before with a single USB mic and things worked just fine with no drop-outs or any other issues.

I’ve read other threads about Dell Inspiron laptops runnng just fine with Alesis mixers. Could this be due to the PCMCIA firewire card? Do I need a better PC? Could there be preference settings I need to change? Any thoughts?



The first thing to try is increasing buffer size. (Don’t know about the Aleses, but it is often set via the driver of the soundcard). The default buffer size might be too small. Set to max, record and listen. If the problem is fixed then you will know at least part of the cause, and you can then optimize settings.

When using firewire devices, the order in which the computer and devices are turned on can be important. I have an Edirol FA101 firewire interface. When I use it with my Dell laptop, the FA101 must be turned on first, or I get clicks and dropouts. But if we try to use the FA101 with my son’s slightly different Dell laptop, the computer must be turned on first, or we have problems.

Also, be sure that all background processes are shut down before you try to use your interface (e.g. antivirus, file sharing software such as Allpeers, chat, network -especially wireless). Also be sure that non-essential firewire or USB devices are disconnected or turned off.

You have plenty of processing power. That is not the problem.


I got this figured out. I downloaded the new drivers and after many tries at using the ASIO drivers, Alesis informed me to use the “Alesis Firewire” driver and not the Multimix ASIO driver (Alesis Firewire is still an ASIO driver). Also, I upped the buffer to 512 and set the latency compensation on the ASIO control panel to Medium and things work great!