Anyone using Echo soundcards?

Can I use Purewave mode with N-track?

I have been using an Echo Mia soundcard, and I have had no problems yet, but I am wondering if I should use what they call their Purewave mode, which bypasses the windows kernel mixer. They say that for some recording programs this is a big plus but some other programs already bypass the windows kernel and we should leave the soundcard mode alone.
Does anyone know if n-track bypasses the windows kernel mixer or not? Thanks!

I always kept mine checked when I was using it and never had a problem.

But as always, just try it!!! You can always turn it off if it doesn’t work…

I use Echo cards - have three of them (though one is borrowed form work).

To record at 24 bits with the Gina24 I MUST use PureWave, which sits on MME for what I can tell. The other modes won’t work at 24 bits at all - errors opening the device when not 16 bits.

WDM goes right through KMixer, so it gets 30 ms latency upfront. I haven’t been very happy with ASIO in general with these cards on my machine (crashes and LOTS of pops and clicks), but I don’t need low latency for any reason.

I use MME when using the Layla20. Unfortunately, I can’t use the Gina24 and Layla20 at the same time. I brought a Layla24 home from work to experiment with but haven’t installed it yet. I had it installed on my work machine for a long time. It did well in all modes on the work machine, but I needed to use PureWave to do 24 bits as well. It uses the same driver as the Gina24.

I concur with phoo. However, I successfully used WDM with my old Gina24. I now have an Layla3G & I use Pureware/MME because WDM will not work.

I’m also using the Echo MIA card.

I don’t know how much this will help, as some of the info is a little scattered. I’m currently using WDM drivers and everything works pretty well. I do remember using Purewave also a little while back. Here’s the scattered part. About 6 months ago I got a new HD and so reinstalled Windows. Before the reinstall, I had lag issues (HUGE ones) that I could never quite trace. After the new HD all was good. This makes me wonder if Purewave was causing the problem, because until you mentioned it here, I had totally forgotten about Purewave. It does record in 24 bit unpacked left justified, so that’s not an issue.

So, try it. If you get terrible lag problems (by this I mean a lag reading of over 6000 with 2 tracks and no effects) like I did, we’ll no where the problem is.

There is a bug in n-Tracks, unless it’s been fixed, that if you start recording anywhere but the very beginning of the song then there will be latency added to the new tracks - the new tracks will be placed in the song out of sync, but can be manually moved to be in sync. The tracks do not get out of sync over time when this happens.

It’s possible that isn’t a bug in n-Tracks, but since it doesn’t happen when starting at the beginning of the song it may be something n-Tracks can work around. I haven’t recorded anything in a while so it might be fixed.

There are other reasons that can cause that - wave buffer creating and start up time is one of them. The option to “Keep devices open” affects that to a GREAT degree.

Another thing that has an affect is in Echo’s Console. That’s the option to synchronize the devices. When that is on each pair of inputs and outputs is started at EXACTLY the same time from a single clock tick. This is actually a good thing, but it can cause a little more delay at startup - when record is hit for example. All pairs are daisy-chained together. When that Echo Console is not enabled all devices start independently. Since there is only one clock source they stay in sync anyway, so this isn’t used a necessary option to use.

I record drums (8 tracks at a time) and have never had a problem with any of those 8 being out of sync when the Sync devices option is not enabled, but have had problems when it was checked, though only when not recording all 8 (4 pairs) at once. The problem happens when Sync is on and I’m trying to record a single pair, such as pair 3-4. Since the input pair are daisy-chained pair 3-4 waits for pair 1-2, which would be disabled. Since 1-2 is disabled 3-4 never starts recording. As a matter of fact, playback won’t even start – Hit record and NOTHING happens except it goes into record mode as if the pause button has been hit.

Uncheck Sync in the Echo Console and all is well.

Phoo - I start recording all over the timeline while working on a song & I’ve never experienced this bug. Is it a 4.x issue (I’m still using 3.3)?

As I recall Sync Devices may be the default. I’d better check that.

It was 4.something. I don’t remember is with 3.3 either. I think Sync Devices is on by default.

Thanks Guys! I will keep fiddlin’. Phoo, so are you saying you would recommend against using ASIO drivers with the Echo cards? Thanks!
And TimOBrian, do you mean you always used Purewave w/o problems? Thanks again

I wouldn’t recommend against ASIO. I simply never needed the low latency (most folks don’t) and I had major problems with ASIO and WDM early on - mostly crashes when using earlier Echo drivers. I do experiment after every driver upgrade. I didn’t try to use ASIO or WDM for any serious work later once I realized I couldn’t get them to work with 24 bits (Gina24). PureWave worked so I stopped there (Gina24). I use MME otherwise (Layla20). MME has been the most stable by far on all of my machines for many years.

Thanks!

As far as drivers go, it seems to me that the MIA manual recommends WDM on a Win2K machine, if that helps.


Thanks for the input phoo

I have a Layla 20 and a Layla 24. I have used WMD with both successfully - MME worked but not ASIO.
Echo has finally taken some of the drivers out of Bata and now I can use the ASIO drivers.
You might want to check their site www.echoaudio.com

I cannot get the Purewave to work with either Layla and Ntrack. Maybe it is the Sync setting Phoo referred to.

<!–QuoteBegin>

Quote
I cannot get the Purewave to work with either Layla and Ntrack. Maybe it is the Sync setting Phoo referred to.

That’s possible. I had to fiddle with it, but don’t remember what did the trick. One thing is to make sure the inputs and outputs match type and are from the same card, but that might not be it.

I use a 96/24 and I’ve pretty much always used ASIO. I used the LIVE feature of N-track so low latency was a big issue with me. I’ve never noticed a difference between regular and purewave. I do know that if your output is in purewave mode that Windows Media Player won’t playback files.

Until I started getting into recording lots of tracks at one time, up to 16 now, I didn’t have much trouble with ASIO at all. Using the LIVE feature could be jumpy with too low a buffering and I usually had to ctrl+alt+del to fix it though. When I started doing like 10 tracks at once though, I started having lots of trouble with the recordings just stopping after a certain amount of time based on my buffering settings. For example, 16 tracks with a 1024 buffer would give me about 2:30 worth of recording time before it quit. And it ALWAYS quit.

I tried ASIO4ALL and that resolved it, but I noticed some popping/clicking even with the higher buffering settings.

Next card I get will probably not be an ECHO unfortunately.

To anyone who wants to check: I have used the Layla 24 with both the Analog and the digital as input and recorded large amounts of data, all 16 tracks, using WDM. No problems.
I used to use the Layla 20 and the 24 together with the WDM and that worked too, just no need for 24 tracks recorded at once.
I would say, try the WDM drivers. It doesn’t give you the grouping feature of Purewave, but it works - for me anyhow.

For what it’s worth, I just heard back from ECHO tech guys; they said Purewave should be fine. … We will see.

Please do post what you find out. I would like to try the Purewave but I must be doing somethng wrong.
Bax

I found this link from a few months ago where I put up some screen shots and thoughts. It might be relevant.
http://www.ntrack.com/cgi-bin…urewave