Beginner Question

Setting recording /monitor recording?

Hi, Im new here. I hope I can learn something here. I just got ntrack and am trying to use it. I recently went from a mac to this PC and am on a learning curve. I am using XP and the sound card that came with my new HP computer. Right now I am just trying to figure out how to have my voice play through my earphones ,while recording, as I’m listening to the other tracks that I have recorded. I have tried everything under the sun. I’ve read ntrack’s manual looking for an answer. If I could make this work I could go on and record my songs. Do I need another kind of sound card?
Thanks Jim

The answer probably lies in the Windows mixer settings.

Try this:

Double click the speaker icon in the system tray (by the clock).

The mixer is in two parts; a RECORDING mixer and a PLAYBACK mixer. It’s important to get the settings right for both. To make matters slightly more confusing too, different soundcards have different names for the RECORDING and PLAYBACK sources, but hey, let’s give it a go…


Go “Options”–>“Properties”. Make sure the “Playback” radio- button is selected and tick all the boxes in the panel below.

Then when you click OK, you will get a mixer up with all the PLAYBACK sources that Windows knows about. Make sure that the section for your input source (eg LINE IN or MIC IN) is not muted or set to a very low volume. These are the sources that you can hear when playing back. So this is probably where your issue lies.

Note that in the PLAYBACK mixer you have multiple playback sources available at the same time.

Now go Go “Options”–>“Properties”. Make sure the “Recording” radio- button is selected and tick all the boxes in the panel below.

Again when you click OK you’ll get the mixer up again but this time it’s the RECORDING mixer. In here you can only select one source at a time. Make sure that the one you are using (LINE IN or MIC IN) is selected and the volume is up.

It’s important to ensure that you have the right recording source or you may end up with a) nothing recorded or b) everything on the other tracks recorded onto your new track)


If you are using MIC IN, a subject for another day is that you would be better using LINE IN.


HTH


Mark

Thanks for the help Mark,
Ifollowed your directions and ticked all the boxes in the playback and record windows. I pluged into the rear blue line in on the back (instead of the pink MIC IN)and the headphones to the green line out on the back. I can record to ntrack and hear when I play back the track, but still can’t hear hear my voice through the headphones as I’m recording. In the playback window the volume is up and not muted on the “line in 1&2” In the recording window mixer device says “back line in/mic front line in” and “line in 1&2” is selected with volume up. With headphones on I keep trying different things to see if I can hear my voice when I speak in the mic. I can’t seem to find a control that will do this. Maybe I’ve fouled things up trying everything.:frowning:

See that little window in nTracks that says “live” hit that button. Should light up bright green. Try that.

Quote (StuH @ Mar. 31 2006,11:42)
See that little window in nTracks that says "live" hit that button. Should light up bright green. Try that.

Hey! thanks , I hit the "Live" button. Before when I tried to hit the live button, it would just crash ntrack. But now Im getting something in the monitor. Problem is now that I sound like one of those chipmonks talking with a big delay. I'm getting closer though. Maybe now it is buffer settings?
I appreciate the help.
Jim

Fustrated,Hit the live button and get a loud fast ticking and messed up sound.??? I try adusting the buffers and ntrack crashes. :(

You really don’t want to use the Live button for recording.

You should be able to setup your sourndcard mixer as I described to monitor via the hardware rather than through n-track (software).

What is your soundcard and what are the recording and playback sources that are shown in the mixer?


Mark

I’m not sure how to tell what my sound card is. Where do I find that. I feel about as smart as a bag of hammers. Would it be Realtek HD Audio rear output? Thats what it says in the bottom left corner of the playback control window.

Mark is right. LIVE mode is an advanced feature and shouldn’t be used until you have a need for it.

His first instructions should have worked, but note that some computers name some of the items a little differently.

BTW, you can more easily get to those two Windows mixers from n-Track’s “View -> Soundcard’s Mixer” menu, and you’ll see in the menu that there are two function keys mapped as well.

You don’t need n-Track for this to work, btw – it’s entirely between Windows and your soundcard.

Without even running n-Track, do this to experiment and see how it works. Put on any music player you like, if you want. In the “Volume Control” mixer (the playback one), uncheck Line In (unmute it). While listening in headphones and also sending a signal into your line inputs, adjust the fader for that channel. You should be able to hear it. (For folks with laptops, you can click “mic” and hear yourself talk using the laptop’s built-in mic.)

This fader is where you adjust the monitor level for the audio being recorded. The one labeled “Wave” is the level for the output from n-Track or a music player. It’s generally best to push that one all the way up, unless you need to turn it down some to get the input channel loud enough. I’ve never had that problem myself.

Thanks guys, this really helps. I finally got sound coming through, now i need to experiment with some music.
Thanks a million for the guidance.
Jim

Well I just learned something new there too…I have always been using that live feature. Sorry for the bad advice there dude.

<!–QuoteBegin>

Quote
You really don’t want to use the Live button for recording.

I think exceptions to this rule should be made whenever you are recording something that uses insert effects as an intrinsic part of the performance.
An example is recording electric guitar and using VST effects to shape the sound.
You will need to monitor the performance LIVE through n-Track because the guitar player will finger his instrument differently if he just hears back the clean guitar sound.
So even if you will be recording the performance clean and add the effects at mixing time, you’ll have to provide a somewhat realistic monitor signal.

This goes to say I’d like to ammend this rule of thumb to:
Don’t use LIVE if you don’t need to, but don’t be afraid to use it if the situation calls for it.

And of course, if you are really brave, you could use n-Track’s LIVE feature on stage… :;):

Spot on, Hansje, and thanks for correcting the overgeneralization.

Hansje is right but in order to effectively use “live” you must be able to set-up the system to reduce the latency (delay) and your CPU must be able to handle the effect. This is not always trivial, which I presume is why Jeff was suggesting avoiding this at the entry level.

If you have too much delay it will affect your playing worse than not hearing the effect so that is a prerequisite. I prefer to minimize all program activity while tracking and do all my monitoring externally.

Since I mostly work “live-in-the-studio” it is vital to me that tracking be rock solid. I want to give my PC as few “distractions” from that task as possible. I do this by minimizing the possibility that other programs are running in the background (no anti-virus software for instance) and that unnecessary features are deactivated.

I will either mic a guitar amp or use my Line 6 POD and do my monitoring from my (physical) mixer.

For overdubbing I may be a little less cautious, but for the tracks where the whole ensemble is playing and the live interaction is vital, I am a minimalist. I can use large buffers and don’t have to worry about latency. Large buffers mean that if some part of the PC goes active and interferes with writing to disk momentarily, the data is not lost and no artifacts are created. I tend to be a “belt-and-suspenders” sort of guy though.

Jim

“Belt-and-suspenders” is a wise attitude in this trade and you are absolutely right, except on a couple of minor points:
There is no (or only a slight) relationship between latency and the cpu-load of effects.
If your processor can’t handle the effects you are using, no amount of buffering is gonna cure that.
I’ve played live through a P1-MMX machine with less than 10ms of real latency without dropouts.
It’s your soundcard drivers and the tuning of the OS that make the difference.

Also, dropouts are much more likely to come from overflowing of the input buffers than from overflowing of the disk-writing buffers (which you can set to be 100x as large).
The effect (dropouts) of course being exactly the same :) .