bugs in the final 6

I know Flav is probably breathing hard…taking a break…I did a clean install of the finalized V 6 and found some bugs…

1) I can’t stop the program from creating peak files while recording regardless of the preferences setting

2) the sends and returns faders are all set to a minimum of -30 regardless of the setting in preferences/appearance

those are just annoyances that don’t bother me too much…however, THIS ONE

3) When I push play, regardless of the buffering, driver choice (wdm or asio), number of tracks or effects (even with no effects)the program doesn’t start for about 10-20 seconds…first it does nothing, then it hits the cpu with about 400%, then it plays perfectly…If I use the asio driver (regardless of the asio buffering settings), it stutters for the 10-20 seconds before starting playback…I tried a million different preference settings including the default to no avail…it does the same thing during offline mixdown as well…
I did notice that on my internet/office machine that ntrack “phoned home” (I have to allow it in my firewall) to the mother ship after I registered it and it does run better…My Daw is not online…could this be part of it?


IBM P4 2.8
1 gig ram
Win xp sp3 (tweaked for audio recording)
Delta 66 with the latest drivers
nothing running except windows, Ntrack and my mouse software

All of my other audio and video programs work flawlessly with the same card and setup…hmmmm?

Ray

What build is this (initial 6.0 build was 2373, yesterday I’ve released build 2374)?
Is (3) new in 6.0 final or it happened in earlier beta builds?
Does it make any difference if you try to play a simple 1 track song with no effects?
Please try to reinstall n-Track and after the installation please answer “No” when the program asks you if you want to keep existing settings.
I don’t think that the problem is related to the ‘phoning home’, which only occurs when the program checks if a newer version has been released.

Thanks for the feedback,

Flavio.

There is a setting in Setings>Preferrences>Options to have n-Track check for up-grades. You can turn it off with no problem.

I now have Build 2374 on my computer, and I do not have the long start-up pause that you are experiencing. I don’t show the surge in CPU you are getting either.
The Volume envelope is also accepting new settings as are the Send sliders.
So, maybe I am lucky, or maybe there is a problem somewhere in your system. I sure couldn’t say. Particularly, as you have the same experience on different machines. Are you using build 2374? If not, see if that fixes it. Flavio has not said what build 2374 does yet (when I wrote this anyway) maybe it fixes that bug.

But the .npk files are indeed being created even if they are “turned off” in the preferences.

Latest build (2374)…the previous one (from Sunday) was AWFUL…it froze everytime I tried to register it!..I tried fresh installs, one track, no effects…default settings…, unchecking the “check for new versions”, all my drivers…I mean, I went at this for several hours. I does the same thing on both my p4 machines (internet and DAw) that have entirely different hardware…I’ve been thru so many beta’s that I can’t remember when it started…This version does stop playing immediately when I hit the stop button which is an improvement over the last few builds…On the internet machine it seems, although I can’t be positive, that it got worse when I removed the always on compressor from all the tracks (I HATE that feature…should be an option, not part of the setup)…I would pay ALOT of money for version 3.3 with the volume envelope /plug in/ latency bug and P4 cpu floating point bugs fixed…with the exception of those 2 things my old AMD machine ran almost flawlessly with 3.3…had I not bought the Waves plugs and a newer P4 I would still be using it today!

Ray

My office machine runs it very nicely - latest build 2374 - XP SP3
One little glitch I noticed in Options:

It halfway goes away on mouseover but still looks goofy.

Yikes I have build 2373…I havent noticed anything wrong but I’m new to N Track…I will reInstall It so Its a 2374 build

rsolinski,
I think you are saying that you are having this playing problem with build 2374. I can’t be sure from the way the sentence was phrased.
But what a drag to go through all that and still not have it work!
Glad I am not having that problem.
I notice that the Delta66 has new drivers listed for Windows XP SP3 - do you have those drivers?
My Echo Layla 20, has old drivers, they have not issued new ones in a long time, and WDM will not work with version 6. The ASIO drivers do - go figure? You might check on the new driver and the different MME, WDM or ASIO. I think the answer may be in the driver or it’s setting.
Then:
Try what Flavio has suggested - get build 2374 and do a fresh install and don’t use the existing Config file.
If that doesn’t work:
If you have Not tried these, you might give these a try one at a time.
These settings are all in the Settings>Preferrence> Options:
I don’t think you have a multi-thread computer so be sure that the “Multithread audio processing” is Not checked.
Try with the “Use system timer for” unchecked (that makes your sound card incharge of the clock) It’s probably not this, but can’t hurt to check.
Then try settng the “Compensate plugins” off or on - what ever setting you are not using.
From your comment, you know how to turn off the built in compressor. I have found that set to default it is transparent for me. You can check this by leaving it on default (the diaganal line has no nodes or curves at default) and then move the threshold up and down. Of course, it is easy to just set it to bypass, but I can’t tell any difference at bypass and default. It does seem to add an amplifier, and in other versions I have noticed that it added volume, but I have not noticed it in this one.
You might have a good idea to have a Preferrence setting to turn the Track EQ and Compresser On/Off by default. Then the feature could be enabled or disabled in using the track icon to access the feature.
Bax

Thanks Bax,
Yes it is a playback issue…I had already tried all of your suggestions and many , many more…I have been on Ntrack since 2001 so I know the routine…Yep, I have the latest drivers for the Delta. N doesn’t work with those new ASIO drivers very well although 4 other audio platforms use them with ease…N does the same thing on 2 different machines with vastly different hardware and drivers (but both have XP sp3)so it is logical to think it is a software glitch. I will keep hoping but the ship is sinking fast…I need to get back to work on some projects so it looks like it will be the “other program” until this gets ironed out…My feature request? To be able to disable all the features I don’t/will never use and run REAL LEAN… record audio-mixing with effects and automation-done :)

Ray

Ray

My version (2273, I think) works perfectly. No issues with anything.

BTW, how do you know it hit’s your CPU with 400% ??

Is there a special program your using? Every CPU measurement program I’ve ever seen only goes to 100%.

It’s very strange that you get a 10 to 20 seconds delay before playback starts.
I have a Delta66 that I can test with to try to reproduce the problem.
What buffering settings are you using (i.e. Asio buffer size as set in the Delta Control panel or when using WDM View/buffering settings)?
When you use WDM drivers do you have the ‘Keep audio devices open’ option checked or not, in the Settings/Audio Devices/Advanced box?
Does something change if you use very low or very high buffering? (even if at very low buffering you get drop-outs, just for the sake of testing)
Does the same think happens if Live input processing is active or inactive?
Is the problem connected to video card activity, i.e. does it matter if you close all windows that have moving controls such as vumeters etc.?
Can you check using the Windows Task Manager if the 10-20 seconds wait corresponds to an increase in memory usage for the n-Track process, and if so by how much?

Thanks for the feedback,

Flavio.

The problem occurs with wdm and ASIO drivers (althought the ASio drivers stutter while the wdm
s are silent for 10-20 seconds)…I have checked and unchecked EVERYTHING in the preferences box and the ASIO settings config on the Delta panel…I will try ridiculously low buffering settings with the wdm and closing all moving windows although I normally don’t have any open while I am mixing/playing back…It does exactly the same thing on 2 different machines with different video and audio cards…the only thing the 2 machines have in common is Win XP sp3…everything else except ntrack is vastly different from a software and hardware perpective…

Ray

The “wait” corresponds with a huge spike in cpu activity in task manager…After changing all the settings I now get a consistent “audio driver requests stop streaming” error message…I will try to get it running again and use the ASIO drivers to see what happens and monitor the ram usage…had to take my son to his soccer practice…

Ray

Hi,

I’m having similar difficulties with Version6.0. I’m away from my regular PC so I don’t have all of the build numbers to hand.

I’m using n-track with a desktop (XP, Athlon 3000+) & a laptop (XP, 1.8GHz T43p). I’ve experimented with the built in soundcards on the machines & also an M-audio Blackbox USB guitar front end.

I’m finding that n-track is very unresponsive. I have a demo recording with 8 tracks of audio and I get a 4-8 second delay when I hit the play button. I’ve followed other advice on the forum & adjusted the buffering but to no avail. I’ve tried bypassing any effects sends & turning off the compression. It helps only slightly. I’ve tried Muting all channels except one , but this doesn’t help much either.

I’ve noticed that the CPU usage reported by n-track doesn’t match the story from Windows task manager. The number inside n-track is approximately half of the number reported for the ntrack.exe process. I don’t know how significant this can be; it’s just an observation :whistle: CPU usage shoots up to 100% during this delay, but there is no increase in RAM usage.

The audio channels are slipping out of synch over time. I’ve got a very simple song (1 audio drum track, 1 audio track of rhythm guitar). They play fine together for the 1st minute or so of the song, but then the guitar starts to ‘drag’. I’m not the worlds best guitarist, but my timing isn’t so poor. The synch generally sorts itself out if I stop the song & restart it halfway through.

Sorry if this is too vague to help with debugging the problem. I just see that other people are reporting similar issues. I can provide much more data to help!!

-Andy

Welcome to my world! With the latest builds, using ASIO drivers and unchecking the “compensate for plugin latency” box I get N to run pretty well with no delays in playback…If I check that box it takes N about 4-8 seconds to start. With the ASIO I have not noticed out of synch or dragging tracks like I did last week…Now I have trouble getting Ntrack to start. My work around? If I start 2 instances of ntrack, open task manager and close one of them a box appears saying “error opening midi input device” (just fine as I don’t HAVE a midi input device on the machine…not a built in one or a pci card)…then it loads and runs…obviously there is a bug during start up that freezes if it does not find a midi device :disagree:

Ray

rsolinski
How many processes do you have running in task manager?
(before you load N)
For example I have 19 running after I remove the anit-virus
stuff - which I remove when doing audio rec/play.

On my daw I only have windows xp and a few audio apps…I disable EVERYTHING that isn’t a priority…it is a very clean machine with all the bells and whistles turned off…no anti virus because it is not online…

Ray

Update: I installed a new video card (geforce 6200, agp) and cranked up the display resolution…seems to have fixed the plugin gui interface problems and the popping when I opened a plugin during playback…I still have a delay when I start playback with the latency box checked in prefs but the latest build loads very quickly with no problems…ALMOST THERE! :agree:

Ray

Quote: (rsolinski @ Sep. 02 2008, 12:24 PM)

Latest build (2374)..the previous one (from Sunday) was AWFUL..it froze everytime I tried to register it!..I tried fresh installs, one track, no effects...default settings.., unchecking the "check for new versions", all my drivers..I mean, I went at this for several hours. I does the same thing on both my p4 machines (internet and DAw) that have entirely different hardware..I've been thru so many beta's that I can't remember when it started..This version does stop playing immediately when I hit the stop button which is an improvement over the last few builds..On the internet machine it seems, although I can't be positive, that it got worse when I removed the always on compressor from all the tracks (I HATE that feature..should be an option, not part of the setup)..I would pay ALOT of money for version 3.3 with the volume envelope /plug in/ latency bug and P4 cpu floating point bugs fixed..with the exception of those 2 things my old AMD machine ran almost flawlessly with 3.3..had I not bought the Waves plugs and a newer P4 I would still be using it today!

Ray

That is amazing, I'm not having those problems.

Well…that was about 15 builds ago…everything is where it is now according to my latest post…but that one build a few weeks back was baaaaad.

Ray