build 1707 vst.exe problem

Hey all;

Well, I finally got up the courage to install v.4 of nTrack. I uninstalled 3.3, installed 4, and everything went fine. However, if I try to open up and older (v3.3) sng file, I get vst.exe scan errors that tell me the program needs to be shut down.

Can anyone help?

I’m not sure if this is relevant, but have you copied all your VSTs from the old 3.3 VST folder into the new version 4.xx VST folder? By default, the 3.3 VST directory is c:\Program Files
-Track Studio\Vstplugins, while the 4.xx VST directory is c:\Program Files<b>FASoft
-Track Studio 4\Vstplugins. Of course, if you specified a different N-track installation folder during installation, then the folders above will be different.

Just a thought…sorry if it’s irrelevant…

Tony

Looks like someone else had this problem, too. (See this thread). If the problem persists and no one here can help, I’d email support at support@ntrack.com (you can do it through the feedback form here).

HTH

Tony

Thanks Scantee.
I did copy all my VSTs from the old to the new directory after I installed v4. I checked the “paths” tab in options, and it was still set to the old directory. I changed it, but still get the same error message.

I’ve found that vst.ext just doesn’t like certain plugins. I had this happen a couple times, and I ended up having to pull out a couple that kept making it crash like that.

I think Flavio has to put in little hacks for specific plug-ins, and he probably hasn’t moved over all the ones in V3.3, or the hacks need to be different in the new version (most likely - why blindly put in hacks that may not need to be there?).

Best to report them to Flavio once the offending plug-in has been identified.

I had the same problem, and emailed Flavio about it. Heres the first reply:

I might be an incompatibility problem with some of the VST plug-ins
installed on your system. You can try removing groups of VST plug-ins (.dll
files) from the VST folder as set in the File/Settings/Preferences/Paths
dialog box.
Try selecting the ‘next time do a complete scan’ option in the
File/Settings/Preferences/Paths dialog box.

Got this a little while ago.

What Cpu is installed on your system? I’ve received similar reports from
other users with AMD cpus. I’ve just uploaded a new build (1708) of the
program that has the n-Track multiband compressor vst use a more compatible
AMD code. If you try it I’d be glad to know wether the new build solves the
problem on your system: http://ntrack.com/ntrck_sw.exe


I downloaded and installed the latest build, and all is well.
:D

Cidbil;

Yup - I got the same message from him, and, like you, the new build is fine.

Flavio rules