Builds 2098 and 2099 are stable?

On last little bug

I’ve been running build 2098 of version 4 for over a month now, and I don’t believe that I have had a single crash while tracking. Also, the number of true bugs that have been mentioned on the discussion formum has been really small. Has Flavio really stabilized version 4, or have people that were having problems with stability using earlier builds of version 4 just moved on to other software?

I personally have run into only one real bug in build 2098. And forunately, his bug shows up only when I start manually moving tracks alng the time line. It appears that when you do this, n-track doesn’t properly protect memory, and you can get file corruptions and other problems. If you save the project before you realize that the file is damaged, the damage is tranferred to disk, and becomes permantent. The file may refuse to load next time, or will cause an error on replay. The only safe way that I have found to deal with this is to put away packed file of the entire project periodically when I start this kind of editing. Alternatively you can simply copy all the song files to another subdirectory periodically, and recall from there if things go awry. According to others on the forum, this bug has been around since day one. It is still there.

My point is not to be critical here. Actually quite the opposite. My son also used Sonar. It crashes while tracking with considerable regularity. So if crash-free tracking is what we want we use n-track. Its just that there is this one little bug left.


Nice to hear that you got a stable setup, and N, apart from that bug. Which is very annoying though. Can you tell if you are using any multi-out VSTis? Those are giving me trouble at the moment, or at least I think it’s the problem. I have a multi-out sampler VSTi (Skale) that reserves more than 150MB of memory, that keeps crashing on N-Track. The weird thing is that it only crashes while trying to SAVE the project, not in any other time.

I’ve used the multi-out version of Fruity Loops without crashes, but only on a limited basis. I usually use the non-multi version.


I am still using the latest non-beta version of n-Track, and everything works fine as far as tracking audio and mixing down goes. It doesen’t play well at all with VSTi’s - yesterday I tried using it with Garritan Personal Orchestra, and I had to make a cold reboot to get in contact with the machine again - I couldn’t shut down the n-Track process at all.

I thus took a different approach and used Cubase LE (curses!) for the midi tracks I wanted to do, playing along with an audio premix exported from n-Track. It hasn’t got the ease of operation that n-Track does, but it works absolutely flawlessly with any VSTi, including GPO and Arturia Moog Modular V, which are the ones I primarily use. It is no big deal for me to render midi tracks to audio in Cubase LE and then import them into n-Track, but it would be cool if n-Track was capable of running VSTi’s properly.

I also tried Cakewalk Sonar LE (came with the soundcard like Cubase LE did), and it was a big disappointment. Frequent crashes, narrow-minded asssumptions about the type of music to be recorded, awkward design, and many assumingly easy things very har to figure out how to do, if possible at all. It seems to be primarily loop-based, and that does not suit the types of music I make these days… - Out it went.

BTW, I make a lot of my midi tracks in Voyetra Midi Orchestrator Plus, which is an ancient (circa 1996-97 or so) piece of software that came with a soundcard (surpirise, surprise). Despite its shortcomings, I haven’t yet found any midi tracking program of the same ease and flexibility. In combination with Cubase LE (to overcome the shortcomings) and Overture SE (came with GPO, easy to work with, looks good, and does notation as well), they can do most of what I want midi-wise.

regards, Nils

I’ve had quite a few bugs with N using 2099 the last month or two. I recorded a couple of bands and therefore had to opportunity to put N through its paces.

On a couple song files with a decent track count, 14-16, I am unable to use the panning envelopes. panning a track left result in a decibel increase and no actual panning. panning it right doesn’t do anything. It’s like it switched from panning and just applied the 6 dB boost or something. Flavio wasn’t able to recreate it, but I still have the problem.

On another song file, everytime I open it I get buffering errors and it only loads a couple of tracks. If I reopen it about 4 times I’ll finally have all the tracks displayed but I have to move the endpoints out to see more than 30 seconds of track or so.

Lately I can’t use N-track’s EQ, it’ll crash as soon as I move a band around.

At one point I tried sending some tracks to a group, and then sending that group to an auxillary channel. I ended up getting some phasing issues because the auxillary channel wasn’t syncing. It happened with a few different plugins, Fasoft plugins included.

fo some reason my Wvaes Renaissance Vox plugin doesn’t play well with N-track. It’ll work fine for a while and then randomly after I save the file at some point it’ll crash on playback. I can’t play the song back until I disable the plugin. I have to manually remove and re-insert the plugin in order to use it.

All in all I’ve actually had more trouble with the last couple of versions than before. Unfortunately Flavio couldn’t reproduce my problems and so they remain.

I suspect something is occuring during the saving of my files. Something is getting messed up when I save, then the song file starts having problems. I save a lot to ensure I don’t lose my data or progress, but that has become a problem because of these wierd erros.


The problems you are having sound a lot like the weird stuff that happens when I start moving tracks around on the time line. I’m pretty well convinced that that is caused by some type of memory protection fault. I can’t think of any other way that you would get the variety of apparently unrelated problems you see.

Is there anything unusual about your computer setup or Windows settings that might effect memory use? Drivers, video cards, and background processes can all muck with your computers memory allocation, and if n-track isn’t dealing properly with memory protection (or isn’t passing info properly to windows), almost anything could get messed up.

It might be worthwhile to make sure that you have no unneeded background processes running, although I assume that you’ve already tried that. Maybe check Windows to see how virtual memory is being used. Most websites that talk about optimization say to enable virtual memory and use a fixed-size swap file. Sytem stability can be impaired if it is turned off. And using a fixed size swap file might help with certain types of memory management errors.

The problem is that there are so many things that could impinge on memory usage that it is hard to know how to check it out.


yeah, memory problem might be the cause. don’t know about my virtual memory being to blame though. I’ve got it set with 1.5 X my RAM min and like 2.5 X my RAM max and it’s also running on a separate harddrive as to not compete with Windows and such. I have most of any unnecessary processes turned off.

Driver’s are up to date. My computer is completely stable with pretty much any other program.

I’ve never had a crash while tracking with ntrack. All my crashes have been mixing related, and at the moment, the only two things that make it crash are digital fishphone plugs, and looping, for some reason… (v3.3)

I’m at build 2099 here… It upgraded very well… on my set-ups… No issues in that regard… I have a P-4 machine that the mainboard failed and I’m in the process of rebuilding the software and getting the '98SE desk up-and-running… But for some reason the ASUS P4P 800-SE and 865 chipset doesn’t like '98SE installed on IT… I’m in a BIG Battle with that desk… and the Lexicon drivers… on that computer… and set-up… The 865 chipset may be the bottleneck… The 850 chipset on the P4T-E mainboard worked very well… no issues …

The issue here is not build 2099… It’s getting hardware /drivers to work on the P-4 and '98SE as the desk. and to discover the work-arounds to make the set-up run as stable as IT will work…

Build 2099 on the ASUS P-111 and XP and '98SE desks, works with no issues of any kind…