can't record from Roland

I installed a new sound card awhile back and have not been able to record from my Roland digital piano since. I have it properly hooked up from the piano’s “out” jacks to the soundcard “in” jack and also from the piano’s midi out jack into the joystick port. I have checked the soundcard physically, and through the software diagnostics, and they say it’s fine. I have checked the box in the dialog box in n-track’s midi-settings for “keep devices open” and tried every combination of input and output devices possible. Don’t know what is next. I’m thinking it must be something I don’t know to do with n-track. Help?

Just curious, does the sound card work when other instuments are channeled through it’s line in?/via a mixer of course.
Also have you recently upgraded windows in any way? It’s common to run into problems there as well. If the soundcard is not in the computer when windows is run initially Windows won’t load all the necc stuff for midi, and line in ect.
I’m shure that if you give us a little more info, OS, soundcard brand/series, and which functions do work, someone will be able to help you.
In the mean time you can try to access the soundcards mixer via the preferences box inside Ntrack. From there you can see if "Line in’ is checked or if Midi is checked, inside recording controls.

hope that helps…


jerm

The only other thing I record is mic and it works fine. I tried all available alternatives in the surround mixer for recording sources. What should it actually be on for recording a digital piano? Is it a problem that I have the line in AND the joystick connected at the same time? When I try to record on n-track, it does not even make a track with a straight line through it (as when it is just not receiving the sound). So did I mess up something on n-track in all my efforts to make this work? Everything else with my system and with n-track has been working great.
I have win XP, and Creative Audigy 2 ZS

Without knowing to much about the Audigy series I would say there might be a problem having the joystic(I’m assuming that’s midi) and the line in at the same time. I’d say one or the other. Now I don’t know if your particular keyboard has the proper impedance to send a signal to a line in on a card. Most people I know use a mixer, or some form of pre-amp when using line in.
I know I can mute different inputs on my soundcards mixer and select the inputs I want to use during recording.
I would say try unplugging the line in,
Select MIDI inside the recording setting of Ntrack and see if you get a signal.
Also sometimes the Midi exponants of a soundcards don’t load properly. When I installed a SoundBlaster card it only loaded the Line in/ Mic inputs. The midi functions never loaded…since I don’t use them I didn’t care…but might be worth looking into.
If your intetersted go to your windows control panel and see if there are any new hardware devices showing. That’s how I found out my the midi components of my soundcard were missing the drivers.
Also I would go to www.creativelabs.com and see if there aren’t any driver updates for your card, or any post in the dowlaods areas sitting simular problems with your card and the OS.
Also i will suggest it again…RELOAD WINDOWS!!!
I know it’s a pain in the arse but if you try to install a soundcard after the fact windows is not able to detect it and change your system setting to comply with the cards needs. Shure you will hear sound, since some of the drivers that came with the card will be loaded , but all the neccisary files for Windowes to run midi for example will not be loaded. ( time out of ten if you reload your version of windows the problem will fix itself.

You can also try this to see what is installed on your system.

Start>Settings>Control Pannel>Add Programs> Click on the middle tab (windows setup) this will show what components you have loaded from your OS. If you see a box that is audio related that’s not checked that would be files you might need.




jerm

Quote (ahwander @ April 23 2005,21:08)
The only other thing I record is mic and it works fine. I tried all available alternatives in the surround mixer for recording sources. What should it actually be on for recording a digital piano? Is it a problem that I have the line in AND the joystick connected at the same time? When I try to record on n-track, it does not even make a track with a straight line through it (as when it is just not receiving the sound). So did I mess up something on n-track in all my efforts to make this work? Everything else with my system and with n-track has been working great.
I have win XP, and Creative Audigy 2 ZS

You are trying to record two diffrent things: Audio and MIDI.

First for audio: You need connect your roland audio outs (usually two monos out) to the "LINE-IN" of your soundcard. Optionally you can connect your roland from the "phones" out.
Then in your soundblaster sourround mixer select like record source "LINE-IN".
Go to n-Track and in "preferences">"Audio devices" select like in "soundblaster audigy" (or similar name).
If the record vumeters are on they will move when you start playing with your roland.


OK, go to MIDI:
Well, this is a diffrent thing. Recording midi will not record "audio". No sound will be recorded. It only will record the information about what notes you played, that can be usefull if you want edit later. Disconnect your joystick after turn on the PC (to avoid windows detect it and null the midi port) and then select under "preferences">"midi settings">"midi devices" a valid midi input port (something like sbaudigy uart in or similar). Then select a valid midi-out port (sb audigy synth A). That will rout the sound to the internal sinth of your soundcard. Alternativly you can route it again to your roland, but that's another history.

Well, luck!

Thank you all for your input. So far, I’ve tried it all (except re-installing windows). Nothing has changed.

Marce: "Disconnect your joystick after turn on the PC (to avoid windows detect it and null the midi port) . …"
Am I supposed to re-connect it?

Jerm: I did re-install Creative and downloaded updates there and updates for windows. I used to use line in only for recording from my Roland before I upgraded my soundcard. All my boxes are checked in hardware. Most bxes are not checked in the windows set up but the stuff works. To reload windows, do I have to uninstall it first?

"In the mean time you can try to access the soundcards mixer via the preferences box inside Ntrack. From there you can see if “Line in’ is checked or if Midi is checked, inside recording controls” No I can’t. I can click on “soundcard mixer” from the “View” tab, but then it just disappears. I have to access it from my system start menu.

I keep getting a message—“Multiple channels selected for input/output; select channels on audio format” But I only have one thing highlighted under input and one under output.
Thanks again for your help.
Wanda

With all my adjusting and trying different things for the last several hours here, now I can’t get any sound at all through n-track; can’t play any of my finished work. It is too much to loose. If I go to default settings or re-install how do I save my stuff?
Wanda

Quote (ahwander @ April 24 2005,01:22)
With all my adjusting and trying different things for the last several hours here, now I can't get any sound at all through n-track; can't play any of my finished work. It is too much to loose. If I go to default settings or re-install how do I save my stuff?
Wanda

If you have saved your work, the fact that you change settings or re-install will not affect your saved songs.

Avoid Panic and give us some info to help you:

What is listed in n-Track under "Audio Devices"?

Have you connected your Roland phones jack or audio output to the "LINE-IN" of your soundcard properly?

Have you selected the "LINE-IN" source in your mixer properly?



FORGET MIDI BY THE MOMENT; LET MAKE TO WORK THE BASIC CONFIGURATION OF N-TRACK, and later you can concentrate in midi that is more tricky.
Most bxes are not checked in the windows set up but the stuff works. To reload windows, do I have to uninstall it first?
No, just follow the steps on my last post..
"Start>Settings>Control Pannel>Add Programs> Click on the middle tab (windows setup) this will show what components you have loaded from your OS. If you see a box that is audio related that's not checked that would be files you might need."
This will tell you what components are not loaded for Widows. All sound related programs should have a check in there boxes, under multimedia I think...It should prompt you to insert the Windows disk, when you click apply after checking alll the boxes that weren't originally checked.
No I can't. I can click on "soundcard mixer" from the "View" tab, but then it just disappears. I have to access it from my system start menu
That's still tellin me you have components not loaded which windows needs to be able to display your mixers recording controls. I have spent days, even weeks trying to get soundcards working properly, it can be very frustrating, try not to take it out on the computer! tee hee
Especially when you find out later all you would have had to do is re-load windows! Takes about 45min, of your life, the other two weeks I will never get back! :laugh:
Just slide the disk in, and it should start, if not type in (setup.exe) proceded by the drive # the disk is in of course.... :p

Now if you should find that you reloaded windows, and still have problems, it's alot easier for us to narrow down the feild of possiblities with that one outs the way.
I guess it's Newtons law..if something can go wrong, it will.

good luck

jerm :cool:

I re-installed windows and during installation, it called for ctac32k.sys which I could not find on either installation disk, or creative’s site. I After completing the installation, I tried to get updates from creative again, but it diagnosed my system and said I had everything I needed. I get these messages “Error opening wave driver. Make sure sampling frequency and recording format are set correctly” (They are set at 16 bit and stereo where it directs me to check) “Error opening MIDI in device” Still have no sound and other problems.

1… get n track to run on windows default sound again - if ness pull soundcard and uninstall all SB components -

2… set up n to use windows default sound -

3… when you hear your already recorded tracks - click advanced tab on audio devices properties page - check keep audio devices open - connect Rolands AUDIO outs to the little line in socket on your PC (you may need some sort of convertor plug) -

4… insert blank track audio - make sure you have both RECORDING AND PLAYBACK meters in view -

5… left click on the red dot that appears in the recording meter - set record to the track you have just inserted -

6… click the live button - play roland, record and playback meters should show action when rolands keys are pressed -

7… if both meters work you should now hear your roland from the phones out socket on back of PC -

8… when you get that far then start on the SB again. remember that n tracks mixer is not the final link in the chain, it just supplies audio to your soundcard, if the SB mixer is not correctly configured then no matter what you do in n, nothing is going to come out of the SB unit -

get the audio to work first, then start on the midi not the other way round as midi can be more difficult to implement - before you start on midi make sure that the midi drivers are still installed correctly - you can do this via your control panel - and download a midi test/check program (there are a few available on the net) this will show you that your midi ports are working correctly -

your SB unit may only be a two channel unit, but it may also have S/PDIF outputs, n track picks all outputs it finds and tells you that you have a choice of which to use - when you get the SB right and set to outputs in n to the ones you want to use then that annoying box will not appear again unless you make a change or start a new song -

dr j

Marce;
Under Audio Devices I have:
Creative ASIO
DS Primary Sound Driver
DS SBAudigy 2 ZS Audio [DF00]
MME SBAudigy 2 ZS Audio [DF00]
MME Wave Mapper
SBAudigy 2 ZS ASIO 24/96 [DF00]
SBAudigy 2 ZS ASIO [DF00]
WDM SBAudigy 2 ZS Audio [DF00]

The only one I have checked is the last one (both under Playback and Recording) since I saw “WDM” in the Creative description somewhere in my travels.

I’ve checked my jacks repeatedly, and I have “line in” selected in the mixer (which I still have to bring up through my start-program menu; not through n-track).

I still don’t have any sound at all. My speakers were buzzing yesterday, I will try hooking up some different speakers here in a minute.

Dr Jackrabbit;
I don’t know how to make n run on default sound, but I don’t even get the windows welcome song at this point.

Well, you have two sections in the Audio Devices “in” and “out”:
i suggest you that you start your test with: MME SBAudigy 2 ZS Audio [DF00] (in & out) that is the more “compatible” device, less problematic.

Now, from where are you getting the sound of your Roland? An easy option can be get the sound from your “Phones” jack, using an stereo plug connected to the line-in.

Marce,
I changed audio devices to MME. No sound.
Yes I have the phone jacks to line in.

I did get at least my regular computer sound back., just nothing on n-track now.

Quote (ahwander @ April 26 2005,17:34)
Marce,
I changed audio devices to MME. No sound.
Yes I have the phone jacks to line in.

I did get at least my regular computer sound back., just nothing on n-track now.

Be aware that Audigys support more that two speakers, you need connect your speakers to the right outputs of the soundcard. Can be happen that all is ok and you have your computer confgured for 2.1 output and are connecting your speakers to the deactivated rear speakers. See also in your sourround mixer how much speakers are setted.

Ok it might just be that you haven’t selected ‘Line in’ under the ‘recording’ mixer tab. It is important to remember that this is completely separate from the ‘Playback’ mixer - if you have ‘Line in’ selected in the playback mixer you will be able to hear the instrument through your speakers while you’re playing it, but it will not record.

Try selecting your input using the windows mixer instead of the Creative Surround mixer. (To open it you need to double click the little yellow speaker in the system tray, next to the clock). Click ‘Options’ => ‘Properties’, select ‘Recording’ then OK. You should now see a list of inputs. Select ‘Line in’ and you should be set.

If you can’t see the little yellow speaker, open Control Panel => Sounds & Multimedia (or Sounds & Audio Devices) then make sure ‘show volume control on taskbar’ is checked.

Also those sound cards often also use the inputs as surround/sub woofer outputs. Check your configuration and make sure it is in ‘2 speaker’ mode.

Hope this helps :slight_smile:

Hallelujah! I’ve got it all back. Don’t really know what the problem was. I had installed all the updates for my soundcard twice in the last week, but today they needed installed again, so maybe for some unknown reason my computer was not installing them properly?
Feel like I have my life back again.
Thank you all for your help

Check your settings and write them, look your cables and dont forget them. It will save you for the future.