Cannot record using Asio4All

Says i need 24-bit version of N

i am using Asio4All on a Win XP Comp:

Athlon 64 3000+
512 mb RAM
Asus mobo w/ integrated 5.1 sound (AC97 maybe?)
n-Track Version 3.3 build 1516

Every time i go to use N to record, it says “24 bit recording and playback features have been disabled” and it gives the options of “OK” “Upgrade Now” or “”. When i press “OK”, it will start recording, butabout a minute into the recording, it will come up with the message again, stopping playback and recording. the wavefile ends up just being a giant red bar, no peaks or valleys, but it plays the recorded part back fine.

On the Asio4All menu on the n-Track VU meter, i checked “Force 16-Bit” but it still gives me this message.
Does anyone know a possible solution? Any help is greatly appreciated.



I believe, this is an asio4all thing. I use the same driver with a dman pci audio card. asio4all sets automatically the output to 24 Bit, I don’t know why. So I registered the n-ntrack 24Bit version and now everything runs fine for me.
(The audiocard can only handle 18 Bit says the specification).

i dont have any money to upgrade, but i use A4A for other programs just fine. When i tried to switch back to my old drivers, the sound was real jittery and slow. WTF!!! i think i have seen other peeps with this problem, i will check back later.

Hello swenstrup,

on, there is a new Beta version of the software available 2.0 Beta 2. I don’t check this. I am using the version 1.8.
The new version could fix your problem.

i DL’d the new beta version, but it did not help. When i go to either of the little hammers on the VU meters and go to “ASIO Settings” and try to click on “ASIO Control Panel”, nothing comes up. i tried changing the setting by opening ASIO4All on its own, but the settings dont stay. i tried switching back to my old driving and reverting the buffers, but i still get the “You Need n-Track 24-Bit” window :angry: , even though i was using my AC97 16-Bit drivers. :( :( :(

i think i will try to contact flav, b/c i cant use n-Track for more than a minute no matter what drivers i am using.

i have got the ASIO panel open and set to force 16-bit and resample to 41000. even with n-Tracks “force 16-bit” and A4A’s “force 16-bit”, i still cannot play back the song for more than 40 seconds.

i will email flavio tonight


If you’re using ASIO and your soundcard IS a 24 bits, then 24bit Ntrack will be what you need.
Try using WDM instead of ASIO.

i got the answer, i am just going to use my original drivers. Flav told me to revert to the default settings and try it again, and it works fine now
Thanks Flavio!! :) :) :)