Can't start the program

Hello there !

I just downloaded n-Track Studio 9 and installed it, but when I launch it I’m stuck on the loading screen (cf screenshot).

It doesn’t move, doesn’t use CPU, uses about 32MB of RAM (the amount changes slightly but not significantly) and doesn’t seem to use the network either.

Does anyone know what I can do about that ?

Thanks and have a great day :slight_smile:

Hello Niid,

do you have any USB device plugged in? (HUB, audio devices, etc).

Please try to run the program while holding Ctrl key pressed and check if it opens up correctly.

Should the problem persists, please write me at so that we can better investigate the issue.


Indeed I have quite a lot of USB peripherals (keyboard/mouse/soundcard and a few other things)
I tried to start the program by holding the ctrl key and it worked ! Now I have to work out the kinks of my audio setup, when I try using the ASIO driver of my soundcard, n-Track seem to detect my mic, and I can start a recording, but as soon as I try to stop it it crashes.
Thank you !