clearing groups

over 80 in my song!

So, how’s it done? And how’d they get there in the first place? I never once created a group intentionally. This may be causng my excessive cpu usage? Heck just the mixer for 19 tracks takes over a minute to load on my system, making the total load time about 2 mins after drawing the track waveforms.

:angry:

Thanks,
Rick

Eyup!

Hi Rick, If you open NTrack’s mixer and click on each of the group mixer strip name bars (the bit on the top where it says (Grp)… ) a dialogue box will open and there is an option there to delete the channel.
N sometimes creates these groups when vsti’s are first loaded. I don’t know why and I have only recently noticed this since I upgraded my operating system from Win98se to XP Pro. I can’t remember it happening previously.

Steve

Thanks Steve, but there is no option to delete like there is on an instrument channel. ???

Click the “Group 1” name or whatever you named it in the mixer. When the dialog opens, click “Delete Channel”.

TG

There is no Delete in the Dialog box.

Are you using the same version I am? (4.1 build 1969)

A bug perhaps?

it’s on the right, second button down, under “effects” and above “move ch up” I have the same version. if you don’t see this, then you should probably reset it to default configurations and see if it comes back.

<!–QuoteBegin>

Quote
it’s on the right, second button down, under “effects” and above “move ch up” I have the same version. if you don’t see this, then you should probably reset it to default configurations and see if it comes back.


Nope, ain’t there. It IS there for the Aux channels, but not the Group channels. Other than the Cancel button, on the right there is (from top down) Effects and Output Names buttons. Reverting to default preferences did not help.

I’m bugged!

Guess I’ll have to wait till Flavio gets back. :(

Hmmm… you sure you are looking at GROUP channels?



TG

EDIT** I noticed you said something about VSTi’s. I opened a new song and inserted a VSTi. It failed to load because of a missing or corrupt file… or so the error message said. n-Track went ahead and created a Grp1 channel. The Properties dialog DID NOT have a delete button! I could only wack it with Undo. You sir, have indeed found a BUG! Did you notify Flavio?

Thanks for setting the record straight TG, and verifying the bug. I think you found it because I didn’t really know what was causing it. Good detective work!

Rick

Bringing this up again because I have an acute emergency.
Has anyone found a way to get rid of these ghost-group channels yet?
I would greatly appreciate any ideas as this is becoming a very annoying problem over here!

I dropped Flavio a message. He’ll probably let us know in a few days…

TG

Hey guys? I just tried to repro this again with the latest build 1974. I got a Delete button this time around. Maybe Flavio already fixed it? What builds/version you guys running?

TG

No.
Build 1974 here. And 10 group channels without a delete option.
The undeleteables are left-overs from a 10 channel drumsynth vsti (that was removed from the setup).
Mind you: normal group channels (the ones that you route track-outputs to) do have a delete button.
I really hope for a quick fix for this!

OK hansje. I did send Flav a message to check this thread. Just because I could not repro the problem again in about 2 minutes does not mean it is not there. I guess there is some error checking code missing or awry? When I seen the problem, it was after I inserted a VSTi that for some reason or other n could not load. THAT Group track I could not delete.

Maybe Flav will check it soon… :)

TG

Quote (hansje @ Oct. 20 2005,08:05)
No.
Build 1974 here. And 10 group channels without a delete option.
The undeleteables are left-overs from a 10 channel drumsynth vsti (that was removed from the setup).
Mind you: normal group channels (the ones that you route track-outputs to) do have a delete button.
I really hope for a quick fix for this!

Just a question out of curiosity: Does that explain where all the channels came from? VSTis with multi outs will produce a lot of extra channels. Is that how you ended up with 80?

<!–QuoteBegin>

Quote
Is that how you ended up with 80?

Well, I ended up with 10. It was the starter of this thread that ended up with 80.
But yes, that is one way to get ghost groups.
If you add an instrument channel for a multi-channel synth, n-track will make as many extra (stereo) channels as needed for all instrument outputs.
All these channels will be deleted too, if you remove the original synth channel. The instrument itself though, can also be removed by right-clicking its name in the channel effects box. If you do that, the extra channels will not be deleted but remain as undeleteable group-channels.
So the bug can be avoided, but once you made the mistake, there is no cure. :(

<!–QuoteBegin>

Quote
Well, I ended up with 10. It was the starter of this thread that ended up with 80.


Oops, sorry! thanks for the answer though! :)

I thought I’d resurrect this thread to see if anyone has found a cure for this. I just upgraded to build 1980 from one of the relatively older builds (1811 I think) and I am having this problem with any projects that I used RMIV drum sampler on. I was able to work around the problem in most projects by removing/reconfiguring RMIV and reassigning group outputs. It was all pretty random but it worked for a few projects. One project however seems beyond this, it only shows “group 4” in the output assignment drop down and no way to delete the old RMIV channels.

The only option I can think of is to export the individual tracks and rebuild everything in a new project.:frowning:

I have not heard anything new on this problem. I sent Flavio a message via the support page but no answer so far… :(

TG