connecting piano help

usb port

I recently bought a casio wk-210 piano which came with a free download of ntrack. I did so and can not figure out how to make it recognize the piano. I connect the piano through usb (since it has a usb connection on the back of the piano) and get no response from the program. I am new at this and would appreciate an answer in simpler terms :).
Please Help! and THANKS!

Hi, I found a Youtube tutorial on your keyboard and n-track .

http://www.youtube.com/watch?v=mqmAHZ-f6UY


Midiox can be useful to diagnose midi problems, you could use it to see if the midi information from your keyboard is getting to the computer.

http://www.midiox.com/

That definitely helped… but i still can’t get the program to record the piano. I know the computer recognizes the piano because it has a usb name of CASIO USB-MIDI. I think i just don’t know where in the program to go to add the piano as the source to record. Ive tried settings-audio devices but dont see the usb as an option. But i did see it in preferences and changed that but it still wont record… URG

I also keep getting an error that says:
“error opening wave input device.
Make sure that the sampling frequency and the recording format set in the dialog box that appears clicking on the setting button on the recording vumeter are supported by the soundcard.”

It would be helpful to know what OS you are running.

Windows xp? Vista? 7? and is it 32 or 64 bit?

If your running on Windows 7 64bit you may need this driver:

7-64-bit

Change the hardware ID in the INF file under

[Roland.NTamd64.6.1]
;; Windows7
%RDID0053DeviceDesc%=RDID0053Install, USB\VID_07CF&PID_6802


HEre is how:

Quote:


The ID is after the comma and the one you see above is from the Casio keyboard i
have. The
hardware ID for your keyboard can be found in “device manager”. Just choose your
hardware/keyboard and go to “details” and choose “hardware id” from the drop down
menu and put that after the comma. It will start with “USB” since it is a usb
devise. There may be more than one ID but the first one works for me. Then just do
a manual install by right clicking “computer” or “my computer” and click “device
manager” tab. Then find your keyboard (probably a yellow exclamation mark next to
it) and double click it. Then go to the “driver” tab and click “update driver”.
Then choose “Browse my Computer for driver software”, then “Let me pick from a list
of device drivers on my computer”, then “Have Disk…” and browse for the INF file
you just put the hardware ID in and click “open”.


That’s only if you are on Windows7 64bit.

other than that, we need more info to advise.

You should get the frequency thing sorted too, Preferences> see what frequency the Casio is sending the audio data in (my guess is 44.1k since that is common with USB devices) and set Ntrack to the same.

dontcare

Did the Casio come with a software disk? My Keyboard cannot be recognized by the computer if I have not installed the USB drivers for the keyboard, and if I plug the keyboard into the a different USB port I have to install the drivers again for that port. If that doesn’t work
Your answer may be as simple as having the correct input selected (the icon is on the tool bar - mic. midi. or mic and Midi) or there may be some other settings that we will stumble around for days trying to give you the correct answer.
People Hate this answer, but if you have not checked, I think the quickest answer is to refer you to the Help menu in n_Track. If you click on the Help menu and bring up the help file, then press F3 to open a search box. Type in MIDI. There are several pages of information on using midi. The Help file Should do it, check it out and if the fix isn’t there, this forum is the place to get answers. Honestly, I am trying to help, but we can waste a lot of your time waiting for answers when the answer may be easy to find. :love:
Bax

I guess i just really don’t know what to do. I am running the software from 32 bit windows vista. I checked the frequency and it is at 44100 Hz… I am in MIDI input…and as i said, the piano is recognized as CASIO-USB MIDI. I think I know this because there is also a piano icon in the lower right of the computer that blinks red whenever a press a button on the keyboard. Whenever i go to settings-audio devices… no usb is listed so i dont know if thats a problem or not…but in settings-preferences there is a tab called MIDI settings where a button called MIDI devices shows the casio usb which i chose as the input and output port. I really don’t know if this is on track to fixing the problem, but I hope this gives enough information for a possible response.
Thanks again for any help so far!

My crappy, old GoldStar isn’t recognised but having “midi devices” “always open” sorts it.

My MIDI device is already selected as always open…

Hang on, dman. Just getting my scrambled head round it.
I can’t be arsed reading back.
You checked in the upper tools that the recording mode is set to midi (keys/mic/keys+mic?
And created a new midi track?
Chosen an instrument in the output window of the Track Strip (if you’re only using your keys as a controller)?
Matched midi channels and prg’s - ? “all devices”

Basically i did everything you said except i don’t really know what you mean by:
Chosen an instrument in the output window of the Track Strip (if you’re only using your keys as a controller)?
Matched midi channels and prg’s - ? “all devices”

Just out of curiosity are you recording midi data or audio tracks from the keyboard? or both?

So far we seem to be trying to get you to record the midi data, but it seems this keyboard may also act as a soundcard/interface?

Click the little hammer on the recording VU meter in Ntrack and see what is set up as the source for recording incoming audio (my guess is soundblaster or whatever is on your system).

What do you see when you click this chain?

Settings>soundcard settings>Recording format>

(check to see if “enable live input processing” is checked) Click Select I/O channels, see if you see Casio USB in there.

Does it say “Casio USB” above your hammer on the Recording VU meter?

Alternatively you could record your part on the keyboard, then Open Ntrack and import the midi file off the F: drive (USB devices generally show up as F:)

What TOny is saying is if you are setting up a midi track to receive data from your keyboard when you start to record, you could in theory set that track to be playing one of the standard GM sounds on your computer by double clicking the track, properties will show up on the left and you can select a “bank” to use instead of the sounds on the keyboard being heard through the computer the sounds you select on the computer would be heard.

dontcare

Hi, I think there might be confusion here between Midi and Audio. If you record Midi information from your keyboard into n-track the information is not sound it is just data to say which key you pressed when you pressed it and how hard (volume).

When you view the midi information in the piano roll view it will look like this.

http://www.generativeart.com/on/cic/papersGA2006/31_file/image003.jpg

In order to hear any sounds you then have to get the Midi info to play some sort of synthesiser either a so called “soft synth” or a windows GM general midi synth or an external Midi sound module.

Your first step should be to see if you can record some Midi information to a track even if you can’t hear anything at the time. Then once you’ve recorded it experiment playing back that track until you can get the Midi to generate some sounds.

n-Track comes bundled with a few vst instruments inc’ strings and drums.