CPU Usage in different builds

Hey guys this is my first post here! Here’s my problem: I started my most recent project on an older build of n-Track 4.0 (it was 16-something). I have 14 tracks (13 wave files) and countless effects all over the place (gates and comps on some of the channels, 2 instances of Drumagog for drum replacement, 2 aux busses with different reverbs, and a couple master channel effects like compressors, a limiter, and an analyzer). This ran very nicely on my Pentium 4 @ 2.4Ghz with 512MB of RAM, I’d say around 40% to 60% in general. The other day I upgraded to build 1776 and I’m looking at an average of 75% to 95%. It still manages to do a real-time mix (a.k.a. playback) except for parts that have volume/pan drawing. Even when the volume level isn’t actually changing, whenever it’s not at 0 it uses quite a bit of CPU… enough to make the playback horribly unstable. For example one track has a 30-second section drawn down to -Inf, and this creates a problem as well.

So do the newer builds have a different kind of processing that uses more CPU, or maybe a different volume-drawing algorithm? Nothing is different about the rest of the running tasks on my computer, because it was basically a side-by-side comparison when I upgraded.

-Mike

Hi Mike,

Can’t say I’ve noticed but them I haven’t done much with volume evolutions on the last couple of builds. Perhaps you’re on to something.

It may be a combination - a particular plugin AND volume evolutions for example. I know for a fact that OBtune, for example, starts eating resources on tracks with lots of splits/parts.

Perhaps Flavio had to re-write a chunk of code to get around the recent memory problems and it’s not quite as efficient as before. If you can track it down to something specific let us (and more importantly, Flavio) know.

And welcome to the forum.


Mark

oh, and as a temporary measure you could try using the new Freeze function to save a few CPU horses.

Hi,

I too have problems with cpu usage.

For those who are using the Audiophile delta 2496 soundcard I thought I’d mention the discovery I just made.

I thought I’d update the soundcard driver and when I did I found that the cpu usage on my current project went up from a max of 63% to 93%. So I went back to the old driver and the usage went back down again.

I wonder if there has been a trend for “new” drivers to use more cpu as cpus have got faster? Not surprising I guess. However, if the old driver does the job ok then we may be cutting off our noses…

Can anyone suggest any other drivers that we’re using that could yield additional cpu for n-track in this way?

Mike F

Hi Mike F,

Which OS are you using? Could you please post the revision numbers of those two audiophile drivers. Sounds like this could make a big difference for those of us who use that card.

I hope N becomes more efficient and stable in the near future. It does have almost everything I want…

Thanks,
TrackGrrrl

I just changed from a tascam 428 to a delta 66 with omni set up. The same songs that were use 35% of my cpu are using 80-90% now. My machine is slighty older and running 2000 pro. No other changes than the sound interface. Does anyone have an idea what in the &$^%* is going on?

It’s probably because of the buffer settings. Try twiddling those and see if the CPU usage changes.

I think this is a problem that really needs to be addressed. Honestly…its just annoying. Yeah, yeah, the freeze function is cool and all, but stability comes first in my book. CPU usage shouldn’t jump the way it has in version 4. My 12-track/30% CPU mixes from 3.3 are up to 60% now in V4, and I’ve toyed with settings all day to no avail. I love this program very much, but a CPU hog makes a worthless tool when your serious about recording. I went back to 3.3 last night after much agrivation. I hope Flavio gets this all ironed out because I love Ntrack. I’d hate to see N develop a bad rep, which is what has been happening as of late…lets be honest, newbies pop in here asking about stability and CPU usage problems because they heard about these problems on another forum and such. pissant>>>CB

I may be wrong but… are you sure N-track is really reporting the cpu useage properly?

I noticed that my cpu useage went up 2times as big when i turned off hyperthreading, so I put it back on and the cpu useage went down 100% Well thats fair, so I went and looked
at the application cpu useage in winxp(with hyperthreading enabled) and noticed that N-track was only really using 1cpu anyway…suddenly it didn’t make sense.


regards

Quote (stormboy @ Mar. 11 2005,07:06)
I may be wrong but... are you sure N-track is really reporting the cpu useage properly?

It seems to be reasonably close on my Win 2K Pro machine in comparison to the Windows CPU usage meter, assuming N-track reports only it's own usage and not that of the whole system. The difference is just about the %age Windows reports without N-track running.

Tony

I remember we had this discussion several years ago with other builds when I was logged on as a different user. Right now I’m using build 1788 and CPU usage not that bad. I noticed the CPU usage jumps when I move the N mixer panel. I remember CPU usage was such a pain for most people that it caused N to crap out. What I would do to keep the CPU usage down is I selected a track with effects and bounce that track down. Then in the original track I would mute and disable the effects which in turn free up the CPU.
If I’m not happy with how the bounced track sounds with other tracks I would go back tweak the original track then repeat. That was my method and it worked well for me. I got this idea from a mixing engineer that had this problem with pro tools. Anyway this is just my suggested method I don’t expect anyone to try it,but I figure this might help someone out. :D

The new “Freeze” function in 4.04 is basically a one-click implementation of what you’re talking about, archon, no?

Tony

you are right,but I meant on older setups at the time before the freeze function. Sorry I should have been more clear on that.

I thought that’s what you were saying…thanks for the clarification :cool:

Tony

No problem. I still use that method cause it’s second nature to me.:smiley: