Crashing

?

Sort of a newby here. I used to use n-track a little bit a few years ago but did not get very indepth even then. I need to start using it more often now and still have it on my computer.

Problem is; Almost anything I try to do the program locks up and I get the standard…

"ntrack.exe has encountered a problem and needs to close. We are sorry for the inconvenience."
The Error signature says "AppName: ntrack.exe, AppVer: 3.1.0.0, ModName:ntrack.exe, ModVer:3.1.0.0, Offsett:00074f37.

My version of ntrack is 3.3, build 1516, XP Home Edition with latest service packs (I think it’s SP2 or something like that)

Even when I try to simply close ntrack I get the same lock up, End Now? window.

I used the support e-mail link where I filled in all the info but no reply for over a week.

Appreciate any help.

I suggest uninstalling n-Tracks and reinstalling it if it’s been a long time since you ran it. Make sure you have your original install exe amd reg keys handy. Also, clear out the VST folder temporarily. There might be a bad plug-in in there. You combination of OS and n-Tracks sould work fine, unless there is something else getting in the way. It’s had to tell what might be the problem might be, but the times the crash is happeing is when n-Tracks reads and writes its config files. If one of them is corrupt that could lead to the kinds of troubles you are having. Generally, any time hardware is changed n-Tracks needs to have its config file manually reset.

I do change hardware in other programs. By that I mean I might switch my midi input and output driver/s around from soft synth to USB powered synth module to USB powered Edirol controllers’ midi output to a DXi synth and sometimes a MidiSport 2x2.
Do you think maybe there is a hardware conflict with that stuff and one of my other programs that is using a midi driver at the time I open n-track? I’ll try un-assigning any midi drivers and audio input devices from my other programs before opening N next time.

Also, I did install a sound card and a second hard drive possibly between the last use of N. Could that be a problem?

When I filled out the support form I did ask if there was somewhere I could get the latest free update in 3.x but I have not gotten a response. Do you know where I can download the latest 3.x version/build for free since I have 3.3?

Tobias,

Do yourself a big favor and stick with 3.3. It is the best of N track. 4 will probably cause you lots of problems- more than this lockup.

XP is not the best platform for N track but it should be basically problem free.

I suggest downloading 3.3 again, uninstalling your current version and re-installing the newly downloaded version. That should settle the matter.

no cents

It’s funny how we all seem to have different experiences here… My advice is the exact opposite of nocents… v4.0 is working out much better for me than v3.3 ever did. Also gotta disagree with the XP comment; a clean install of WinXP pro dedicated to nothing but n-Track is the way to go. Works for me, anyways.

Guide to setting up winXP on your “recording” installation of Windows:

http://www.musicxp.net/

-John
:cool:

I’ve found ntrack 3.3 to be less stable AFTER a clean install of XP/SP2 (made a slipstreaming cd which installs sp2 at install). I had SP2 on previously too, but the machine seemed to run better.

Willy.

nocents bases his experience on a machine or machines that have obvious problems that n-Tracks may bring out or be victim of, but otherwise are not necessarly caused by n-Tracks. His experiences are in the minority of uers, though his problems are real and need addressing somehow. The problems he’s having may not can be fixed in n-Tracks, but that’s a hard call. It could be that the rest of us are very lucky.

<!–QuoteBegin>

Quote
XP is not the best platform for N track

This is just not true. It may be true that WinXp is not the best platform for the particular hardware in your machine, but that is a driver problem. WinXp is the best platform for nTracks if you don’t count driver issues, a since n-Tracks doesn’t install any drivers it’s comparing apples to lugnuts.

<!–QuoteBegin>
Quote
Also, I did install a sound card and a second hard drive possibly between the last use of N. Could that be a problem?


Yes, physically changing hardware around can cause n-Tracks to do funny things, though not usually what you are experiencing.

n-Tracks creates a list of the audio devices and stores it in the n-Tracks config. It uses this list when you select the desired devices to us in the preferences. If you change hardware, and that includes plugging in or removing any audio USB device, then the order of the devices may be different. There is no guaranteed order of devices in windows. Once that order is changed, even temporally, n-Tracks may need to have the prefs reset.

Manually selecting different devices in other apps won’t cause a problem.

The last V3.3 build posted was 1516. Do you have the install exe?

I get N-track crashing if I try to change the knobs on a VSTi, or VST when I don’t have instances of all the plugs I’m using opened…This happens totally consistently and it’s always been like that since I used N-track. So, If I wan’t to edit a
VSTi setting I must make sure to open all the VSTi’s and VST’s I’m currently using in a song, usually I just make them very small and stick them somewhere where they don’t get in my way. I was going to ask about this aspect but, so far it’s easier just to tolerate it.

regards

Yes phoo, I think I have the 3.3 1516 install exe somewhere. I’ll try to dig it out. Do I need to fully uninstall first or just install on top of the old one?

Just in case, as suggested by John, where can I get download of 3.3?

Last night I tried changing the input/ouput drivers in N (both midi and audio. Well, I made the changes then the dialog would not even close. I tried everything the ctrl|alt|delete and I back at the “END TASK” dialog and poof…desktop.

Man, I know this is a great program and I loved when i was noodling with it before. From what I’m gathering, I need a reinstall before coming back with more questions.

Gotta go, must work, thanks for the suggestions.

BTW, I haven’t had time to browse the other thread but, where’s Flavio? ???

For the previous versions, just go here:

http://ntrack.com/__old_download.shtm

Build 1516 is there and it is VERY stable…

You could probably just install over the existing installation, but considering the problem you are having it might be good to try the uninstall. Depending on how hosed the setup is uninstall might not work. That’s not a huge major problem. We can deal with that if we need to.

If you have the same problems after getting everything restored there could be something else going on. Do you see any devices in the list that aren’t currently working on the machine in other apps?

Alright, I think i forgot to mention that upon opening N I was getting a [Unable To Open MIDI Device] dialog on initial opening. Well, uh, i think that was happening ever or most of the time.
Finally, after switching my midi input/output drivers around and fighting with the lock-up every time I made a move I think I got enough changes in between the crashes that now it seems to be holding together just fine. Not crashing at least for now.
I was able to get through most of a piano roll drum grid edit ( too tired to finish ) save it, close program, no crash. Yeah!
I think the other thing I did was make sure that every midi drive listed as available in the midi preferences was ON and ready before opening NTrack.
I’ll check in the morning to see if it’s still good.

Thanks for the help.

The Unable To Open MIDI Device usually happens when the MIDI device in the preferences is set to MIDI Mapper and-or the MIDI device in the metronome is set to the MIDI Mapper. The reason is that the MIDI Mapper blindly points to one of the named MIDI devices that has been selected in Windows Control Panel (for example MPU-401 - n-Tracks has no idea what this device maps to). If that named MIDI device is selected in the MIDI preferences then it will be opened when n-Tracks is run and any calls to open the MIDI Mapper will fail. When the metronome tries to open MIDI Mapper it fails since a second instance of MPU-401 is being attempted – n-Tracks treats them are different devices. The fix is to never use MIDI Mapper. It’s ok to use MPU-401 in both places, or different named MIDI devices that are truly different devices, except MIDI Mapper.