Delay Issue

Problem with Drivers

When I use ASIO or WDM drivers, I get a long delay with sound. When I use the MME or Directsound drivers, I can lower the buffer settings and there is no delay, but it sounds horrible. Is there a driver that I need to download that I don’t have, or do I need a new soundcard altogether. I’m currently using surround sound SB Audigy 2 ZS Audio [D8CO]. Also how do you lower latency, I can’t find that option.

Have you tried the kK project drivers? They solved all my problems with the SB Live cards, and they are supposed to work with Audigy2 cards, too. It’s a complete replacement for the Creative drivers; I’d recommend reading up on them before taking the plunge, but I’ve found them totally indispensible. They let you re-wire and re-route signals at will within the soundcard with amazing flexibility.

http://kxproject.lugosoft.com/index.php?skip=1

{EDIT: The following paragraph gets it wrong – see below for a proper explanation of latency… PR}
As for the latency question, I’m just a newbie, but I don’t think there’s a knob to lower latency – it’s a sum total of your computer’s ability to process everything you’re asking it to do in the time allotted. If there’s too more going on (too many tracks, too many plugins, etc) than your computer can handle, then there’s a greater lag between your input and the time it actually gets recorded.

Try “freezing” tracks that have a lot of effects on them, deleting or temporarily removing tracks you aren’t actually using, and/or mixing finished portions of the projects down to a single wave file.

Good luck!

PR

<!–QuoteBegin>

Quote
it’s a sum total of your computer’s ability to process everything you’re asking it to do in the time allotted. If there’s too more going on (too many tracks, too many plugins, etc) than your computer can handle, then there’s a greater lag between your input and the time it actually gets recorded.

This is a popular misconception.
I’m glad someone explained this to me one time, so I’m gonna risk sounding very pedantic and try to explain it to you.

Latency in general is the time sound is delayed when travelling from your soundcard input through your DAW to your soundcard output.

Part of the total delay is caused by the soundcard hardware. There is usually nothing you can change about that.
The rest of the latency is caused by the software (drivers and applications).
This software latency is due to the fact that programs process the audio samples in blocks. These blocks are called buffers.
The delay introduced depends only on the size (and number) of these buffers.
No matter how small or big these buffers are, your computer has to be able to do all computing it needs to do for one sample, in the time between that sample and the next one (e.g. 1/44100 sec).
If it can’t, you’ll get major glitching as the computer will have to drop samples to keep up with the flow (because the samples keep coming, 44100 per second, no matter the size or number of these buffers!).

The main reason why working with low latency settings is heavier on the cpu, is that your computer is doing all sorts of other tasks as well and has to switch tasks more often with small buffers than it has to with bigger ones.
The chance it cannot complete processing a buffer in time, because of one of these other tasks, also increases with smaller buffers.
This will cause incidental glitching.

If you’re using wdm drivers, you can set the buffer sizes in the settings dialog.
When using asio drivers the setting must be done in the soundcard’s own asio control panel.
You can usually access that one via the little hammer symbol under the rec/play vu meters.
Low latency settings aren’t possible with mme or direct sound drivers.

Just to add to hansje’s already excellent post… buffers too LARGE can cause glitching, pops, etc on many systems in addition to introducing more latency. There is a happy medium you need to find to get things working glitch free. Trial and error is the only way…

D

Well, I stand corrected. Thanks so much for the clarification.
As I said, I’m new to this, and I clearly have a lot to learn…
Thanks again.
PR

Good explanation, Hansje – mind if I post that in the Wiki?

Quote (learjeff @ Dec. 12 2005,19:18)
Good explanation, Hansje – mind if I post that in the Wiki?



I was just thinking the same.

Not at all!

Edit: I don’t mind (at all).