delayed recording

I just started recording a new song on sunday, and from the second i started, everything that i recorded was delayed. I would record the instruments right on time, but they would show up around 2 1/2 beats after they were supposed to, and the delay time would never be consistent. I have no idea why my computer started doing this, and i looked into just about everything i could think of to fix it. If anybody has any ideas or anything to help me out, that would be very much appreciated. thanks.

There’s a few things to check. Toggle the settings of theses, one at a time, to see if they change anything.

1) Keep devices open - That’s in the Audio Devices Advanced preferences.
2) Use system timer for - Usually uncheck for both Playback and Recording time. In Preferences Options.
3) Start recording at the very beginning of the song. Some systems (like mine) will result in track being out of sync. Some systems don’t have this problem at all.

Thanks for the suggestions, but i tried all of those things and none of them fixed my problem. the first two things were already checked in the preferences as default. And i’ve never had a problem with recording starting from the middle of the song before, but i tried it just in case something changed, and that didn’t work either. does anyone have any other suggestions?

<!–QuoteBegin>

Quote
the first two things were already checked in the preferences as default

Did you uncheck them to see if there was any difference? The default isn’t always the best, even if it was that way before…especially the system timer setting.

Anyway, toggling them could flip the settings. We have seen (very occasionally) a bug where the setting displayed are what they actually are. Switching them, then closing and restarting n-tracks, will reset them. I haven’t seen these display incorrectly though.

AND… :) …reselect your inputs and outputs. I have seen these get messed up.

One other thing to try is to cold reboot you machine.

The Audigy 2 on my work machine will occasionally get in a state that is funky at best. Warm rebooting won’t fix it, but turning the machine completely off for a few minutes will. That forces the soundcard to power down completely and reset. A warm reboot doesn’t power down the cards enough to force a hardware reset…depending on the hardware.

That’s true of cards other than sound cards too. It’s very hardware specific.

Hey I tried unchecking the ‘keep audio devices open’ box, and it made everything go back to normal when I record! Thanks a ton! But will unchecking that box have any effect on other aspects of recording where I would need it to be checked?

There’s no “need” to keep it checked, period, unless something is funny when it’s not checked. It’s an option to use or not use, depending on what works best…sort of.

What it does is cause the input and output to be opened when n-Tracks is first run. They are left open while the app is running. Doing that can prevent other apps from being able to open them while n-Tracks is running (maybe can’t run n-Tracks and a wave editor at the same time for example). Another reason to use it is that the devices are already up and running. This is suppose to help startup performance a little. and it does cause a little less time to be taken between when the play button is clicked and where n-Tracks starts playing.

When it’s unchecked the devices are opened and reopened every time the play button is clicked, and closed when playback is stopped. That seems inefficient, but it’s not much of a deal unless the soundcard has some kind of device open issue.

Some older soundblasters take about 50 milliseconds to create each hardware buffer, and the soundcard will lock the PCI bus for 50 ms every time another buffer is created. That can cause problems for some apps on some systems. Most soundcards do the same thing in MUCH less time, like 1 or 2 ms, or less. Those particular SoundBlasters can cause any currently playing audio to glitch…that’s pretty ironic if you think about it. Most soundcards don’t do things that CAUSE audio to glitch. That’s something that should be left to video cards. :)

The short answer is that it’s not suppose to affect anything else. Do what works for your system.

Ok, well thanks for all the info about that, i never knew what it did until now. Thanks alot for all your help with my weird delay problem too. You’ve been alot of help.

Miles

oops…wrong thread…sorry

cliff
:cool:

Hello

I got the same problem, been into settings cant find the “Audio” bit that people talk about can some one tell mw how to access this.

each time I pree the “Live” button I get the delay I’ve try to reduce the buffer to “Low” but its not helping.

is there a way of being able to listen to what you record other than the “Live” button.

I.ve tried all week to get rid of the delay but will admit Im ready to give up and rip out n-Track I though a brand new PC would be ok or am I missing somthing.

Im used to working with my Korg D1200 and thought computer based recording would work seems I wrong.

Help please

and thankyou

budgie :( :( :( :(

Budgie, got to Prefrences, click on Audio Devices, lower right hand corner click on Advanced, un-check “Keep Audio Devices Open”

ooops, sorry bout that, lower left hand corner, jeesh I wish we could edit these posts!

budgie I’m not sure I understand your post.
1. Are you hearing a delay as you play live? (you play and hear it delayed live)
2. Or is it recording the wave file delayed (out of sync with other tracks)?
These are 2 seperate issues.

Thanks Yaz

I will try, did look for it last night I found settings but thats about it.

will give it one last go.

thanks

Budgie :(

Don’t give up budgie, there are some extremely smart people on this forum. I’m pretty much a novice with 'puters and soundcards.
I’m sure someone will figure out your problem. :)

Ok yaz

here is my problem

Im used to using Digital recording systems but as I got a new PC I loaded n-Track as I was told that it was top dollar.

I pluhed in my guitar via the input on the front of my pc at first I could not hear anything unlil i clicked on the live button this is where the problem is.

I hit a note and I hear it milli seconds after later, somone told me that its "Buffering"

waht I would like to do is record in realtime and hear in real time, surly this is possible.

I admit Im not a wizzard with a PC, its not a track sync issue all I want to be able to do is record a few trcks but at the moment I cant even do that.

I think its a latency delay, perhaps there is another way to monitor yourself while recording.
my pC has lots of memory so I know theres not a problem.

I just kinda feel a little disapointed at the results of N-Track but I no its my fault its not working how it should
not being a computer buff dosent help but I understand the basics, trying to find the Audio bit ect takes somone like me a liitle longer so sorry to be a drag.

I appreciate your help
and avice as I do with all who contribute, perhaps I will master n-Track or return back to my digital domane.

Best regards

Budgie :(

OK, sounds like it’s not nTrack but the soundcard set-up. If you could give us info on pc, operating system, soundcard, what driver you’re using, wdm, asio, wave. Asio is probably the best driver for audio recording.

Do you go straight from guitar to PC? If so, you’d better have a soundcard that can handle the weak signal. Don’t use no line level or mic inputs.

Anyway, the latency you’re experiencing is a buffering problem, not an n-Track problem.
Answer the questions above re OS, soundcard, drivers etc and somebody wise will most likely pipe up :)

The amount of latency that you will have to tolerate is a function of several things which affect the size of buffers that must be used. Small buffers = low latency. Some people are able get by with less buffering if they switch to ASIO4ALL ASIO drivers for their soundcards. But the recording software and the complexity of your recording (number of plugins, tracks, etc.) also affect the size of the buffers that you will need for recording your project. The basic rule is that anything that taxes the CPU will result in a need to increase the size of buffers. So try to do your live-monitored guitar work before you throw in zillions of effects and tracks. Also, decreasing sampling rate from say 96 kHz to 44.1 kHz will allow you to use smaller buffers and reduce latency.

If you do enough tweaking, you may be able to reduce latency so that it is not a major distraction, but it is impossible to eliminate it completely. Personally, I avoid the whole issue of latency by monitoring the guitar signal before it is routed to the recording software. Some soundcards allow you to do this via the headphone jack on the card (usually called zero latency monitoring in their literature). Because I use a mixer in front of my sound card I can also monitor via the headphone jack of the mixer. Depending on what you are recording, sometimes the lack of effects in the monitored signal can make it hard to get the feel of the music as you play. On occassion, when I wanted to use direct input and do all processing of my guitar post-recording, I have run the monitor headphone signal through my guitar effect processor, and monitored the post processor sound via the processor headphone output. Thus, a clean (unprocessed) signal is recorded, but you hear an approximation of the final sound as you record. This is especially helpful when the sound you are aiming to achieve eventually is highly processed.

As Teryeah says, folks will be able to give more specific suggestions if you can provide more detail about your setup.

T

Thanks to you all
I will find out what card I have and if need be will upgrade.

at least Im getting good advive.

Budgie