echo in n

just got 4.04 up and going but have an echo,What do do to get rid of it.
Thanx Litmus

Ok so i figured out its the live imputing causing the delay,i lowered the buffers as low as they would go with out scewing it up, but theres still a delay,ive just got a sound blaster in there so thats probaly not helping tomarrow im getting a delta 44 do you think i can get it to go away with that,I really want to be able to use the live imputing

Thanx Litmus

There will always be latency with the LIVE input.
If you are using fx it will depend on the latency of the effects.
ie. even if you have low buffering it will be the fx, not the soundcard that will be giving you latency.

Some fx have more latency than others.


Wow that really bums me out. well ill just have to deal with it.

Thanx Litmus

Latency has always been a problem, Litmus. That’s why many of us use the Inserts on our mixers to feed our sound card and monitor both existing tracks and new tracks using our mixers.


KX Project Drivers will let it go as low as your SB will allow, and the drivers on the Delta44 will allow pretty low latency as well.

You’ll get close to almost realtime.

It’s a just a little daunting fiddling with the delta’s control panel the 1st time.

Good luck !


Edit : Maybe you’ve anwered this somewhere else, so sorry if the question is reduntant: Do you use plugins that require you to monitor in Live mode, or could you just switch liveinputprocessing off and monitor clean (and hardwarewise) ?

When i record guitar i want to use one of my plugins.


I can record a track with virtually no noticeable latency with LIVE input. it depends on your sound card really.

if you record at 48 khz with your soundblaster, you’ll avoid the downsampling it does to achieve 44.1-the soundblasters ALWAYS run at 48khz, and any other frequency you choose, it downsamples from their, creating extra latency.

your delta 44 should help. you’ll need to try and use ASIO drivers if it has them-those will be the fastest.

Depending on what plugin you use, (reverbs are pretty software intensive) you can use it LIVE and barely tell there’s latency.

Ok so that sounds great,but how do i make it record at 48 khz,
so that it dosnt downsample. Im not sure how or where to configure my sound card

Thanx for all your help

Set the sample rate to 48khz in the n-Track preferences.

Another solution (which is how I record a dry guitar signal) is to get a DI box.
Plug you guitar into the DI box
Run the balanced out of the DI to you mixer/soundcard
Run the thru (or direct link or whatever it’s named) to your amp/effects unit etc.
you can play and monitor the guitar with distortion/reverb/whatever effects you want and just record the dry signal coming out of the balanced out of the DI.

Then you can play with the sound later - either using plugins or even output to an amp/fx box.

That will get rid of any latency issues as you will be monitoring the guitar sound coming out of the amp/fx box and not needing it to be processed by n-track and a plugin.


Yeah – there’s always some latency. But, there’s always some latency using a guitar amp too, about one millisecond per foot between the speaker cabinet and your ears! Most of us are at least 5 feet away, so obviously we can stand a 5 msec latency.

In most cases, you should be able to rig your system for low enough latency that you don’t notice it.

First, you need to use the right drivers, either ASIO or WDM. Both can do the job, though some folks have more luck with one than the other. ASIO is usually easier to set for low latency: just pick it and it’s already pretty low, low enough for many folks.

First, make sure you’ve installed the best drivers. I don’t know the drivers for Soundblasters, but I’m sure someone here does. Something about KX and some other kind depending on what you’re doing. Don’t run the drivers that came with the card or computer, download the latest from the web. Stay tuned so someone will post which & where, and if nobody does just search or else post a new question about that.

To pick the driver type, go to Preferences -> Audio Devices.
BTW, sample rate is right there in Preferences.

With ASIO, you control latency in the driver’s control panel. You can get there by clicking on the hammer under the recording meters.

With WDM, you control latency by adjusting the buffer setup in n-Track’s Preferences -> Buffers. I suggest you try ASIO first.

For soundcards that don’t have ASIO drivers, there’s a one-size-fits-all one called Wushell’s Asio4All, which works great with things like built-in soundcards.

Thank you so much,that fixed right up. This forum is awsome.

Thanx Litmus