Effects sliders have no effect?

Effect presets work, sliders do not


I’ve spent a bit of time on this and can’t see any reason for it, so I wanted to post it to the forum.
I have the latest nTrack studio for Mac (2.1.0), and it seems to work well.
I don’t do anything extravagant with it, so it seems to fit my needs.

Recently, I did some things with the effects plug-ins, and none of the sliders on any effect changes anything - numbers in the effect window, the sounds the effect produces - nothing.
The only way to change an effect is to use one of the presets in the drop-down box.

For example:
the ‘Pitch Shift’ plug-in has a slider; it does absolutely nothing.
I can move the slider around all I want, but the numbers to the left do not change, nor does the sound change.
If I pull a preset from the drop-down box, the numbers and the sound both change.
I’ve tried a few different plug-ins and they all seem to behave this way - the sliders do nothing at all.

I’ve tried these in both the 32- and 64-bit versions of nTrack with no difference.
I’ve also tried this on a Mac Pro running Lion, and a Macbook Pro running Mountain Lion; no difference.

Is there some setting I’m missing?
A “ignore all slider positions” switch somewhere?

Any help is appreciated, and thanks!

- Fred

I know this might sound like a silly question but are these midi tracks or audio tracks?

Not silly at all, I simply missed that detail.
These are plug-ins for audio tracks.

The sliders certainly LOOK like they’re supposed to do something, but they don’t. For example: reverb settings like room size, wet level, early reflections - none of them do anything. The sliders move, but no levels change.

is it just Ntrack effects not working or are third party pluggins also ineffective?

if it’s only Ntrack effects, I would say a bug report is in order, make sure to include the build number and OS you are using.

sometimes in new builds unexpected bugs like this come up, the temp solution is sometimes to go back to a previous build till the programmers get it sorted.

if third party plugs are also not working (there are a lot of free ones on the net to try) than it could be OS or system related.

I’m sorry I am not familiar with Mac, or the Mac version of Ntrack so I can’t answer whether or not there is a setting to ignore slider input.

Ok, I was being a bit facetious with the “ignore slider input” comment. I’ve been through all of the nTrack settings and don’t see anything that would prevent the sliders from working, but wasn’t sure I was looking in all the correct places. Like maybe having to tweak a plist file to allow custom settings or something.

I haven’t tried any third-party plug-ins, but I will try that later. No, this is only happening with the built-in nTrack plug-ins. I did open up a bug report, but was hoping someone else had seen something like this.

I can’t imagine how it could be related to hardware or OS since I’m trying it on two different hardware platforms and two different OS levels. Still, weirder things have happened, I guess. It just seems like a strange thing not to work because of some OS conflict. Garbled sound maybe, or problems recording - I could see that. But everything working except the sliders? Seems like a setting or a bug to me.

- Fred


we have reproduced the problem with the nEfx plugins on the latest version of n-Track for Mac. The problem will be fixed in the next build which will be online early next week.
Thanks for reporting the issue and sorry for any inconvenience caused by the bug.



No inconvenience at all, thanks for looking into this. I was more worried that I was missing a simple setting.

Let me take the time to say that I hadn’t used nTrack for quite a few years and am thoroughly impressed with the latest version. It’s quickly become a go-to app in my workflow. Nice work!

- Fred

Quote: (GablickFL @ Aug. 13 2013, 4:30 PM)

I was more worried that I was missing a simple setting.

the thought you had which you said might have been facetious was not without merit,

there are settings in the PC version for controlling things like sliders or other FX parameters remotely from an external source (like a hardware midi pedal/trigger or pot/slider).

I don't know if Ntrack ignores the mouse movements, or will, while such an external device is controlling it or not tho, but it was a possibility worth exploring if such an "off" setting existed.

as I mentioned before you could try and go back to a previous version from the download page to keep working till they upload the update that fixes the bug.

good catch btw! they rely on people like you each time they add something new to the program if it causes some adverse effect.