error opening MIDI in device

Stupid error

I just got an external 24bit Soundblaster Live card and upgraded N to the 24 bit version. Now every time I try to record, I get this error “error opening MIDI in device” I can still record, but it’s bugging me to no end. I already tried messing with the metronome settings, and teh midi settings… nothing seems to work… I did notice one fishy thing though… In my MIDI devices properties box, the MIDI output port has 3 devices listed, but the MIDI input port is completely blank.

SB Live should have midi in and outs showing in the n track preferences.
What are your 3 outputs?
From memory they should be
SB Live midi port
SB Live Synth A
SB Live Synth B

or similar.

The input option should be SB Live midi port or similar…

Do you have an other applications that use the midi ports that you can test them with?

Does the midi port show up in the control panel?
If not try re-installing the driver

also try ticking/unticking keep midi devices open

That’s all I can think of right now…

HTH,
Rich

Jay Jay–

Also remember that the “Keep devices open” checkbox in the MIDI settings could not be cleared in some earlier 4.0x builds–don’t know how far back, but I’ve seen it in the last 4.03 and most of the 4.04 betas–so be sure you have the latest 4.04 build when trying Rich’s suggestion regarding this setting.

Tony

OK… I tried your suggestions to no avail… yes I am using the newest version of N… In my control panel under all my audio options, the only device it will allow is SB Live 24bit External
Except my MIDI music playback device gives me 2 options:
Creative USB SoundFont Synth
Microsoft GS Wavetable SW Synth

Selecting either one still gives me the error message.

But, I didn’t install all the “extras” on the drivers disk… one of which may have been the soundfonts… so let me try that.

OK… True… one of the “extras” I didn’t install was the soundfont option… But… I installed it and still I am getting the same problems.

did you turn your metronome off? If you’re trying to to do 2 things with midi, I think you’ll get that message

Quote (Jay Jay @ Feb. 16 2005,15:29)
OK... I tried your suggestions to no avail... yes I am using the newest version of N... In my control panel under all my audio options, the only device it will allow is SB Live 24bit External
Except my MIDI music playback device gives me 2 options:
Creative USB SoundFont Synth
Microsoft GS Wavetable SW Synth

Audio devices shouldn't be relevant here...
What do you have listed under the midi input or recording devices?


Also when you say that you can still record, what are you recording? Audio or midi?

There are 2 things it may be...
1) You have the recording mode se to midi (or audio + midi), but you have no midi input devices in your midi settings. When you hit record, it won't be able to find any midi device to record from. IT will still record audio thoughif you have the dual mode selected.

2) You have the metronome set to be played back by a midi device that eitehr doesn't exist, is being used by something else or is not functioning properly.
Turning the metronome off will test this...

Rich

Jay Jay – A quick glance at the manual shows it doesn’t mention anything about a MIDI In on your USB SB Live 24-bit External, so maybe you simply don’t have one? (correct me if I missed something–here’s the manual) If that’s the case, one thing you might try is enabling the onboard MIDI port of your motherboard (if you have one) even though you might not use it, just so N-track finds some kind of MIDI In. I did this to get rid of the same error on one PC last week. Not the cleanest solution, but if you’re really fed up with the error and it works, maybe you can use it as a last resort?

(Edit: actually a last resort could also be to submit a bug report here if nothing else works for you.)

HTH!

Tony

I am recording audio. I have no idea how to set the recording mode to audio, MIDI, or both… I can’t find the option anywhere.

To turn off the metronome, I just have to leave all the “Output to:” boxes deselected, correct?

How do I enable my onboard MIDI port? I went to device manager already, and the only MIDI device I found was already enabled.

Man, I must sound like a newb about now… blush:p

OK… problem solved. Scantee was correct in saying that my new fun soundcard has no midi input… So after tinkering with settings for a couple hours, I found the recording mode options… it is that pic to the left of the metronome, which looks like a keybpard for midi mode, an old fashion mic in audio mode, and a mic on top of a keyboard for audio + midi.

By the way… thank you guys SO MUCH!!!
:laugh: WOOHOO!

Quote (Jay Jay @ Feb. 16 2005,14:09)
How do I enable my onboard MIDI port? I went to device manager already, and the only MIDI device I found was already enabled.

Sorry, I should have mentioned this, but I wanted to wait to see if any of the other solutions worked (per the "last resort" thing). But just FYI, if you do have onboard MIDI (i.e., built-in on the motherboard), it is usually enabled/disabled in the BIOS setup for the motherboard. However, it's typically enabled by default--I only mentioned it in case you had manually disabled it, but if you don't know how, that's highly unlikely. :D

Anyway, it sounds like your solution is better...
:cool:
Tony