error opening midi in device

start or exit n-Track, I get 3 errors

Every time I start or exit n-Track I get the following 3 errors:

error opening midi in device
Error unpreparing MIDI header when closing device
Error unpreparing MIDI header when closing device

The errors also happen when I enter end exit the preferences dialog.

turned off metronome
recording mode to Audio Only
disabled any midi devices in MIDI preferences tab.

24 bit - 4.0.4 build 1772

Any suggestions?

I was experimenting with Fruity Loops and using the VSTi connectivity into n-Track (which was generating BSODs), but now I just want this error to go away.

TIA,
Chris.

If you don’t have any midi devices selected you shouldn’t get that error just starting n-track I don’t think…

Have you tried resetting your preferences?

Do you have any midi devices showing up as available in the midi input or output preferences?

Is N loading the previous song on startup?
Maybe it has a midi track in it…?

Rich

Quote (chrisj @ Mar. 12 2005,16:42)
Every time I start or exit n-Track I get the following 3 errors:

error opening midi in device
Error unpreparing MIDI header when closing device
Error unpreparing MIDI header when closing device

The errors also happen when I enter end exit the preferences dialog.

chrisj,

Do you still have "Keep MIDI devices open" checked in the preferences? If so, you might try unchecking it. I've seen this option cause those same errors before (but not on exit). I think reverting to defaults like Rich mentioned may do this for you(?).

Tony

Make sure the metronome isn’t set to MIDI Mapper.

I also have a system with no midi devices (Delta44), and see the ‘error opening midi in’ error every time I open a project. I remember getting the same message in earlier versions, but it stopped happening somewhere around 3.2. Now it is back. :laugh: I also was getting the ‘Error unpreparing’ message a few builds ago, but it seems to have gone away on its own after a reset to original settings. I haven’t seen the error on exit though - just lucky, I guess! :cool:

If you find an answer, please post it here, okay? :)

'til then;
Tony W

OK, I think I have solved the problem for now.

I uploaded build 1791 (I didn’t realize there were multiple builds within the same release number) and used default settings. That eliminated most of my problem.

Then I still had the problem of error opening midi out device when opening simple songs; even those that had no midi tracks.

Turned off (unchecked all checkboxes in) metronome but the dropdown is selected on MIDI MAPPER and not Microsoft GS Wavetable

recording mode to Audio Only

disabled any midi devices in MIDI preferences tab.

The Keep devices open is unchecked

The key seemed to be deselecting any devices in the Midi Preferences dialog.

Now to get on with trying to insert Fruity Loops as a VSTi device on a track. I’m sure that will be more stressful on the system, but that’s ultimately what I’m after.


Thanks,
Chris.

Wow, it works!