Error opening n-track

n-Track had been working fine for weeks, and all of a sudden last night when I opened it, I got the windows message “n-track studio has encountered a problem and needs to close. We are sorry for the inconvenience.”

??? Help! This happens right after I double click on the n-track icon, and the initial n-track logo screen appears. The program doesn’t open up at all.

I have uninstalled, and reinstalled several times, and I get the same problem. Each time I reinstall I get a message like “a previousl configuration has been detected…would you like to use this existing config or use the default?” Regardless if I click yes or no, I still get the same error.

What now?

When you get that error, the dialog box has two buttons, one says something like ‘generate error report’ or not…try generating it and having a look in it, see if it helps explain why the app is crashing.

Quote (thirdaura @ April 22 2006,00:20)
When you get that error, the dialog box has two buttons, one says something like ‘generate error report’ or not…try generating it and having a look in it, see if it helps explain why the app is crashing.

Yeah, I’ve looked at it, but its just a bunch of code/junk…can’t make heads or tails of it. Wish there was a way to copy/paste it here or something.

This is the only thing I could copy/paste, the "error signature:"
EventType : clr20r3 P1 : ntrack.exe P2 : 4.2.0.2093 P3 : 443e1376
P4 : mscorlib P5 : 2.0.0.0 P6 : 4333ab80 P7 : 44b1 P8 : 4f
P9 : vzevnfupilsvc31z3h5gto45urxfkid3

Whatever that means…

Have you downloaded any Windows updates, maybe something for .NET?

I,ve Just had the Same problem. I downloaded the Newest version of N-track,and its been working Fine,and all at once,I get the “Needs to close” screen,and i havn,t been able to Open n-Track since…I reloaded the lattest version again,and Nothing happened…I,m “Dead in the water”. any help,would be VERY Much appeciated…Thanks

I’ve seen similar behaviour in the past when the soundcard drivers that n-Track is configured to use are no longer there.

This was self inflicted when I was playing around with the KX drivers on sn SB Live! card. It goes like this… Configure n-Track to use the KX drivers, exit n-Track, uninstall the KX Drivers, install the Creative drivers, start up n-Track and KABOOM.

This was back in early v3. May be fixed now. Solution then was to remove the n-Track config file and all would be well.


Mark

I tried the “Config file” trick,and Nada. I,m still “Dead In the water”. Everytime I try to open N-track,I get the “Needs to close Screen”. This is Very agrivating,because i had a project,I was working on,and Now I can,t do anything with it…I Know this happens,sometimes,With Software,But its Still a Pain…If anyone Comes up with somekind of Fix,Id Be VERY appreciative.( I wonder,If it would work,if i loaded a Older version,of N-Track?????? thanks for any help…KVM :(

Which config file did you delete? In current versions ntrack2.cfg file is stored in the folder:

C:\Documents and Settings<i>your user name here\Application Data
-Track Studio

…assuming your boot drive is C: and you are using Win2k or XP.

have you tried to delete the configuration file in your user directory ?

(c:\documents and settings<user name>\Application Data
-Track Studio
-track2.cfg)

is the registry pointing to the proper directories ?

(HKEY_CURRENT USER/Software/n-Track/Path = C:\Documents and settings<user name>Application Data
-Track Studio

and

HKEY_CURRENT USER/Software/n-Track/CFG1.1 = C:\Documents and settings<user name>Application Data
-Track Studio
-track2.cfg)

Make sure your anti-virus software, and other executables that might be running in the background have been turned off.

If the things that the others have suggested don’t work, it might be helpful to know if the problem is n-track version specific. Perhaps you could install an earlier version of n-track and see if the error persists.

tspinger, I tried you,re idea,of loading an earlier version,of N-Track…and it Worked! Loaded up fine and I Tried opening some of my “In Work” songs,and it worked fine. so I guess for me,it might be a Version specific Problem. I went from the Newest version,back to Version 4.1.6 Build 2065,if that helps anyone. :)

No, I didn’t install any windows updates. I am dead in the water too. As soon as I click on the n-track icon, the flash page comes up and 1 second later I get the error message.

I deleted the config file and still…same problem. I am in the process of downloading the latest build that was released today, and I’ll see if that works. Also, why doesn’t this program come with an uninstall function? I find that using Windows Add/Remove programs still leaves junk on your HD that messes w/ future installs (e.g., I didn’t even know there was an entire n-track folder left in my application data folder…frustrating! all these little artifacts can mess with re-installs)

I’ve got the exact same problem with the exact same symptoms. The newest build from today didnt fix things either. However, a warning window opens on the first run after you install that asks if you want to keep the existing configuration. I couldnt get n to run if I selected Yes, but I tried reinstalling and selecting No on the first run and it seems to be working.

Unfortunately I know have to reconfigure everything…


grrrrrrrrrr

hope this helps

Ok, uninstalled version 4.2, reinstalled version 4.2.1. When I loaded the program, I got this error:

Sytem.Runtime.Serialization.SerializationException: Attempting to deserialize an empty stream. At System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage) at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream) at nTrackDotNet.UsageStatistics.DeSerialize(String filename)

but the program opened up ok. ?? weird, but hopefully the program will work correctly from now on.

Keep posting results of your efforts to get n-track going. Flavio is obviously watching this thread, as he posted a new build a few hours ago that is intended to fix the problem. Perhaps he was successful, although the error message that flaktrak got makes me think he’s not quite got it yet.

Tim