ezdrummer - velocity control

Can the setting be saved?

When running ezdrummer as a plugin in ntrack, is there a way to save the velocity
setting. I have tried the save presets and it does not save it. I have to reset the
velocity to what I want everytime I reload a project into ntrack.

When running ezdrummer in stand alone mode (Toontrack solo), it also has the same
issue, that it can not save and recall the velocity setting, so I am guessing this is
an ezdrummer specific problem.

Must be an EZD/Toontrack issue. Velocity is not saved in Reaper either. Not in the project file or as a preset.

Have you checked the Toontrack forums?


Just updated to EZD V1.1.6… I had V1.1.1 It made no difference though. Still can’t save/recall velocity.


You know what would be COOL? If Toontrack would make the Velocity and other parameters available to the host for automation envelopes. Cool… Then your host would save the envelope automation data and you wouldn’t really need recall.


Do you mean the master velocity? I always note it in my project settings if I change the master velocity. +6 -4 whatever. I rarely do though. I do however tweak the velocities in the piano roll and save them there. It’s one of the EZD limitations for more serious programmers.

I assumed the master velocity was what the OP was referring to… It would be way awesome if Toontrack would make velocity, humanize and all the mixer settings automation capable IMO. :agree:


Yes, I meant master velocity. And yes I have to note the setting, or I easily forget
next time around. Another neat feature would be a built in piano roll creator, drag
and drop each drum hit where you want it, or start with a rough piano roll and move them.
I know you can do this in n-track, but would be nice if ezdrummer had it.

Yep - I think superior drummer may have all that and more. I think I’ll check into that and see if an upgrade may be in order. Automation writing capabilities on all those features would be the bomb. Instead of taking a week for me to do drums it would speed it up to a month!