Flavio - HELP - I cannot install ntrack!!!

Flavio,

I tried to install the new beta and it un-installed the previous version, but for some reason could not complete - this corrupted the entire install. I went to REGEDIT and removed all instances of ntrack and now when I try to install either the beta or the good version, it tells me 1st it’s uninstalling - of course it cannot since it’s gone, and then it tells me it cannot install the new version because, and I quote:

"The advertised application will not be installed because it might be unsafe. Contact your administrator to change the installation user interface option of the package to basic."

Now, I AM the administrator with full privileges (in fact, Ised to be a unix and windows NT administrator and network engineer - so this is not exactly new to me - yet I have NEVER seen this message before).

I am now DEAD IN THE WATER. I cannot install the program in ANY directory. It does not even get to that point.

Please HELP - I have a lot of work to get done!!!

Mike

Mike,

Sounds like your firewall is doing its job by detecting a system change and warning you about it. You should also see a drop-down dialog allowing you to accept the change. Click on “Accept” and try again.

In your security settings you should be able to add http://www.fasoft.com to your “trusted” sites.

Lastly, you can shut off your AV Scanner and firewall TEMPORARILY until you get the install completed.

HTH

Don

I appreciate your suggestion, but I am quite a bit more tech savvy then that (read, used to be a network engineer (lol) - also I am a programmer and I used to build computers - this is usually my forte). It’s not my firewall. I do not even use Windows XP’s firewall - I have that turned off since I use Sygate personal firewall instead, and I know when it tells me something as it’s dialog boxes are obvious. This was regarding installshield - the installer - not my computer. Being that I am a programmer and use installshield here and there - I know it was installshield and not windows xp/firewall/antivirus, etc telling me this.

Mine was a suggestion, not an acquisation.

Your description sounds EXACTLY like the message you would get from your firewall or AV program.

It is entirely possible that you have a corrupted download. It happens!

You asked for HELP and I offered it. Sorry!

Don

The reason I KNOW it’s a install shield message is that I am being told that FROM installshield. Then the program terminates telling me the installation ended prematurely.

I apologize if I sounded harsh - it’s just very frustrating to purchase a program and then not be able to use it - in addition tot he fact that I can usually fix 99.999% of any computer problem thrown my way - but this is one I cannot fix. It looks like it’s on Flavio’s end!!!

Mike

Apology accepted…no permanant damage done. Entering healing mode.

If you are convinced that it is Flavio’s problem you might get faster results by emailing him at the “Support” page. He only monitors this forum occasionally.

Meanwhile, may I please suggest that you download the program again? It is not unusual to get a corrupted download. It happens frequently, in fact.

I can’t help but think of a gentleman who came into the Service Shop where I worked and wanted a Lint Filter for his Whirlpool dryer. My boss brought one out to the counter, a long curved wire mesh screen, and the gentleman recoiled from it saying: “That’s the secondary filter, I want the primary filter.” to which we all gave him a blank stare. He said: “I’m a Boeing Engineer and I know a primary filter from a secondary filter!” He then stormed out the door and returned in a moment with Exhibit “A”, a fuzzy, multi-colored mass about 1" thick, 6" wide, and 18" long and presented it as the “primary” filter. It was impossible to convince him that what he had brought in was, in fact, the LINT!

Now that gentleman may have been able to single-handedly design a lunar lander but he sure knew nothing about lint filters. And, unfortunately, no one could convince him otherwise.

Good luck to you, sir!

Don

Thank you. I feel the love.

Anyway, I did as you suggested and replaced my primary and secondary filters and even canned the lint. Seriously, I shut my machine down, startted back up fresh, downloaded the full version and the beta. Tried installing both. Same problem. Looked for other copies of ntrack possibly floating around, found none. Tried again. Same problem. Tried booting to different user options and finally administrator mode. Re-downloaded again. Same problem. I have tried everything I can think of. Just so you know, this has NEVER happened to me on any piece of software I have EVER purchased and installed.

I am at wits end and about to give up, which is a shame. I guess my next step is to bug Flavio where Flavio resides. I will email him a support email and get his attention.

If anyone has any ideas - shoot em at me - I’m listening.

Mike

Eyup!

I don’t use V4 (still stuck on V3.3) but I believe this problem has cropped up before.
I think it was something to do with windows installer, downloaded installations or registered packages or some such stuff which I really don’t understand.
This was in the very early days of V4 so may not be relevant.
Sorry I can’t remember exactly.

Steve

Some folks could not install it due to an old version of the Windows installer, but if you are on XP you should be fine. Are you sure the Windows installer hasn’t taken a poo on you? Do you have any other Windows installer based apps you can try? I am wondering if a corrupt DLL or some other obscure gremlin isn’t causing you headache. Have you tried the system file checker? I find it is sort of worthless, but it might be worth a shot.

I think it is the installer and I believe it did indeed crap out on me - but it is this specific version that Flavio uses. This, I know, because I just installed a brand spanking new 400MB file I just purchased yesterday that uses some form of installer that looks and feels different from the ntrack one and it worked just fine!!! No, for whatever reason I have not used the system file checker - any way to let me know the filename of that one so I can run it?

Anyone know the kind of installer used by ntrack - I may have incorrectly assumed installshield - but maybe it;s another installer and I can find out what the problem is once I know which installer it is!

Thanks everyone.

<!–QuoteBegin>

Quote
No, for whatever reason I have not used the system file checker - any way to let me know the filename of that one so I can run it?


sfc /scannow

<!–QuoteBegin>
Quote
Anyone know the kind of installer used by ntrack - I may have incorrectly assumed installshield - but maybe it;s another installer and I can find out what the problem is once I know which installer it is!


n-Track does indeed use the Windows installer as Bubba suggests. The downloaded exe expands to a temp directory and runs an msi file. I suggest you get the latest version of the Windows installer and give that a try. Also try clearing out your TEMP directory before running the install (check the value of you %TEMP% variable to find it - it ain’t so obvious with XP).

http://www.microsoft.com/downloa…lang=en
Check out the updated installer.

Uninstall n-Tracks if possible. My guess is that there are stray mismatching parts of n-Tracks or the Windows Installer left over and need clearing out.

From a cmd line type del /f /s /q %temp%*

Search the registry for all fasoft and ntrack entries and get rid of them.

Seach all drives for file instances of n-track2.cfg, n-TrackConfiguration2.xml, vstdat.dat and vstdat.log. Finding these will show you where there may be files that still need cleaning out after an uninstall. These all get recreated when n-Tracks is run so they need to be deleted or moved to a safe folder. Keep in mind that these will be in hidden folder associated with the user account - any accounts that have logged on and run n-Tracks may have them.

Completey delete or move to a new safe location and folders that n-Tracks has been. The new installation doesn’t need to be able to hind any of that.

Flavio has a hidden way to clear out some things. It’s used to normally when the 24 bit version registers as 16 bits. Maybe that all that’s needed.

I tried all of the above - thank you for some great ideas and excellent info. It did not work, though.

I will be interested to learn what Flavio comes up with for you. Please post back with the fix for it.

Thanks,

Don

Quote (Karmacomposer @ Sep. 11 2005,19:32)
I tried all of the above - thank you for some great ideas and excellent info. It did not work, though.

The following has worked for an user who had a similar problem: manually delete the following registry keys using Regedit:

HKEY_CURRENT_USER\Software\Microsoft\Installer\Products\A0E21374C340D9046B0D412854F7C2AD

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{47312E0A-043C-409D-B6D0-1482457F2CDA}

Then try to relaunch the installation of the latest version.

Flavio.

Flavio,

I checked for those two entries in regedit and they did not exist, but I deleted a few that were nameless anyway and none of that worked. There really is no trace of ntrack on my system - I am totally confused as to why I cannot install it. I get a very weird error message asking the administrator (which seems to be you in this case) to make the installation type to basic - and that this one cannot be trusted. It actually says something very close to that. I have no viruses or problems on this computer and everything else works fine. I installed software each day since then and no problems whatsoever.

I have NO CLUE as to why I cannot download the latest or stable release and not install it. It is still is trying to uninstall another copy of ntrack - but they’ve all been uninstalled and deleted. I have a lot of work to do and I really wanted to use ntrack.

Please help me on this.

Mike

Turn off your firewall and any other internet, spam, security and virus protection. Why? Dunno, but I too work in the IT industry and I’ve seen these things meddle with installations. (Infact I saw one only yesterday).

Tried that - nothing has worked

Flavio,

What installer program do you use? I need to know this so I can delete all entries of that installer in the registry and temp files / previous installations. I can also contact that company and ask them what to do.

Mike