Freezing MIDI

How to freeze a MIDI track

Hi

I want to freeze some tracks to improve CPU load and export to 3rd party application for live performance.

I have them sitting there on my TIMELINE a bunch of tracks, one goes off to a synth, one to a sampler etc.

If I hit TAB I see my MIXER and can see my instrument channels. Sweet.

I go back to my timeline window and rightclick on one of my MIDI bits and hit FREEZE.

The program solos that one track and starts rendering it into a wave file.

Unfortunately soloing that one track means that the INSTRUMENT CHANNEL with the synth on it is now muted and so the wav file that gets produced is silent.

I want to use BOUNCE AND PROCESS ALL TRACKS but when I do that and tick all the boxes in the BOUNCE dialogue box for APPLY EQ, APPLY INSERT EFFECTS, APPLY VOLUME ENVELOPES, APPLY PAN ENVELOPES, BOUNCE FROM BEGINNING and I hit BOUNCE ALL TRACKS it just does nothing.

Any wisdom on how to do these things right?

I’m trying to visualize your routing here. (I don’t care for the way the synths go to channels either.) Been a while since I’ve worked with synths in n… so can you just mix each track to a wav - then import them back in? This should be a 30 second job at most, if it weren’t for that routing. Someone more used to using synths should have a quickie reply for you here soon. :agree: I do all my synth work in a separate editor and import wavs back in for mixing in n.

from the manual

Quote:

Effects processing can sometimes overload the CPU (the computer's ‘brain'), especially when working with complex projects or when the computer is not very fast, resulting in annoying clicks or pops while playing the song.

One way to overcome the problem is to Freeze channels that are being processed by CPU intensive plug-ins. When you freeze a channel n-Track creates a temporary wave file with the channel's audio data after being processed by the channel's plug-ins. During subsequent playbacks instead of processing the channel with the plug-ins n-Track simply reads the temporary wave file you created when you froze the channel


so it makes a wav anyway - right?
Quote: (sevenOfeleven @ May 26 2009, 9:22 PM)

from the manual


so it makes a wav anyway - right?

Hey thanks for your reply.

Yes, it makes a .wav but if I follow the instructions the .wav it makes is silent, because part of the process is that it solos that MIDI track whereas it should solo that MIDI track AND the instrument channel that it outputs to (with the VST on it.) I think this must be a bug, have emailed Flavio.

I'll try your workaround, but I have a few songs with lots of tracks in each one and really wanted to see the BOUNCE AND PROCESS ALL TRACKS FROM BEGINNING button work to make it one click per song instead of half an hour per song ....

Thanks for reporting it to Flavio. :agree:
If you’d let us know the results I’d appreciate it.

I just ran some tests on this and mine seems to be working fine and does not mute the vsti synth channel at all.

I not sure I understand. I just tried a MIDI track along with 3 audio tracks.
I froze the MIDI - it creates a temp .wav - On playback nothing is solo’d, and all tracks play back fine. Is there something else you are doing. Are you saying if you try to render at this point something goes wrong?

When a MIDI track that has a VSTi as output is soloed, the track’s output VSTi channel is not muted, so that the track can be heard when it is soloed.
I’ve just verified this on a simple two track song with the two tracks being sent to two different VSTis. Freezing of the tracks worked correctly as well.
Perhaps the problem is related to some non trivial setting of the song you’re working on or perhaps an n-Track configuration setting. Please let me know if you find what is triggering the problem.

Flavio.

OK it works for you guys so I kept playin with it to suss out what happens.

I have a piano line which I transposed up an octave in the track properties. Tranpose +12

I go to freeze it and it does produce a frozen track, but it comes back an octave higher than it should be, (2 octaves higher than the MIDI data)

Maybe it is applying the transposition twice? I will keep playing with it and see.

Can you guys try it on yours with a transposed track?

e.g. double click on your MIDI so the TRACK PROPERTIES part comes up on the left and transpose it, up or down however many semitones then freeze the track and see if it still freezes right.

I haven’t ever used the freeze on a midi track, and don’t understand why you would want to. I think it is way better to solo the midi track I want to make a wav of, use the render button to create a wav file, give it an appropriate name so I can easily save or toss it later. It is an extra couple steps, and may take an extra minute if you are a slow typer, but it gives you so much more control over your files/tracks.

This is something I do often when creating drum or synth parts. VST effects seem to work much better on rendered tracks, and lets me know if a part is going to be what I want it to be.

You can also skip the soloing step if you want - n has a drop down menu on the render settings window that lets you choose which tracks to render, and it works fine. And if you have a midi track controlling more than one synth (say to get a synchronized piano and bandoneon track :p ) it should automatically add both sounds to the file. At least I seem to remember it doing that!

Good luck, and I bet there are three other ways to get this that are just as good! n is powerful!

Oops, I meant to ask - are you trying to freeze the synth channels from your mixer? I remember doing that once a while back, and getting empty files. The trick is to freeze only the midi channel (the one where the piano roll editor lives). This is because when you use the freeze command it automatically mutes all other tracks, including the midi track controlling that particular synth! This is a great thing when freezing single audio tracks, of course, and at first I thought it was bug in n - but it was not. You just don’t want to try to freeze instrument channels. In fact, I just tried to freeze a syth channel, and it did nothing. Hmmmm. Not quite what you report… You are not trying to freeze a soloed track, are you? That might explain your results.

More thought needed here, methinks!

'til next time;
tony w

Hummmm - it does indeed double the octave for +12 semi-tones.
:)
I recorded a midi file (VSTi)
Then went to properties and raised the pitch +12 semi-tones
Then froze the track
It played back at +24 semi-tones.
Scratching head.

This may be worth filing a bug report on.

The same thing happens with audio tracks as well.

That is - transpose audio file x amount of semi-tones. Freeze track. Playback is 2x semi-tones.

Using n-Track build 2475

The playback occurs through the same track channel. Thus the shifted amount is “frozen” then the playback track which STILL has Properties set to transpose applies it AGAIN. So yeah, one could argue that it’s a bug… sorta…

Somebody test that and confirm please? I don’t have n anymore…

D

Quote: (starboy @ May 27 2009, 8:43 PM)

Can you guys try it on yours with a transposed track?

e.g. double click on your MIDI so the TRACK PROPERTIES part comes up on the left and transpose it, up or down however many semitones then freeze the track and see if it still freezes right.

I was able to reproduce the problem. It happens because the program freezes the transpose MIDI track and then during playback re-applies the transpose to the frozen audio data which results in a double transposition. The problem will be fixed in v6.0.5.

Flavio.

^ and that, ladies and gentlemen, is a key reason to use n-track. Superior feedback processing.

Thank You everybody for your time.

:whistle: