Guitarpost problem

Line6 Guitarpost and n-Track settings

I’m sorry for the typo in the title, it’s GUITARPORT.

I’ve used the Line6 Guitarport as a recording interface for my guitars with great success. The beauty of it is that I don’t have to use cabling, the tone is generated in the software and can be recorded directly by n-track.

I’ve run into problems lately that I haven’t been able to figure out, especially since it used to work. I don’t know with which version of n-track the problem started, or if it really is n-track that is making the problem. I’m using the currently latest version of n-track v.4.0.4 build 1811.

Just to clarify; I am able to use guitarport as a recording interface using cabling to my soundcard still, it’s just the internal “direct” recording I’m having trouble with.

Here are my settings and error messages:

First, my sound settings:


Guitarport audio settings:

I’m a little unsure why the asio indicator is not lit.

n-track settings:

note I use 44100 for sampling frequency.

n-track driver settings:

I’ve tried with both WDM and ASIO settings.

n-track midi settings:

I’ve tried many different settings here since I get an error message indicating midi problems.

Error message when closing prefs:

This happens both for WDM and ASIO.

Then another error when I close the above:


When I try ASIO drivers, this is the first error message:


Like I said, it used to work and now I’m having trouble, I need help to figure this out.

Thanks!

only thing I can assume is that your bit rate is different. are you using the 16-bit version? when I first got a 24-bit card I thought I could just record using the 16-bit version at 16-bits… got the same messages about the sampling rate and such not being supported by the card. I imagine the guitarport is 24-bit and you’re using the 16-bit version.

If that’s NOT the case and you’re using the 24-bit version, sometimes reinstalling n-track and reverting all the preferences to the defaults helps clear up problems-then you can tweak it to your settings.

it could also be you’re trying to use the wrong 24-bit format. open up the playback vu meters, click on the hammer-for WDM you can choose which type you wish to use-ie 16, 24, 24 unpacked, 24 left justified. You don’t get a choice in ASIO I think.

hope that helps.

Switch to 48k. I have the same problem, and the only solution was 48k. I don’t know if the bug is n-Tracks or GuitarPort, but it makes using the GP devices directly impossible for me since I never record 48k.

I’ve run into some similar problems with the Podxt but it all was solved when I switched to the 24 bit 48000hz settings on the driver control panel.