Head may explode (long post)

System instability

I’m at my wit’s end. I’ve finally gotten enough equipment together to start recording and have been trying to put nTrack through its paces. I’ve never had a more miserable time in my life trying to get a software/hardware combination to work. For the last three days I’ve been trying to record a simple song and have faced horrific distortion and spontaneous abortion with and without error reporting screens. Both annoyances happen at what appear to be totally random intervals. Here’s the setup:
Song A: MIDI Piano, bass drum, snare, and hihat, each on separate tracks. Additional acoustic guitar track recorded by plugging into Lexicon Omega.
Song B: Same song, only with acoustic guitar recorded through mic going into Lexicon Omega, guitar track cloned and transposed up an octave, bass recorded by plugging preamp into Lexicon Omega, and one vocal.

Either song randomly aborts. Intermittent horrible distortion that sounds by turns like harmonic/echo/ring modulator and broken signal.

Lexicon Omega USB mixer
HP Pavilion 2.6GHz w/1GB RAM and 37 GB free hard drive space.

I spent from 10 yesterday morning until 10 last night reworking both songs, wondering if the .sng or .wav files had gotten corrupted. Nothing worked. From what I’ve read on this forum, it sounded like it could be a buffering problem. I tried every possible permutation and combination of buffers, to no avail.

Tonight I uninstalled the ASIO driver for the mixer and ran the “Repair” selection in the n-Track installer. Leaving the mixer uninstalled, I opened n-Track and activated the “Live” button. When it lit up there was an awful hiss that drove the Master meter up to half mast and held it there. Not good. deactivated “Live”, noise went away. Thinking I was onto something, I loaded song A and preceded to play it. Aside from the mistakes I made laying the guitar track, it sounded really great. Played it through a couple of times, intermittently stopping and restarting it, and it worked pretty well. Thought I was onto something. Saved file, exited program, and when I re-entered hiss was gone, but distortion was back with a vengeance. It stops and starts at different times during whatever I’m playing back, no warning when it’s coming or going. Figured naught from naught is naught and reinstalled Omega’s ASIO driver, most current version dated 6/20/07. No improvement.

What could be causing this mayhem? This is not fun.

Nothing specific to add here other than a few pointers having been in this game for some time. I feel your pain. We’ve been down this road at one point.

I don’t know what your experience level is so this may be old news to you but here goes anyway…

Start Small. Get your setup working with a simple song or two - a couple of tracks. Add simple effects (try n-track’s ones as a starter). If something then “breaks” backtrack until you find out what caused the issue. Don’t try recording tracks at high bit depths and sampling rates at first. Start with 44.1/16. Avoid MIDI and VSTi until you can make a simple recording with a few analogue tracks.

Plugin Wars. Some plugins can cause havoc in some hosts Be wary when you use a plugin for the first time. If you get problems when you add a plugin, remove it.

Backup, backup, backup. Backup your song file (use Explorer) by making a copy. I routinely do this at almost every edit session. If something goes horribly wrong you can go back to where you were at the last edit.

“Drivers, drivers, drivers”. That used to be the mantra here. Make sure you have the latest drivers for everything on your PC - chipset, soundcard, video card, etc. THEN, when it’s working, don’t fiddle just for the sake of it. "If it ain’t broke, don’t fix it"

On the subject of drivers, try different driver models - eg WDM, or even - shock horror - MME.

Keep your DAW clean. If possible only have a dedicated PC for recording; if not use a dual boot. Keep it off the Internet. Add no software that is not needed - no office software, no games, no virus scanner, no spyware software… All these things steal little bits of CPU time etc and are not used to having to run alongside a “real time” application like a DAW.

Don’t use LIVE mode unless you really have to. Don’t use it for monitoring. If you can’t hear what you are playing then you need to look at monitoring through your mixer or soundcard.

Try a different DAW software. oooh, did I saw that out loud? Sometimes you may find that it just won’t work on your setup. Try some different software. If there is still a problem well then there is something wrong with your setup or your way of working. If all is good, well stick with the new software or start reporting bugs.

I have been using N for a long time and have NEVER used “Live” mode.
I am not sure why I would to be honest.
I have a new version of Reason software that has never worked for me on N.
When it connects to N, N automatically goes into “Live” mode with a bunch of distortion and hiss.
I can’t figure it out so Reason never gets used.
I am very suspicious of the “Live” button though.
Except for that, I have never had a problem that wasn’t fixable.
(knock, knock)

I don’t use a Lexicon so I don’t know bout that.
Is it’s USB connection fast enough?
My stuff is all run into a Peavey mixer which I feed to the LINE IN on my PC.
My MIDI kbd is connected directly to the PC with the M-audio MIDI to USB adaptor.

Most of my problems are with different plug-ins that don’t play well with others and sometimes buffering issues when I overload my sf player (Steinberg Sound Canvas).
The plugins I usually don’t use after they mess things up.
The VST host usually can be fixed by lightening up its load a little.

Keep working on it, you’ll get it down.


on the left we have REASON om the right we have N track. how do the two communicate - using REWIRE, a set (by you) ammount of channels are designated for communication - output from a track in N goes into Reason via one on these channels - output back from Reason has to enter N the sama as it if was coming from your soundcards Mic/line inputs - which means that the returns from Reason have to go throughg the LIVE button or nothing can return to N, in my version of N there is pop up that says so when REWIRE is used -

as for the hissing and distortion you could be overloading your PC or sample rates are not the same somewhere between the two - also i have known conflicts between the version of REWIRE.DLL that is used for rewire communication - fixing that though is another story -

Dr J

Lexicon -
there are reports that some CUEBASE users are suffering from random audio start and stops - to which at this time there seems to be no answer -

hissing and distortion seems to ba a failing in equipment that go beyond the normal USB convention of 1 stereo stream in and 1 stereo stream out - to get more inputs and outputs, more info has to be sent up the standard USB cable and much tighter syncronisation has to be observed - if anything breaks the sync even for a millisecond then ths streams get corrupted, when this happens you either get full vol white noise or the samples get misread, (part of one sample is read as part of another) - some have cured it by upgrading their lexicon drivers but others are pointing their fingers to HIGH END video cards that are stealing CPU time to feed the need of gamers at the expense of the rest of the PC - some have had trouble with wireless adaptors used to connect to routers which are connected at the same time - no other USB device should be connected at the same time as the Lexicon as they can beeak the sync -

are you sure your PC is USB2 capable - this is another item that can cause your problem -

Dr J

Re: ellarrshofan

I opened n-Track and activated the “Live” button. When it lit up there was an awful hiss that drove the Master meter up to half mast and held it there. Not good. deactivated “Live”, noise went away. Thinking I was onto something …

You get something like this

Try opening up the record properties tab for the offending track

And Uncheck

This way you can still use LIVE (which I need to hear my synths)
without causing havoc.

from your screenshot it looks like you have no track in the timeline - that noise you have, it could be that your soundcard is set to WHAT YOU HEAR - this sets up a feedback loop betwen input and output - go to your Creative mixer and on the RECORD fader - change WYH to MIC/LINE - that should keep it quiet -

Dr J

Dr J…thanx for the Reason tips.
I was not doing my Rewire correctly.
I may experiment with fixing it, but my system is running perfectly now and to begin monkeying around with it, well… you know how that goes.

Ellarr…didn’t mean to steal your thread.
I still suspect something with your Lexicon and its usb connection.
Maybe you could try eliminating the Lexicon from the chain and see what happens when you lay down some experimental tracks? Keep in mind, I’m somewhat of a novice at this too…only been doing it a couple of years.


Hi Gents:

Just an OFF-Hand suggestion…
We’ve been discussing on another thread that n-Track defaults n-Track Effects on every track you have on your timeline…
You might want to go into the settings panel and config, the effects to be by-passed on every track till you get a chance to experiment with a “DRY” No-Effects mixer strip for each track…


Re: DR Jackrabbit
I had tried what you suggested earlier.
For me, the problem is repeatable.
If I have “Enable Live processing” checked
for my ASIO-2 record input, and I am in
LIVE mode, and I add a blank audio track and
enable record from ASIO-2 stereo (or Left/Right)
for that track the result is the same - noise.
Hey, it’s a SB Audigy. That’s the problem.
But it does’t matter what the settings of
the Windows record mixer are.
But thanks for the suggestion! :agree:

i have AUDIGY NX2 USB - it does not have ASIO drivers just MME and WDM - i cannot replicate this problem no matter how i try or what drivers i use -

Dr J

I find the more setting you change in N-track such as turning off always on effects and such cause N to be really unstable. I usually end up having to reset the default settings and reset my stuff before I can play something again.

Many thanks to all who replied. The problem has not gone entirely away, but has become more manageable. I’ve installed two releases and each has given me a slight improvement, and I feel like I’ve gotten a better handle on how to use effects and when. BIG LESSON: Record dry! If you have effects on any of your existing tracks it can affect the sound you’re monitoring. It can be distorted or have timing issues. The little green fx button is your friend. Effects are your enemy. At least, they can be until you’re mixing down. Here’s a rough demo of a Who (naturally) song. —>I’m One<— Play “spot the jump cuts” with the guitar, if you’re of a mind. They’re certainly there. But it’s still not bad for a half hour’s work. Used the first take on the vocal. Well, actually, it was the second.
:p Laid down one and before I could save it the program went tittz up the first time. Like I said, it’s not perfect yet, but it’s a lot better thanks to the advice I got from people who participate in this forum.

BTW, if I’m violating any copyright laws with the link, someone please let me know and I’ll take it down.

Sorry about the outburst at the end. Mentally unstable, you know.

Hi Guitar69 and Guys:

I find somewhat the opposite from the findings you post on turning off “Default” Settings that you don’t normally use with n-Track…

I’m not completely sure of this …
but I’d say I have trimmed off any resources from n-Track that I can find to a point where I have it leaned out n-Track and void of anything I don’t normally use…

However, I’ve been known to open some feathers up at times…
but that would be on a purely temporary basis…
It’s sure nice to know that you can add any of the features at any time…
knowing that they are available…