Help: recording midi only

Hi folks,

Sometimes I get this little glich when I what to record only a midi track.

I hit the button on the toolbar until it gives me just the keyboard picture, indicating that I will record only a midi track. Next I go to the red record button on at the bottom of the record VU meter and disable my audio inputs so I will not record an audio track with the midi.

When I hit record I get an error message telling me that I don’t have any soundcard selected and the button on the toolbar automatically switches to record audio and midi. I didn’t have this problem before.

My solution at the moment is to always record an audio track along with the midi and delete it after, but it’s beginning to get quite annoying.

Any suggestions?


If the audio input is disabled then my guess is that n-Tracks isn’t getting a clock anymore to record with. That would be a scenario that may need to use the system timer insted of the wave timer for MIDI, or at least fiddle with the different timers in preferences.

Anyway, that’s a wild guess.

Just to clairify, this problem was happening to one particular .sng file. When I loaded another projet, the problem went away.

The .sng file in question was being used as a template, but I remove some tracks and rebuilt the project. Not too difficult to do as there are no .wav files. Don’t spend too much time thinking about this one. I’ve found a fix for it!