Higher quality recording problems

I think Mark A has a good suggestion. I’d check to make sure you have DMA enabled.

I remember tearing my hair out years ago on a slower computer until someone suggested this. I’m not a computer tech kind of person but I’ve often read this forum and thought that a few people’s problems could be related to this setting.

Gramps

Have you tried version 2.3 ?

That was the latest 2.x version …

Err, has no one noticed that he has 32MB of RAM? I am amazed the thing even boots. There is more RAM in an iPod. I have to imagine a tad more RAM could not hurt you any if you can find it laying around free/nearly free.

Quote (Bubbagump @ June 14 2005,12:27)
Err, has no one noticed that he has 32MB of RAM? I am amazed the thing even boots. There is more RAM in an iPod. I have to imagine a tad more RAM could not hurt you any if you can find it laying around free/nearly free.

Yes only 32, however my system resorces are around 70% free and with ntrack running it drops to about 40-60%. Still have enough memory to go around so that shouldn't be a problem. I have no background programs running while ntrack is, except the very basics win98 needs to run like win98-Explorer,Systray, and Rnaapp sometimes. Even these few things take around 4mb of ram to run, so that's still 28mb for ntrack to use. Virtual memory isn't being used at all when ntrack is running, and even if it did I set the max/min virtual memory settings to the same value to speed up vmem access.
I swear I've tried everything.
Maybe it is the AMD CPU?
I can pull off 16000 and even 18000 with 4-8 stereo tracks but anything more than 18000 (like the 22050 I want to use) just limits ntrack to 2 stereo tracks! Any more tracks and ughh.. It just doesn't make sence to me. I use no effects or anything special.
I'll try that Playback In Mono tip and see how it goes..

<!–QuoteBegin>

Quote
Err, has no one noticed that he has 32MB of RAM?


Yeah me on page one of this thread.

My bet is that, as soon as you ask it to do anything, the O/S is swapping to disk constantly. On my system (albeit with V4), N-track uses about 15M of ram with no plugins, etc loaded. Once W98 is loaded my bet is that there is little RAM left. Add N-track and hey-ho a-swapping we go.


Mark

Something else that springs to mind…

When my old system was maxed out, a good indicator of how hard the drive was working was by watching the drive LED. When nearing max load, it would be pretty much on the whole time a project was playing back, but as long as there were a few off-flickers there might just be room for another track.

Did you check your DMA setting? This has a major effect on disk performance.

Quote (darklife @ June 14 2005,13:47)
Quote (Bubbagump @ June 14 2005,12:27)
Err, has no one noticed that he has 32MB of RAM? I am amazed the thing even boots. There is more RAM in an iPod. I have to imagine a tad more RAM could not hurt you any if you can find it laying around free/nearly free.

Yes only 32, however my system resorces are around 70% free and with ntrack running it drops to about 40-60%. Still have enough memory to go around so that shouldn’t be a problem. I have no background programs running while ntrack is, except the very basics win98 needs to run like win98-Explorer,Systray, and Rnaapp sometimes. Even these few things take around 4mb of ram to run, so that’s still 28mb for ntrack to use. Virtual memory isn’t being used at all when ntrack is running, and even if it did I set the max/min virtual memory settings to the same value to speed up vmem access.
I swear I’ve tried everything.
Maybe it is the AMD CPU?
I can pull off 16000 and even 18000 with 4-8 stereo tracks but anything more than 18000 (like the 22050 I want to use) just limits ntrack to 2 stereo tracks! Any more tracks and ughh… It just doesn’t make sence to me. I use no effects or anything special.
I’ll try that Playback In Mono tip and see how it goes…

I think Bubba has a point. There is a direct relationship between the amount of RAM and the sample rate that the software is able to manage. With 32 MB of RAM you praticaly don’t have space for buffering.
The CPU usage doesn’t have relation with the memory use.
[EDIT]
Take a look at http://support.microsoft.com/default.aspx?scid=kb;en-us;259161 and you can confirm that you are near to the lower memory limit for Win98
[EDIT]


Cheers,

32 megs is a bare minimum to get earlier versions of Windows up and running without requiring virtual ram. I had a machine at work a long time ago that was setup with 32 megs – all virtual ram was disabled. It would boot with Win95 on there and still have a few megs to play with. It was great for testing stuff for low memory usage problems. It wouldn’t boot at all with Win98 on it, though it would with 64 megs.

All things being “normal” 32 megs will work fine for most stuff under Win98 with at least 64 megs of virtual ram. The bottleneck, as has been pointed out, will be when running out of physical ram – the hard drive will have to constantly work, killing all performance and making recording virtually impossible, thoughy playback might still be ok (sort of). Moving up to 64 megs should make a big difference, but might not solve the problem. It’s not a CPU % or resourse usage issue. It’s a physical verses virtual ram issue.

For comparison, I have WinXp SP2 on my work machine. Ther are currently 6 applications running. I have 1 gig of physical ram in the machine total. Right now there is 577 megs of physical ram free, showing that over 400 megs are in use…and Win95 use to boot with just 32 megs.

That said, I think the system should be doing better than it is…and - yes - stay with the older version of n-Tracks on that system, though 32 megs, in my opinion, is too little for Win98 to be comfortable.

Quote (Mark A @ June 14 2005,13:33)
Yeah me on page one of this thread.

My bet is that, as soon as you ask it to do anything, the O/S is swapping to disk constantly.

Sorry, missed that. But I am thinking like you are, the paging must be mad. No wonder there are drop outs. You couldn’t keep a steady audio strem for more than a few seconds with paging going bonkers, especially on an older PIO drive.

with all the information given in this thread…
I’d have to say, go back to Win95,Version 2.3 and only use 4 tracks at a time.
You can mixdown the tracks to one tracks and work on three more.
hen once you get those 7 tracks down you can mix them down, rinse lather, reapeat, as many times as needed to make the song.
You always have your original tracks seperatly save them, to a disk and take them to someones house who is living in the 21’st century! for mixdown…lol
Anyway, I think it’s important for you to work within your systems abilities, not to try and make it do what you want.
:D
jerm

I have just finally been able to get rid of the last Win98 32MB PC from our office network.

It would boot up fine, and run any one individual application without problems, but much in the way of multi-tasking was pretty much out of the question … and that was just using bog-standard office software and our client database. I wouldn’t even have attempted to try recording on it.

As makako pointed out the measure of CPU usage bears no relation to how much physical memory is being used at the same time, so don’t use this as a guide to how well the PC might be performing. in recording and mixing audio.

DaveC,

I agree with the opinion that you do not have enough RAM in that machine to make Windows 98 work without too much swapping. I run 98 on all my machines and on my dads machine and have been stuck using macines with only 32-64MB at work - it just isn’t enough memory for many of the applications out there.

You may get away with it usint version 2.2 or 2.3.

Also be sure that you have auto insert notification turned off for your CDROM. You can find the setting in the system tabs under control panel.

Peace,
TrackGrrrl

I used to record 8 - 10 dry tracks (16/44) on a machine with a 166 MHz AMD K5, 16 megs of RAM, and Windows 95. (About three years into its life the CPU fan died. I never replaced it, and it STILL worked jolly for a long time!)

Adding some RAM might help, but really Darklife’s system is typical of a lot of systems that came out around the time version 2 was released (which was 1998, I think). I don’t think adding RAM will completely solve this problem. There’s definitely something else wrong with this picture, and it’s going to take some work to figure out what it is. n-Track 2 should be running a whole lot better.

I do recall that a lot of us had serious issues with some of the 2.x versions. There was a huge thread about it… Something about a memory leak or something.

You could always try upgrading to 2.3 or even downgrading to 1.3 to see if that helps.

Quote (jeremysdemo @ June 12 2005,21:32)
Depending on the effects and lenth of tracks was gettin' up to 10 easy..with some lag around the 8th track or so. Nothing that couldn't be edited to line up though.

I found it worked better if you selected (mono playback during recording) pretty shure I increased the buffer speed, but don't over do it..'cause it does more harm than good.
Program Highest Priority in settings,
And cross your fingers...just don't use effects during recording for best results.

Oh man, that brings back memories.

Mono playback while recording worked wonders for my rig in those days.

Also disabling the waveform calculation while recording.

Oh yeah, my machine worked better when n was set to high priority rather than highest.

There were just so many tweaks and workarounds that had to be performed on so many levels to squeek every ounce of performance out of our machines... We've really got it good these days.
Quote (Former Member Gone @ June 15 2005,19:33)
There were just so many tweaks and workarounds that had to be performed on so many levels to squeek every ounce of performance out of our machines... We've really got it good these days.

Amen to that brother!

I'm only on a 1G proc, but my hardrive has a 8.5 buffer speed. Man I'm in heaven! And I'm still using 2.3! Who cares, does what I need and more!

keep shinin'

jerm :cool:

I hate to repeat myself…but…have you checked your DMA settings? You haven’t mentioned whether you have or not (i don’t think??). I used to have a PII 166 (or maybe PI) with some rediculously low amount of ram.

At 48Khz I got up to 6 or 8 tracks (mono). Surely, the basic process of taking a signal and writing it to the hard disk hasn’t become that much more cpu intensive from earlier versions to now???

I just know that without DMA enabled i could not get more than 1 track on that old machine. If you could just confirm whether or not you have DMA enabled then I’ll stop ranting :)

Gramps

I am probably too late for this forum, but before I upgraded my PC I used:
P-III, 10g HD, Win98, N-track V2.2, 256 RAM, Goldwave Wave
Editor and all of the Classic Series vst plug-ins.
Note: A big difference in my old sys and yours is the RAM amount. That is why I am leaning toward the RAM as being the culprit. Unless you have a terribly fragmented HD, the CPU is probably working like crazy at disc-swapping like referred to in previous posts. A couple of 64mg RAM chips would probably solve a lot off the problem.
I used to manage 8-10 trks per song with a couple of plug-ins on each. Maybe I was just lucky.

P.S. a sign of changing times: I have a whole bag full of 8,16 and 32 mg RAM chips i have removed from old PC’s. they are just sitting on a shelf…don’t have much use for them anymore. :D

Maybe try resetting the PCI latency on your video card. Read the thread about issues with the 1010 sound card that is on this forum. ALso there are similar threads about pops and clicks during recording and a program is listed to reset the vidoe card latency and it has helped.

http://downloads.guru3d.com/download.php?det=951