I know this is probably a dumb question but.....

Whenever I record a new track while playing back others I get all the other tracks recording on the new track. How can I stop this ?

Check your sound card’s settings. It is the cause of this 99% of the time. Look through old threads too. This has been ask/answered a lot here, so you will probably find a thread on here about the specific card you own.