Importing midi files

I am brain dead again… please help

Hi all,
I need help in figuring out importing MIDI files into n-T.
My brother sent me a MIDI drum track that he put together with a program called tab-trax. I import the MIDI file into that program and it sounds and plays just like it is supposed to.
I also use Finale Notepad for writing and printing music. I import the MIDI file into there and it sounds and plays just like a drum track.

I go to import the MIDI track into n-t, browse for the file, it asks me if I want to use the MIDI file tempo map, I have tried selecting yes and no on separate attempts to see what happens. And nothing does. There is no drum track there is nothing at all. I have inserted a blank MIDI track and selected n-track drums for the vst instrument and tried to import the MIDI drum track and still nothing.

Please tell me what I am doing wrong here. Or what else I need to be doing that I am not.

can you post it somewhere or email it?

I’d like to see what’s up too.

If I have done this properly, here is a link for the MIDI drum file.
The link according to the site will be good for 7 days.

Also in case it matters I am currently using Version 6.0.2 build 2431. I have downloaded but not installed the latest build.

the MIDI file is OK - it is set to channel 10 which means that it will play MIDI drums in the GM set within the Microsoft wavetable synth - when output to NTD not all notes are played as it is not set up to NTDs pads -


plays fine for me using EZdrummer in n.

Ok, then I am glad the MIDI file does work properly.
So what the heck am I not doing right? I have a midi track, set it up for m-channel 10, try to import the file and I get nothing at all. Do I need to somehow select the GM drums?
Could someone please step me through the process for what I need to do here? I keep trying and I just can’t seem to figure it out.

All I did was open n, Imported midi without any track set up, puished play and it played through GM automatically. Ran it through EZdrummer VSTi after that - then switched to n-Track drums. All played well without any tinkering the track.
I am using the latest build of n-Track, that may be the dif - I dunno.

I just got done installing the lastest version and build of N-T and I still get nothing when trying to import that MIDI drum file. I am really getting frustrated… it has to be something I have set wrong or not set somewhere most likely.
I have gone through all the settings and preferences but cannot figure this out. I am obviously missing something somewhere. I even tried switching from ASIO to MME to see if even that would make some sort of difference but it didn’t.
This is going to be a really dumb question… but after you import the MIDI drum file… do you actually see it on the screen?
I get no visual sign that the MIDI track is there, I press play and nothing happens. But if I go to the ‘EDIT’ tab I have the option hi-lited to ‘undo add MIDI track’

I just D/L’d your file. I’m have build 2459 on the laptop here.
FILE/IMPORT MIDI FILE/ browsed to your file and it opened fine.
played it back with MS GS Wavetable SW synth (which is selected as MIDI out in SETTINGS/PREFERENCES/MIDI SETTINGS/MIDI DEVICES

opened fine / played back fine.

If you import your midi file and don’t see anything, I would try setting the program defaults. SETTINGS/PREFERENCES/RESTORE GLOBAL DEFAULT SETTINGS and try again

Could be your running into some unusual install problem also.
If you do another install - opt to NOT keep your old config settings.

Thanks for all your help again but I have still gotten nowhere.
First I tried the global default reset and this did not work.
So I went ahead and reinstalled n-t and chose not to keep my old settings.
And still nothing at all happens when I import the midi drum file.
I am going to check with my wife to see if she has a pattern to make me a straight jacket
I think I am going insane

Have her make us one too. I’m really stumped (I can’t not make it work).
Is it possible your original midi file got wiped?
File size SB 11.2k

I double checked on that and it is fine.
I load it up with MS Media Player and it plays perfectly.
I load it up with (Roxio) Creative Media Player and it plays perfectly.
I import it into Finale Notepad and it looks and plays perfectly.
I import it into Tab-trax and it looks and plays perfectly.
Every other program on my computer that can read/play/import MIDI files reads and/or plays this file perfectly.
??? The darn thing just refuses to import into N-Track ??? which leads me to believe that it does have something to do with N-T and nothing else in my compuer. Stange things can happen so I could be wrong about that one

I literally am going insane my friends

For the hell of it I downloaded a totally random MIDI file off the internet. It was Take On Me by Aha. I opened up N-T and the file imported perfectly. I pressed play but got no sound but once I added a vst instrument of any kind each track played.

SO… I thought what the hell? While those MIDI files were still in n-t I tried to import the original drum MIDI file in question and it loaded into N-T perfectly. I assigned N-T drums to it and actually played.

SO… I thought again WHAT THE HELL? I closed N-T and chose not to save any song settings. I restarted N-T and tried to import just the MIDI drum track and … it imported and played perfectly once I assigned N-T drums to it.

There were absolutely NO changes to any preferences and settings between the drum track not working and me trying to import the other MIDI file. But now for some really strange reason MIDI files are importing into N-T just fine.

I guess "Ours not to question why, Ours but to do and … oh what the hell
:) As long as it is working now that’s all that matters.

Thanks everyone for your help on this.

Probably a disturbance in the space-time continuum.


there seems to be a running set of problems for some/most in piano roll and midi overall.