inserting bars in between grids

Hi everyone

I got a song with bars of guitars and other instruments using a snap grid on the timeline.

Sometimes I realize I got to add more in between bars of instruments in the timeline and I don’t want to MOVE everything for every subsequent track just to make room for more stuff in between measures.

Is there a way to do this?

TIA

Have you tried “Edit -> Insert”? I think it’s just what you’re asking for.

Note that afterwards you can easily adjust the begins & ends of the gap for each track, in case the new gap causes a note to be cut off at the end or a pickup to get stuck at the end of before the gap rather than at the end of the gap leading into the second part. Just turn the grid off and drag the little squares at the beginning or end of the wave “part” in the timeline.

what i mean is i want to insert new GRIDS without imposing on existings ones

1 - 2 - 3 [insert new bar] - 4 - 5

and it should do the same for the rest of the tracks to align them properly.

im already moving everything over to readjust with a mouse in every track…i was hoping that i can add new bars in between without having to do that

Track 1 -> 1 - 2 - 3 - [insert new] - 4 -5 -6 -7
Track 2 -> 1 - 2 - 3 - [new] - 4 - 5 - 6 - 7
Track 3 -> 1 - 2 - 3 - [new] - 4 - 5 - 6 - 7

etc

In V4 there is an “All Tracks” or “Selected Tracks” option when inserting as Jeff suggested.

Wanderer, what you’re asking for sounds like exactly what “Edit -> Insert” does. Except, of course, you don’t have to move the parts manually first.

Jeff…no it overwrites the existing bar which is NOT what i want it to do

Think of this way…when you use a word processor…if you were typing something in between words…whats the toggling difference if you hit the “Insert” key?

Thats what Im trying to accomplish…not only with one track but all the associated tracks to shift over when adding a new bar in between bars.

Edit->Insert just adds a silence between the bars overwriting whatever wav file was in place

<!–QuoteBegin>

Quote
Edit->Insert just adds a silence between the bars overwriting whatever wav file was in place

Not in my experience. It creates a splice, inserts silence, and moves the wave to the right. It doesn’t overwrite the wave. When I slide the wave part on the right back left so the ends butt up against each other it’s very obvious no wave was overwritten as that basically removes the insert.

If that doesn’t happen then post your exact repro steps and we’ll see what the problem may be. It might be a bug we haven’t hit yet.

I agree with phoo. If it now does what you say (overwrite), then it’s a new bug. I understand now what you’re saying, though. Better try it again and make sure. (Make sure you’re in “nondestructive editing mode”, which is the default every time you start n-Track.) If it still overwrites, post here and let us know, and tell us what build # you’re using (from “about”).

Then, folks here can try it and we can figure out whether it’s happening for everyone or just certain builds, etc., and then someone can file a bug report with Flavio via the support webpage.


If anyone else would be so kind as to