Intigrated sound card

n-track 4 doesn’t recognize this.

I just bought a new computer with windows Vista and an intigrated sound card.
For recording I will use external devices run through the usb port, so I wasn’t concerned about the lack of sound card.
My problem is that if I don’t have anything plugged into my usb port and just want to play a song, n-track doesn’t recognize a soundcard and gives me 2 or 3 error messages then begins to play my song.
Does anyone know how to fix this?

Jon Weems

Under Settings/Audio Devices select your integrated sound card as the playback device. Of course, you’ll want to unselect it again when recording if you are using your USB device for playback.

I’m finding Vista to be rather user friendly in making these switches - right click on your little speaker icon at the bottom right of your main tool bar. You will get choices there - Open volume mixer, Playback devices, Recording devices, and Sounds - (That’s my machine anyway - yours may have more or less installed.) - If you click on playback devices and nothing is listed I would be concerned but Vista has been good about finding everything for me. It even annoyingly (sometimes) will let you know when something is or isn’t plugged in.

You can also set separate volumes in the ‘volume mixer’ for each application running.

No matter what I select from audio recording or playback devices, I get an error message that says ‘error opening wave input device’ or ‘no sound card detected’. I get the message twice then n-track will play my song. It is very annoying. Thanks.

Regardless of which soundcard is selected in Windows, what is the device selected for playing in n-Tracks preferences? It’s possible that n-Tracks is still thinking the USB device is still present (even though it isn’t).

You MAY have to reset your preferences to the defaults, then reset them to you liking. The need for that happens occasionally. I’ve needed to do it almost every time I change soundcards (do almost anything to the hardware). USB devices can cause issues because the index of devices can change depending on whether or not the device is inserted out out. (This isn’t an n-Tracks specific issue.)

OK…I read my original message and realized I didn’t mention that I haven’t even plugged up a USB device yet. I simply installed n-track and tried to play a finished song I had recorded on another computer. I’m just trying to get n-track to work on this computer before adding any recording devices. Thanks again.

Actually you did say that, now that I reread your post. Thanks for clarifying. :)

What are the available devices shown in n-Tracks preferences? I assume sound can be played through the motherboard soundcard from other apps (Windows Media Player for example).

Yes, all of my other applications work fine regarding the sound. n-track even sounds fine after the 2 or 3 error messages come up and I click ‘OK’. Everytime I try to play a song I get the error message:
‘Error opening wave input device. Make sure that the sampling frequency and the recording format set in the dialog box that appears clicking on the Setting button on the recording vumeter are supported by the soundcard’.

I have tried every sampling frequency and get the same message. When I first installed n-track on this computer, it said a soundcard was not detected.

In my wave devices window I have:

Audio playback devices-
ds-primary sound driver
ds-realtek digital output
mme-realtek digital output
mme-wave mapper
wdm-realtek hd audio rear output
wdm-realtek hda spdif out

Audio recording devices-
ds-primary sound capture driver
mme-wave mapper
wdm-realtek hd audio line input
wdm-realtek hd audio mic input
wdm-realtek hd audio stereo input

I’ve tried them all.

What bit depth is set for recording? Click the hammer on the recording meter. If that is set to something that your soundcards driver can’t be opened as then you might get these errors.

There’s other things that can cause those errors as well, such as if another app running has opened the input device. That shouldn’t be the case, unless you intentionally ran another app, but it’s still possible.

Just a thought.

Have you tried using ASIO4ALL drivers?
Download here
Install and select as I/O device in preferences.
Just to see if you get the same error messages.