iOS: Speaker output not an option

“Receiver” is the only output option.

I’m new to n-track for iOS. When trying to play back a song through my iPhone6 speaker, the output is very very soft. I notice that all of the tracks have “Receiver” listed as their outputs.

However, if I run n-track as an Audiobus input, “Speaker” is the output for the tracks and the volume is as expected.

I haven’t been able to find anything regarding what “Receiver” means; and the folks at the Apple Store didn’t know. They suggested that maybe it’s playing back through the earpiece? Surely that can’t be. Why would that exist as an option?

Why doesn’t “Speaker” show as an output option unless I’m using Audiobus?

Redzoom, on your iPhone you have two different audio outputs. Speaker means that audio has been routed to the speakers in the bottom of your device, on the contrary Receiver means that audio will be played through the receiver of your phone (if you put your ear on the receiver you should be able to hear louder).

n-Track should route audio to the Speaker by deafult.
Try checking in the app Settings->Output Channels what options you have, and eventually set the Speaker as output from here.
Please keep me posted.

Andrea
n-Track Team

Thank you for the suggestion. I double checked that setting a moment ago and,oddly, only “receiver” is shown. “Speakers” is not an option. I did find that running ntrack as an input to audiobus does cause “speakers” to appear in the output channel list (and also causes “receiver” to disappear… ).

rodzroom, we’ve found a little bug on iPhone6 & iPhone6+ devices. We’ve already submitted the fix to Apple and an update will be available on App Store in few days.
Thanks again for your feedback,
Andrea
n-Track Team

This, ladies and gentlemen, is what service looks like.