is this possible?

recording live with effects?

my apologies if this has been asked before, but i am just wondering.
let’s say i had a song and i wanted to overdub a guitar solo. i have many plugins such as chorus and reverb etc… is there any way of recording the solo live with the effects already added on so i can hear it while playing guitar instead of laying down the solo bare and then adding the effects afterwards?
help is much appreciated.

Yep. That’s what “LIVE” mode is for. One big gotcha though… you need a soundcard/driver set that will give you low enough audio latency so that you can play without discernable audio lag… otherwise your timing will be off. All that FX processing uses CPU time and with an inefficient audio subsystem, latency becomes a real issue when using virtual effects and virtual instruments.

D

Diogenes is right, except it’s not the CPU time but the buffering.

If you’re using a built-in soundcard, you can get low latency using ASIO4ALL (google to find it, works great). If you’re using a soundcard made for audio recording, just select the ASIO drivers. (Preferences -> Audio Devices – you’ll need to do this for ASIO4ALL too.) Then you can use LIVE mode.

You may also need to adjust the latency settings in the ASIO driver control panel, if the latency isn’t low enough by default. Get there by clicking the little hammer below the recording meters.

Note that you’ll hear the effects, but they don’t get recorded. When you play it back, you’ll still hear the effects, since the settings are saved and they’ll still be “in the chain”. This is good news because it means you can adjust them after recording.

The bad news is that some systems just aren’t up to it. It has more to do with MOBO and softwarem, not CPU power. If you set for low-latency you might find that you get “drop outs” in your recordings – pops, clicks, zippers/buzzes – here and there. If so, try higher latency settings or else ask about streamlining your OS for low latency operation (post a new thread). First, try rebooting and not starting any other applications or services.

<!–QuoteBegin>

Quote
The bad news is that some systems just aren’t up to it. It has more to do with MOBO and softwarem, not CPU power. If you set for low-latency you might find that you get “drop outs” in your recordings – pops, clicks, zippers/buzzes – here and there. If so, try higher latency settings or else ask about streamlining your OS for low latency operation (post a new thread). First, try rebooting and not starting any other applications or services.


I find that once the track and effect count goes up, so does the possibility of sucessfully using low latency ASIO for live recording - the number and size of the buffers gets inadequate for the throughput required. At least in my system.