Latency... I think

Normally, I use N-Track to mix the tracks I record via an Alesis HD24 during a show. I’ve had the occasion to fix a few things and started to record new tracks using N-tracks.

However, I’ve noticed that the newly recorded tracks aren’t completely synched. I’ ve got a M-Audio 2496 sound card that i’m recording from a Yamaha MG12 mixed.

I’m guessing there’s is a some kind a latency issue between the playback and the recording. Since I’ve never had occasion to fiddle with such settings, where would you all suggest I begin??

It’s not really latency. It’s a sync problem to be more accurate.

Try setting N-track options to use the “wave timer” rather than the “system timer” as there’s probably a small variation in the sampling clocks between the PC and the HD24.

actually, that’s not very helpful. Try this:

In N-track “Preferences” on the “Options” tab, untick both options for “Use system timer”.

This will cause n-track to use the Wav file timing information rather than the system clock.

I’m at work now, so I’ll try that when I get home.

But, perhpas I wasn’t clear. The tracks from the HD24 are no problem. It’s the new tracks that dont synch up.

For example, the bass player came over to redo his bass part. I created a new track, armed it to record and started the record/playback. After recording the new track, when we played it back, it was a few milliseconds behind the rest of the tracks. I was able to move the track left to align it, but I’m seeking a way to not have to do that.

<!–QuoteBegin>

QUOTE
But, perhpas I wasn’t clear. The tracks from the HD24 are no problem. It’s the new tracks that dont synch up.

You were clear enough. That’s wat XonXoff was saying when he said it’s a sync issue.

Also try, Prefrences,Audio Devices,Advanced, uncheck keep audio devides open.


(YazMiester @ Jun. 12 2007,05:51)
QUOTE
.

Just some thoughts.....

It would be great if the folowing settings were defaults i n-Track:

wave timer checked

uncheck keep audio devides open


I´m sure that it would be a great help for many new users who are not aware of the latency/sync problem.(sorry if it´s a bit off topic)

Kind regards Henrik

:)

The “keep audio devices open” part is a crap shoot: lots of systems work better with it enabled.

The “use system timer” thing is for the benefit of those using built-in soundcards, many of which don’t (or perhaps, didn’t use to) support wave timer. One less thing to go totally wrong for the newbie, a setting that always works, albeit often not quite correctly.

The truth about both of these settings is “Use the ones that work for you”. We don’t ever hear from the folks where it works best when set the default way, but I’m sure there are plenty of them. (I was one of them, once upon a time.)


(learjeff @ Jun. 21 2007,15:02)
QUOTE
The "keep audio devices open" part is a crap shoot: lots of systems work better with it enabled.

The "use system timer" thing is for the benefit of those using built-in soundcards, many of which don't (or perhaps, didn't use to) support wave timer. One less thing to go totally wrong for the newbie, a setting that always works, albeit often not quite correctly.

The truth about both of these settings is "Use the ones that work for you". We don't ever hear from the folks where it works best when set the default way, but I'm sure there are plenty of them. (I was one of them, once upon a time.)

OK, I just recall many postings regarding these default settings so therefore my suggestion but perhaps youre right.

The truth is we don’t know the truth, because we don’t hear from the people where it goofs up only when used the non-default way.

I suspect that we could probably get away with defaulting to use the wave timer now. The last time I had a soundcard that didn’t support it was back in 2003, and it certainly is better to use the wave timers for the vast majority of us who are at all serious with n-Track. (That card could play back using wave timer, but not record. It was a laptop builtin.)