Layla20, Windows XP Pro & NTrack V6 Users

…do you get similar problems?


I see there’s a thread for the Layla20 and NTrack V5, but I haven’t found an equivalent thread for V6.

I’m trying to keep up to date with my releases of NTrack, and as such, I’m using build 2390.

Some questions:

My Window’s Event Log (under Admin in the Control Panel) is filled with errors related to my Layla…and it has been since I installed the audio device, back when I was still using V4…or maybe even 3. The error is: “EL200 (driver has encountered an internal error), event ID 101”.

…I’ve recently started wondering if my audio card is at fault physically…I’m using driver version 6.11.

Yesterday, I spent hours working with NTrack. I could go through long stretches of it behaving just fine…but occasionally it crashes to desk top, sometimes it plays back incorrectly (might be buffer settings), sometimes, when it records, it plays back what it just recorded at 2x speed, and, also, while watching the real-time spectrum analyser on the master-channel, it’d occasionally “clip itself to death”, despite the fact that I wouldn’t be adjusting controls at the time. By “clip itself to death”, I mean it’d send the program material into the red, the fader indicating the phenomenon, then halt playback.

Also, sometimes my computer completely locks up, not blue-screening, but locked up to the point where the mouse pointer won’t move and CPU Mon stops refreshing.

So, Layla20 users–is any of this stuff familiar to you? Or do I need to consider buyinga new AD?


I have a Layla20, though I’m using a Layla24 currently. I think you’ve got the latest driver, so that shouldn’t be an issue, even though that drive never got out of beta.

Which devices are selected in n-Tracks preferences? I had very little luck with ASIO and WDM when using the Layla20 – almost zero problems when using MME.

I didn’t need the lower latency, so using MME was not an issue.

The double speed playback problem is REALLY strange when it happens. I’ve had that happen a few times. There is a workaround.

Turn OFF ALL System sounds. If you are recording at 44.1k and a system sound plays that is a 22k wave then the system will change the samplerate on you mid stream. All of a sudden 44 becomes 22, but there is no way for n-Tracks to know that, so it writes out the data as 44k (but it’s now 22k). When that recorded wave is played back it will play as 44k, but when it gets to the 22k data it continues playing as 44k, but it’s 22 data so it plays double speed.

I suspect much more is going on that just that on your machine.

Let’s see how MME and no system sounds does then take it from there.

I have a Layla 2 and a Layla 24:
Layla 20 - I don’t think the ASIO drivers worked with earlier versions of Ntrack. The WDM and MME work fine.
I have a problen on my laptop using Ntrack 6 (all previous versions worked with Layla WDM, not ASIO. With nTrack 6 I can run ASIO but not WDM.
So, I am interested in what we find here. I have also run into some problems with ASIO on my laptop with MOTU896mk3 - the WDM and MME drivers work fine. All the drivers, MME, WDM, ASIO work with great with my desktop with all drivers.
I have been in touch with Flavio and he wants some additonal information but I have been covers\ed up with other wrok an have not gotten back to him. So, maybe you guys can share here.

Thanks for taking the time to respond, guys!

That was silly of me: I forgot to say that I use the WDM drivers. I’ll try the MME and see if they’re any more stable.

I keep system sounds off, as per the recommendation in the Layla’s users’ guide.

Do you find the later versions of Layla to be stable? Do you have weird issues happening when you run NTrack? Does it crash to desktop and whatnot? Ever?

I may have just found another bug: while playing back material, going into the channel EQ, entering a center frequency then tabbing seems to crash me to desktop. Dunno if this is an old Layla thing or not.

Again, thanks for your responses.

I have the Gina 20, haven’t used it in forever, but the 6.11 driver gave me problems in nTrack (with asio WDM and MME)If I recall correctly, I rolled back to an earlier driver and it went away. But that was also a Windows 98 machine. The MME drivers always worked better on that machine also.

I use the Layla 20 for playback mostly. Using version including 5: But I do recall a time or two that either the Layla 20 or the Layla 24 would stop working correctly with WDM (ASIO never worked for me) I would change Ntrack to the MME drivers, record and/or play something and it worked perfectly. Then I would change the drive back to WDM and all was fine. I never discovered what caused the problem.
With version 6 neither WDM or ASIO work with the Layla 20. The ASIO driver causes NTrack to quite responding.
Flavio has created a new capture starting with version 6 build 2389.
It will log a message saying which format was used by the ASIO driver.
If you experience a problem with your sound driver you might sent the log to him. It is located at
Documents and Settings//Application Data/nTrack Studio6 folder.

Bax, that reminds me of something. Occasionally, the Layla will get in an odd state an need rebooting. It’s not n-Tracks specific. It’s definitely something with the soundcard or driver. The only workaround is to shut down the computer normally, so that it’s completely off (this powers down the Echo PCI card). Turn off the Layla for about 30 seconds. Turn it back on, and boot up the computer. That’s a cold reboot for the whole thing.

The symptom is that all apps that play audio MIGHT play incorrectly. I found that some audio plays OK, but many video files will play at an incorrect speed. Sometimes the video will be double - sometimes half - sometimes “not right”. I’ve seen the a video double speed but the audio be the correct pitch, but spliced up so it stays in sync. I’ve seen it play slow and low - fast and high.

It’s very obvious the clock is going wacky. And I have system sound turned off, so that’s not the only thing that can do this.

I have had this problem in a really long time. It’s not n-Tracks, but n-Tracks will be greatly affected.

(and I have to work today…I’m not a happy camper)