Maudio Duo

asio driver probs

I’ve been using the M-audio Duo with N-Track (ver.3.3) for a couple of years now without too many hassles. Was using it last in December 04. But when I plugged the Duo in and powered it up tonite XP ‘discovered’ it as new hardware!

I’ve always used the asio drivers as they’ve worked pretty well and I find no latency problems. When I opened N-Track tonite, though, I got the message ‘Error initializing asio driver’ and couldn’t playback anything. Switching to ‘WDM: USB audio device’ does work okay for playback. But what’s changed that I can’t use asio?

Have downloaded and installed the latest drivers from Maudio, have tried system restore to December 04, have uninstalled and reinstalled the Duo a few times…

Looking for suggestions of what else to try. Any help gratefully received! ???

Well then, bugga yez, I’ll answer meself.

ASIO4ALL v.2 seems to work a treat:


Hey, Mcoot…

Shoot…I was gonna mention ASIO4ALL since you said the WDMs were working, but I thought you were really looking for what the real problem was rather than getting a “workaround”, i.e., why Windows/N-track suddenly won’t use the Duo’s ASIO which you’ve been using for years. I shoulda known you just wanted the dern thing to work again!–Sorry. Anyway, this still has me stumped… Some Windows Update or SP2 install? Sampling rate selected in N-track not supported by the Duo’s ASIO? I’m stumped. If you do find out what happened, please post it if you get a chance! Thanks…