midi display problems

GM drums no note names in piano roll

i was working on trying to get midi output to work with ntrack and have actually figued it out. it works great. but now there is another problem:

i clicked on the instruments button (when general midi drums was selected) in the properties window of a midi drum track. in the instruments window i clicked on edit. i didnt change anything and i pressed ok, because there was no cancel button.

now there are no note names for the general midi drums in the piano roll. i tried to go back into the edit menu and it crashes the program everytime. ive reinstalled ntrack a bunch of times, ive tried the beta, nothing works. i just want the drum names to appear in the piano roll.

ive given up on sending a support request, ive done that several times before and even though it says you get a response in 24 hours, you most often never do.

i know the guy is busy but come on, dont say you’ll answer and then never answer.

If you are in the piano roll view, right click on the piano keyboard (or whatever you are seeing on the left edge). This brings up a dialogue that lets you select between “show piano”, “note names”, “show midi drums”, etc.

And yes, I agree. There are a few things about the “properties” window of a midi track that are broken. Odd and irreversible things seem to happen if you change things in that window. Of course I’m a midi noobie so take what I say with a grain of salt.


yeah, i did all that heres what happens:

telling it to display midi drum note names:

what happens after i hit ok:

and thats it, it shows nothing on the side bar. pretty freaking crappy huh? i though maybe i could edit the names but whenever i click edit, the program crashes.

Which version of n-Tracks are you using? (hard to tell from the screen shot)

When you select General MIDI Drums there should be a list of names in the list below. Since that is blank, what other Note name sets are available? If you don’t see many then maybe you are using a version of n-Tracks doesn’t include all the name sets. I don’t know which version added them.

If you are on V4.05 beta then they should be there for sure. Look for a file named banks_default.txt where n-Tracks is installed.

i tried both the beta and the latest official version. i have that file with the note names in it, and i has all the drum note names listed under general drums. so i really dont know what to do. ive found that often there are registry problems with ntrack. there really should be an automated way to clean the registry of ntrack entries. i guess ill try manually editing the registry again… unless anyone has any other suggestions. im all ears!

Not seeing the names shouldn’t be a registry problem, unless there’s a key that points to where it is. I’ll do a search.

DONE: Search for ntrack, fasoft and n-track. That will expose lost of keys, including paths to configs that I didn’t know about.

I wouldn’t suggest editing any, but nuking them probably won’t do anything bad as long as you do a full install to restore them. Of course nuking them will ruin your installation…as if that’s not bad. :)

There may be, and probably are, other keys in there.

Are you logged on as an administrator?

yeah im an admin, i know all about deleting ntrack from the reg, as ive done it a million times because of such problems, i was only hoping i wouldnt have to do it again. and im not even sure if it will work. thanks though, ill see if i can try deleting it from the reg tonight and ill get back to you.

i deleted all the registry entries and the program still wont display the #### midi note names for midi drums. this is becoming very irritating. i dont want to reinstall my whole computer because of this, but its looking like i might have to.

i sent a complain via teh feedback/support thing, and those never get answered, so i dont know what to do…

When you uninstalled n-Tracks and deleted the registry stuff did you also completely clean out the directory that n-Tracks in installed into?

Also search for fasoft stuff in you own settings folder. For example on my home machine there are copies of the config files and other things in C:\Documents and Settings\kellycraven\Application Data
-Track Studio

I’m at a loss as well.

i didnt look in the personal documents folder! ill check that out and see if i can get it to work. after that it looks like a fresh system install is the only thing that can do it…

i purged my system of ntrack again. i cleaned the registry, i deleted the folder in the application data folder under my username. i reinstalled, and it works!

now the only complaint i have is that i cant use the beta version because it doesnt support emu powerFX which i use a lot for vocal sweetening.

  1. Load a midi track to n-tack
    2. Right click on the track and select properties
    3. In properties (at the right side of n-track) select button "Instrument"
    4. Select the “edit” button
    5. Select “import” button
    6. Browse after file C:\Program Files
    -Track Studio\banks_default.txt
    7. Respons yes to all options as they appear one by one
    8. Restart n-track and it is back to standard set up and will now show names of notes in the piano roll again (hurra)