midi export issue

wrong one exported?

n-t 6.0.9 build 2604
Windows 7 Home Premium (x64) (build 7600)
3.00 gigahertz Intel Core i5 750
32 kilobyte primary memory cache
8192 kilobyte secondary memory cache
64-bit ready
Multi-core (4 total)

I have a tune with multi wav files, and 2 drum midi tracks.
One is n-track drums, just a kick drum midi track.
Second is ezdrummer, just a snare midi track.
I finished the kick drum using the piano roll, and it works good.
I started the snare track using the piano roll,
had about 10 bars working good, and so I copied the bars out to end of song, and I no longer could hear the snare track.
Any ideas on that? But while your thinking, I decided to export the ezdrummer snare midi track, and try to import it to
a new track.
I exported it, and imported it, but it was the n-track kick drum track.
I had selected the snare midi and
exported it, but when I imported it, it was the kick drum midi.
Any ideas on that?

Hi Pingcat. Hhmm!? I’ve had/got loads of stuff like this going on. Did you check that other empty pianoroll pages had created themselves? Can I ask? Did you copy the midi patterns from the pianoroll or timeline? Did you mute the midi track that you didn’t want to export - and did it export all/both midi tracks regardless? Are the midi tracks ‘still’ made-up of several seperate parts or have you managed to group them?
FA went over a dump from me and concluded that it seamed to be a ‘multi midi’ thing and asked me to recreate the issue.
I build my projects in the same way you describe and at some point, once I have a couple of midi tracks and any number of audio tracks, the problems start including similar to yours and worst of all, n crashes when I close the project. The only fix I’ve found is to struggle through to the point where I convert the midi to wav.

Hello TonyR,
Yes, I am seeing the same things you describe.
On import I get a new empty midi track, and other existing midi tracks also get loaded in that I didn’t want.
I copied existing midi patterens out to the right to lengthen midi tracks, using the piano roll page.
That is when the midi track stopped working.
I didn’t try doing a mute on export.
I will try some of this later tonight.
In older versions I also had n crash when doing stuff with midi, and not be recoverable, so I always try to back up my project prior to attempting midi stuff.
I will also see if I can create a simple track with two midi tracks that recreates some of these problems.

Pingcat. Report back.
A recent experiment suggests that a measure of midi, that isn’t edited in any way, behaves. At my end, once I’ve chopped out a chunk and pasted it, it all screws up.

I got the midi snare track back.
I highlighted the midi track and right clicked, and found a “Mute Part
Q” option that was selected.
I de-selected it and now have the sound back.
This appears to be a mute that is not tied to the track mute.
They work independant.

Now I can also do a midi export and import.
And it outputs all midi tracks (that are not Mute Part Qed), and imports them all.

TonyR, you seem to be one of the midi veterans around here.
I want to pan part of my sub-bass drum midi track which is just a kick drum midi track feeding a deep n-track bass drum.
I tried using the draw pan envelopes, but changes to the midi track do not work.
Is there a setting or way to do this?
Or is this a matter of controlling the panning from the vsti instrument my midi track is feeding?

Hi Pingcat. If only ‘veteran’ meant ‘expert’ :laugh:
Sorry dude but your findings are the same as mine. I’ve become used to converting midi to wav for this kind of thing. Under event draw, n only has velocity, controller and pitch bend so a midi pan can’t be drawn in the piano roll. You can, of course, set the pan within n-TDrums. But - at my end - even when input is set to controller and cotroller is set to pan it has no effect on the output.

TonyR, by ‘veteran’ I meant you have your wounds and scars but have survived to midi another day.
Just looking to learn some of that wisdom.
So I tried to record the midi track to a new track, but kept getting random glitch sounds.
So then I figured out to do a mix down of just the midi track using the “insert mixdown result into song” and that worked fine.

I am not sure if this is relevant or if it will help but…

I have noticed when I save a midi file as MIDI 0 format, then change it to MIDI 1 format and bring it into Ntrack all the fader/volume settings on the mixer including pan are then embedded into the midi file.

likewise you could take all the other tracks out of the midi file before saving it and only keep the midi file you want to save in there.

keep shinin

jerm :cool: