MIDI question

Mapping intruments

Hi,
I have both an Emu E-synth and a Roland XV-5080. My problem is the Emu expects instruments definitions in the 0 to 127 range while ntrack and the Roland seems to like instrument definitions in the 1 to 128 range. I use the Emu for recording the MIDI, so I always have to bump up by 1 the instrument# I want to use, for example, I have to tell ntrack to send 2:Bright Piano when what I really want to use is 1: Acoustic piano. Another problem occurs when I want to play that MIDI track back through the Roland… I have to remember to change it back to 1: Acoustic piano or I might get something like 57: Trumpet when what I really wanted was 56: Orchestra hit. Any ideas on how to cure this? Build 2085. Thanks!
Paul

Hi Paul,

Checkout the “banks_default.txt” file in the n-Track Program Files folder. I think you can do what you want in there (make a backup first, and I’m not sure if that file gets overwritten by a new install, so keep a copy of the modified file too).

HTH


Mark

Thanks, Mark. That did it for the Emu. I originally tried to do that for the given MIDI track by bringing up the MIDI track preferences and clicking on the Instruments button, then Edit… very cumbersome. I just used Cut-n-paste from a little Excel spreadsheet with what you suggested.

Now I have to figure out how to do playback on the Roland usig the ORIGINAL General MIDI assignment… the XV-5080 might be smart enough to do an offset. The only other way I can think is to make a COPY of each MIDI track but that’s till going to be sloppy…

Paul