MIDI+Wav not in sync with grid

MIDI+Wav not in sync with grid

I’m pretty new to N-Track but have run against this fundemental problem & can’t find an answer on this forum…

I’ve recorded a few audio tracks & now added a basic MIDI drumtrack section that I’d like to “multiple-paste” up to the length of the song. When I playback, all the bits (Audio and MIDI) are in sync, but all the parts are out of sync with the grid of the piano roll. The notes are played back a bit faster than the metronome (the grid). I believe this means I can’t copy/paste a short drum pattern multiple times, because all the midi notes are “time-based” and not “measures/beats-based” like the grid.

Surely I’m doing something basic wrong?

(my PC is fast enough, only runs N-Track and I have a nice M-Audio soundcard - so hardware’s not an issue)

Hi Gusto, did you start with the correct BPM settings on the audio tracks? Say using the metronome for timing?

You can go back and try to manually adjust the BPM to align the grid with the tracks(I would try a higher setting since your notes are ahead of the grid e.g. 120 to 121, 122, 123 etc etc, but if you didn’t use some sort of click track or metronome the timing could be erratic thus resorting to manually adjusting the midi drums to line up thru the whole song.