Mixdown latency issue

tracks going out of sync

We have several tracks of live drums which need to be mixed down into one continuous track, but each time I mixdown they move out of sync.

The first one is fine but the next tracks are slightly behind the rest of the song.

Have experimented with buffer settings and removing plugins, as well as any other variable we could find.

Does anyone have a clue, cause we’ve run out of ideas.

Probably need some more info - such as ‘several tracks of live drums’.
Are they .wav files that you are importing. How were the live tracks recorded?
and how are you syncing the individual tracks.
Sorry - don’t mean to be obtuse - but as always people here need lots of info
like your rig your soundcard/interface and more about the files themselves.
What sample rate (all the same?) Well you see what I mean. Also are you aligning
the tracks on a grid? I’m not one of the guru’s but it would seem pretty straight
forward unless you are using post-processing effects which in some cases may cause
some delay problems. Which is why it’s important to know what the specs of your computer/OS/memory and such are.
Come on back with some ‘hard facts’ and I’m sure someone here will chime in.

Sorry about being vague, I was just frustrated and needed to get it out. I’ll do my best to explain. (BTW, I’ve been using nTrack for years, using very similar recording techniques, with the same audio card in the same room. Just so you know).

The band is a two piece; drums and guitar, with some vocals and bits and pieces to flesh it out.

This track needed to be recorded in many parts, as the main beat was derived from a tremolo pedal on the guitar. We have had problems with the logistics of recording this for a long time - trying to keep the tracks separate for mixing. The solution was to draw a map of overlapped drums and guitar.

I’ll try to explain…

1st track- guitar with tremolo until the tremolo turns off (keeping a constant pulse)

2nd track- drums, atmospheric, as the song builds from start

3rd track- rhythmic drums come in, still over 1st guitar track

4th track- drums with beat following on past the end of tremolo guitar track

5th track- guitar,no tremolo, over track 4 drums, then back into tremolo once drum track ends

6th track- drums over tremolo guitar and then continue until end of song

7th track- guitar ,no tremolo, over last section of drums.

Plus overdubs

There for, what I’m left with is 4 drum parts, one after the other, that are 8 separate tracks (L+R)that sound fine until I try to mix them into one wav file. This is when everything after the initial drum track (which is butted up against the edge of the window, the others aren’t)is out of sync.

The Drums are recorded with 7 mics, into two small, identical mixers (one kick mic into both), one to left, one to right into nTrack and then treated as left and right stereo.

Guitar is recorded with 2 separate mics aimed at one amp, into the separate mixers as with drums, except for the very first track which used DI into just one mixer.

The audio card is an audiophile 24/96 used at 24 bit. OS is XPsp3. Latest version of nTrack.

That’s it for now. I’ll add any more info as it comes to me. Thanks for your time.

az

You indicated that you have done this successfully before. Sure sounds like a buffer problem. There is a setting in preferrences for plug-in latency, you might toggle that to the opposite setting and see if that changes anything. For things like this it’s also not a bad idea to try the default settings for everything.
Did you change versions of Ntrack? If you are using the latest version, it might be the cause of the problem, some bug that has not been caught yet. If you have updated, you might check that first. If you are not on the latest version, try that first (If you changed versions) It might be interesting if you reloaded the earlier version that worked and see if you have the same experience. I believe you can go back to earlier versions (there was a problem doing that at one time, but I think it was fixed.) If you try that, I’d put everything, including the Ntrack program and all the wav in a new directory, be sure you do not import any of the .npk files and create a new file for everything. I would not spend a lot of time trying to arrange all of the tracks, maybe just enough to see if it is working better.
What a drag, I hate it when I spend a long time gettng things just right to find out something is not working. Good luck. Keep us posted on what happens here.
BAx

Quote: (azza @ Jul. 27 2009, 10:20 AM)

Latest version of nTrack.

Perhaps your problem. Have you tried going back a revision or two to one you know worked?
???
Quote:

There for, what I'm left with is 4 drum parts, one after the other, that are 8 separate tracks (L+R)that sound fine until I try to mix them into one wav file. This is when everything after the initial drum track (which is butted up against the edge of the window, the others aren't)is out of sync.


So when playing the project in n-Track as multi-tracks it sounds good? But upon Mixdown things go out of whack. Correct? If so, I'd say something is broken in n-Track. File a bug report.

Check here as well... from the Download page;

Quote:

n-Track Studio version 6.0.5 Build 2493 Released
Sunday, July 26 2009, 11:20 am - 24 hours ago
Fixed small mixdown and freeze file length inconsistencies [Bug Fix]
Fixed Edit/Trim command not working properly on imported MIDI tracks [Bug Fix]
Fixed crash when a .cda file (i.e. an audio CD track) is selected in import audio file requester and "No" is answered to "Enable .Net features" prompt [Bug Fix]


D

Check out bug number 40. I’ve been having issues recently that sound similar. It’s new to my system, but I can’t go back to previous versions with these projects unfortunately.

http://ntrack.com/bugs/show_bug.cgi?id=40

So far, Flavio has not been able to repro the problem as it repros on my setup, yet it happens on both my laptop and desktop (Vista64 with onboard audio – WinXp32 with Echo Layla42 – two very different hardware setups).

Obviously, I’m missing something vital to the repro.

A new symptom is that playback speed will show as 0.99 instead of 1.00. I have very strong feeling this is pointing directly at the root of the problem.

It’s not buffer related, but samplerate conversion related. There should be no samplerate conversions happening at 1.00 playback speed, but if it’s anything else there will be some drift. I think playback speed is getting slightly drifted even if it says 1.00. I have no proof yet, except to see 0.99 after reloading a project sometimes.

Have you tried to establish the same conditions and results using another mix of
files? You know kind of an experiment to see if it’s related to how your mix was
created or wether the program is stumbling on mixdown in general?
Like create eight tracks using a metronome and drum hits at selected intervals
on different tracks and mixdown and see if it (mixdown) lines up with the original
eight tracks.

can you post the .sng or .sgw file for download or you think it would show up on another sys?

In my case I have 5 separate projects in the works. Except for the fact that all were recorded the same night to ADAT they are all different, pretty much from the ground up.

(no, I haven’t done that – need to get these projects finished and we’re right at the end)

Try a mix down while playing to see if that makes any diff.

Try some coffie :laugh:

During just playback the problem doesn’t occur. It does occur and become audible during playback if doing mixdown during playback. That confuses even more what the seems like the causes could be.

It’s not just a latency or sync issue. It’s that the resulting files are playing at a slightly different rate than the original.

Repro was easy for me.

–Clone a track. including EQ, plug-ins and all settings. (both tracks will play perfectly in sync - sample accurate from, beginning to end, after the clone)
–Bounce one of those to a single wave (wave data will not be processed by the plug-ins or EQ or anything else).
–The original and the bounced tracks will play a different speeds just a little, even if they were manually lined up so they were sample accurate at any point in the files.

There would be no artifacts that might be expected if this was a buffering issue.

In the original track EQ is being used. Plug-ins are being used. In the cloned track all EQ and plug-ins are set identically to the original.

The workaround is to manually remove all plug-ins and set all EQ to flat. Bounce the cloned track. Re-import the bounced wave back into the original song.

Not sure if I’m understanding this thread - but I took a click track generated
by Audacity [120bpm 4/4 16bit @ 44.1k] and imported into N.
I then cloned that track 2 times to tracks 2 and 3, selecting wav only in the
cloning options. I then mixed tracks 1,2 and 3 and had it auto inserted in the mix
on track 4. I tried each of the mixdown page settings.
I did get a severe timinig issue on one particular setting
That was when I selected ‘Single Multi-channel file’ and selected only the left
channel, or only the right channel. Selecting both channels caused no error.
But ‘Single Multi-channel’ is for surround sound processing I beleive.
So - did I miss something?

Please report you findings to Flavio - he has probably been watching this forum, but it might help to get your findings.

Quote: (sevenOfeleven @ Jul. 27 2009, 7:01 PM)

Not sure if I'm understanding this thread - but I took a click track generated
by Audacity [120bpm 4/4 16bit @ 44.1k] and imported into N.
I then cloned that track 2 times to tracks 2 and 3, selecting wav only in the
cloning options. I then mixed tracks 1,2 and 3 and had it auto inserted in the mix
on track 4. I tried each of the mixdown page settings.
I did get a severe timinig issue on one particular setting
That was when I selected 'Single Multi-channel file' and selected only the left
channel, or only the right channel. Selecting both channels caused no error.
But 'Single Multi-channel' is for surround sound processing I beleive.
So - did I miss something?

Was the Preferences sampling frequency the same as the click track's sampling frequency (i.e. 44100 hz)? Was there any non-default speed setting for either the track or the global speed setting on the main toolbar?
A problem that some people have reported is that they inadvertedly touch the speed slider on the toolbar and while the speed indicator still says "1.0x" the speed setting is not exactly 1.0 by a very small fraction, and that sometimes creates problems. To make sure that the speed is exactly 1x click on the speed indicator on the toolbar and select "1x" from the popup menu. I'll make the fact that the speed is not exactly 1x more visible in the next version of the program.

I've tried to follow the procedure but needless to say I wasn't able to reproduce any sync problem.
The "single multichannel file" option is mainly useful when you have more than one stereo output pair, selecting it and activating only the left channel will produce a mono wav file that contains the left channel.

Flavio.
Quote: (phoo @ Jul. 27 2009, 5:06 PM)

During just playback the problem doesn't occur. It does occur and become audible during playback if doing mixdown during playback. That confuses even more what the seems like the causes could be.

It's not just a latency or sync issue. It's that the resulting files are playing at a slightly different rate than the original.

Repro was easy for me.

--Clone a track. including EQ, plug-ins and all settings. (both tracks will play perfectly in sync - sample accurate from, beginning to end, after the clone)
--Bounce one of those to a single wave (wave data will not be processed by the plug-ins or EQ or anything else).
--The original and the bounced tracks will play a different speeds just a little, even if they were manually lined up so they were sample accurate at any point in the files.

There would be no artifacts that might be expected if this was a buffering issue.

In the original track EQ is being used. Plug-ins are being used. In the cloned track all EQ and plug-ins are set identically to the original.

The workaround is to manually remove all plug-ins and set all EQ to flat. Bounce the cloned track. Re-import the bounced wave back into the original song.

What plugins are used in the tracks? Do any of those have non-zero latency (as shown in the upper right corner of the plugin properties box)?
The problem shouldn't be related to the track EQ, which is unlikely to cause sync issues.

Flavio.
Quote: (Flavio Antonioli @ Jul. 28 2009, 4:37 AM)

Quote: (sevenOfeleven @ Jul. 27 2009, 7:01 PM)

Not sure if I'm understanding this thread - but I took a click track generated
by Audacity [120bpm 4/4 16bit @ 44.1k] and imported into N.
I then cloned that track 2 times to tracks 2 and 3, selecting wav only in the
cloning options. I then mixed tracks 1,2 and 3 and had it auto inserted in the mix
on track 4. I tried each of the mixdown page settings.
I did get a severe timinig issue on one particular setting
That was when I selected 'Single Multi-channel file' and selected only the left
channel, or only the right channel. Selecting both channels caused no error.
But 'Single Multi-channel' is for surround sound processing I beleive.
So - did I miss something?

Was the Preferences sampling frequency the same as the click track's sampling frequency (i.e. 44100 hz)? Was there any non-default speed setting for either the track or the global speed setting on the main toolbar?
A problem that some people have reported is that they inadvertedly touch the speed slider on the toolbar and while the speed indicator still says "1.0x" the speed setting is not exactly 1.0 by a very small fraction, and that sometimes creates problems. To
make sure that the speed is exactly 1x click on the speed indicator on the toolbar and select "1x" from the popup menu. I'll make the fact that the speed is not exactly 1x more visible in the next version of the program.

I've tried to follow the procedure but needless to say I wasn't able to reproduce any sync problem.
The "single multichannel file" option is mainly useful when you have more than one stereo output pair, selecting it and activating only the left channel will produce a mono wav file that contains the left channel.

Flavio.

>>



My apologies.

The tracks do indeed mixdown correctly using the 'single multichannel file' and seclecting either left or right or both left and right.





<<