Monitoring amp sim

Monitoring amp sim

New to N-Track - I record with some amp sims, mainly Amplitube 2 which 1st doesn’t show under N-Track (probably need to rescan the folder).

However - it recognized the Sonar amp sim and I was able to use it but only post recording, for some reason I cannot monitor through the amp sim while recording.

My audio card is FP-10 by Presonus, fairly new computer running XP.

I believe I am using the ASIO drivers and it lets me monitor in other software (Riffworks).

From the PreSonus site -

Quote:


·



Software Monitoring:
Because each FP10/FirePod's analogue mixer acts independently, you will need to monitor your inputs through your DAW instead of using the Mixer knob.
For software monitoring, turn your Mixer knob fully clockwise to “Playback (1-2)”.
By default, your computer's software will route its output streams to output channels 1 & 2 of ONE of your FP10/FirePod(s).

Yes - all the way to the right when I monitor via software. In this case I can’t seem to route it properly.

I am monitoring in Riffworks with amp sims while tracking - no problem whatsoever. In N I don’t get anything, tried it with also another freeware sim, with input monitoring “on”, still nada.

I asked ntrack to rescan vst plugins and that’s what I get:

7/2/2010 4:17:32 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll
7/2/2010 4:17:32 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll
7/2/2010 4:17:32 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll
7/2/2010 4:17:32 AM: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll: Scan failed
7/2/2010 4:17:32 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig RedShiftOverDrive 1.06.dll
7/2/2010 4:17:32 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig RedShiftOverDrive 1.06.dll
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig RedShiftOverDrive 1.06.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig RedShiftOverDrive 1.06.dll: Scan failed
7/2/2010 4:17:33 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Scar Unlimited 1.01.dll
7/2/2010 4:17:33 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Scar Unlimited 1.01.dll
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Scar Unlimited 1.01.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Scar Unlimited 1.01.dll: Scan failed
7/2/2010 4:17:33 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_FullStack_v1_05.dll
7/2/2010 4:17:33 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_FullStack_v1_05.dll
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_FullStack_v1_05.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_FullStack_v1_05.dll: Scan failed
7/2/2010 4:17:33 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_Head_v2.dll
7/2/2010 4:17:33 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_Head_v2.dll
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_Head_v2.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_Head_v2.dll: Scan failed
7/2/2010 4:17:33 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll
7/2/2010 4:17:33 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll: Scan failed

Any ideas why is it failing?
7/2/2010 4:17:33 AM: Scan finished

wouldn’t recommend ASIO drivers for live monitoring of plugs.

I recomemend it for everything else tho!
:agree:

Try the wmd’s.

I don’t know why but at least on my system and Ntrack they work better when attempting a live monitoring of a amp sim, or recording midi track that has a VST on it.

keep shinin

jerm
:cool:

Jeremy - why not? ASIO is supposed to be lower latency and more stable, that’s what PreSonus recommends to use as you only get 2 tracks with WMD drivers and latency up the wazoo.

Like I said, I recommend ASIO for everything else.

guess you don’t know unless you try.

I suspect if the ASIO’s were so much better at monitoring Live VST’s being processed you wouldn’t have posted the OP.

keep shinin

jerm
:cool:

ASIO works great for monitoring the exact same VST virtual amp sims in Cubase, Sonar and so on… They don’t work in N-Track! So in this case it looks like faulty code from within the DAW, not the drivers.

Not a dealbreaker - I’ll just ditch N-Track, I am doing this for a review and it looks like it is broken.

Have you contacted Flavio with the situation? He can quite often find a fix that will help future users should they run into a similar situation. N-Track is always evolving, and Flavio is quite reseptive to suggestions for improvements.
Bax

Quote: (houstonmusic @ Jul. 06 2010, 1:22 AM)

ASIO works great for monitoring the exact same VST virtual amp sims in Cubase, Sonar and so on... They don't work in N-Track! So in this case it looks like faulty code from within the DAW, not the drivers.

Not a dealbreaker - I'll just ditch N-Track, I am doing this for a review and it looks like it is broken.

That's odd because ASIO doesn't work for me in Sonar, using Freeamp when trying to monitor amp sims live, never did find out why, don't think my post were even responded to by other users in their forum.
I switched to WMD for that project only and it was fine.

Based on your suggestion tho I am going to try Amplitude and see what happens in Sonar next time I attempt something like that.

keep shinin

jerm :cool:

ASIO works for me so far in: Sonar, Acid, Riffworks, Mixcraft, energyXT, Cubase

Doesn’t work in N-Track.

I’ll contact Flavio on this maybe there’s a fix after all.

He mentioned the LIVE button in the toolbar:
http://ntrack.com/help/n-Track.htm#_Toc246390894

I doubt this will work for me as I am getting the vsts to crash and can’t even load them to start with.

Quote: (houstonmusic @ Jul. 01 2010, 11:17 PM)

I asked ntrack to rescan vst plugins and that's what I get:

7/2/2010 4:17:32 AM: Scanning c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll
7/2/2010 4:17:32 AM: Loading c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll
7/2/2010 4:17:32 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\AcmeBarGig Preampus-Distortus 1.02.dll


Any ideas why is it failing?
7/2/2010 4:17:33 AM: Scan finished

I am noticing according to these file paths you have Amplitude loaded into program files\steinberg\vstplugins.


Maybe it's just me, but I have found they work better when loaded into the Ntrack plugin folder.......at least when using VST's for Ntrack.

It is sometimes helpful to mention the type of system you are on what type of soundcard you are using, sometimes it is relevant.
I am using a ONYX1620 and have no soundcard in my computer so my particular problems are unique and the easy fixes like "set soundblaster card as default" or whatever do not work for me......I have to make that clear going in to get the right kind of help.
Other users of the ONYX series mixers can then chime in and say, "ya, that happened to me too, here is what I tried that worked.".....

keep shinin

jerm :cool:
Quote: (houstonmusic @ Jul. 01 2010, 11:17 PM)

I asked ntrack to rescan vst plugins and that's what I get:

...
7/2/2010 4:17:33 AM: Error unloading plug-in module: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll
7/2/2010 4:17:33 AM: c:\program files (x86)\steinberg\vstplugins\canadian\SoloC_PreAmp_v2.dll: Scan failed

Any ideas why is it failing?
7/2/2010 4:17:33 AM: Scan finished

Hi Houstonmusic,

are you using the 32 or 64 bit version of n-Track? We have just tested the plugins listed in the scan log and they appear to be loaded correctly by the 32 bit version.
Note that the 64 bit version of n-Track will only load 64 bit native plugins (you can install the 32 bit version on a 64 bit OS alongside the 64 bit version).

We have tested the AcmeBarGig/Canadian Metal guitar plugins as well as Amplitube 3 and they all worked correctly with n-Track, when playback in realtime using Asio drivers.

What doesn't exactly work when you use the Asio drivers for live monitoring/processing? Please describe what's happening with greater detail so that we can try to reproduce the problem.
If you can hear the input monitoring (coming trough n-Track, not via the soundcard's hardware monitoring) you should definitely be able to hear the input processed with effects.
Make sure that the Live button on the toolbar is pressed, and that the track(s) you want to use for live processing is armed for recording and the "Monitor live input" button on the track is active (it is on by default).

Thanks.

Flavio.

I can’t even get these plugins started but I installed the 64bit app, so I’ll try and use the 32bit and see how that fares, I believe that you found the problem!