n-Track Drums stopped working

n-Track Drums stopped working

I created a new Midi track, set the output to the n-Track Drums, and created an entire track. It worked great until I opened the song file the next day. The Midi track has all of the information, but the n-Track Drums don’t play any sounds when I click the play button. I have the Midi channel set to 16 and I can play the drum sounds from NTD while in Live Mode.

Please help.

UPDATE: WHen I play the MIDI track, the only Step the n-Track Drums play is Step “A”. I can see the different Steps on the Piano Roll view, but they are never triggered. I can also see all of the Steps I created in the n-Track Drums console.

Channel 10 for n-TDrums.

Follow this thread for a quick guide.


Thanks, Tony, but I’m trying to use the step sequencer which uses channel 16. Channel 10 seems to be only for individual drum sounds. There is a YouTube video about step sequencing on the User Manual download page.

When I tried creating a new song with a new Midi drum track, I received a message about not enough buffering. I tried increasing the buffering, but still no luck.

Any ideas?

Update2: It seems the connection between the Midi track and the n-Track Drums instrument is becoming broken. The Midi track will be playing, but no sound is coming from my audio device. I can still play the n-Track Drums by clicking each drum pad and hear sound though. I found out that if I create another n-Track drums instrument on that Midi track, it will start working again. Now I am up to Instrument ch. 4 Effect 1 on the n-Track Drums.

Does this sound like a bug or a setting that needs to be adjusted?


Hi, Tsantini.
I only ever tried the ch16/prg change method with n-T once and didn’t grasp the point. n-T is built to run n-TD on ch10 and prg changes are really easily achieved by dragging multi-timbral patterns straight onto a midi/pianoroll track. Give it a whirl.

Thanks TonyR! I gave in and tried the method you described and it worked.