N-Track Echo-Effect

is freezing the program


I’m working with the latest version 6.1.2(Build 2870) - Windows XP SP3 - Focusrite Scarlett 18i6.

Recently I tried to use the N-Track echo effect. If I open it, I can see the N-Track echo-screen, but can’t use it, because the whole
program(version 6) is freezing. - I have to restart N-Track to continue(without the echo effect).

All the other effects in version 6 are working fine!

I think the same echo-effect is also integrated in Version 4. Here the echo-effect works without problems.

Is this a known problem and a solution available, or should I write a bug report?!


That’s weird. The echo plugin should really not be causing any problems at all. It’s been around for years… I suppose the file might be corrupt? So, a reinstall?

how many tracks in the sng file?

have you tried freeze?

dontcare :cool:


reinstallation has no effect, even if I select not to use the existing configuration.

Using “Freeze” has also no effect. - It is not depending on how many tracks are loaded. The problem occurs also if I have only one track open!

The CPU is strong enough to work with a larger number of tracks and the RAM has also enough space left(1.4 GB).


Are you using any other plug-ins?

Try opening a new project, import any old audio file and apply only n-T echo. Then bring in all other vst plugs, one at a time, that you are using on your track.
Then take the culprit outside for a kickin’-)

I’ll be honest Lomi

many of us don’t use the NTrack echo

there are just soooooooo many better free VST’s out there based on better algorithms = better results. :agree:

dontcare :cool:

Even so, it has never behaved that way. I think Tony has the next step.

I only want to say that the above made suggestion had no effect, but…
in N-Track 7 the echo-effect is working accurate again!


that is good to hear, I never could get 6 to work properly on my antique system, but you give me hope for 7.

dontcare :cool: