n-Track for Mac v0.4.0 Beta Build 2605 Released

Multichannel devices, hammer button.

n-Track for Mac version 0.4.0 Beta Build 2605 Released,

Support for multiple and multichannel devices [Ported Feature]
Drop-down list (Rec vumeter -> hammer button) to change the format of recorded .wav files independently from the format used for soundcard I/O [New Feature]


I downloaded 32 bit on my Mac running OS X 10.6.4

I have my M-audio plugged in and turned on. It shows up in Mac System settings.
When I click Setting -> Audio Devices the list is empty.

If I set Mac system input to M-Audio, then N-tracks seems to know, as all 8 channels appear in the Input VU meter. Settings -> Audio Devices still show empty list.
Input VU shows all channels are maxed as if recording too loud. When I click on the little hammer under the VU meter for channel 1 (mic is plugged into channel 1) it says 16 bit.
If I change it to 32 bit float, the VU meter acts noral (shows level matching the spoken voice). I can record, wave looks normal, but playback is garbage.

Update: Tried same with 64 bit with same results, but did not even get a wav file when trying to record.

Is this the proper place to post these?


Hi dberch,

the fact that audio devices don’t show up might be related to settings that have not bee loaded correctly between the old and the new build.
Please try resetting the default settings by deleting the “/Users/[Your username]/Library/Application Support/n-Track Studio” folder.

We have just found a problem that causes frequent hiccups in recordings. A temporary workaround, until the next build is released in a couple of days, is to disable the “Show waveforms while recording” and “Generate npk files while recording” options in the Settings/Waveforms menu.

Thanks for the feedback,