N-Track hates ASIO and my Guitar Port

Unable to playback

Bummer. I am really interested in purchasing and using N-Track, but when I download and installed the latest version (Build 1846) on my laptop, and tried to set it to use my Guitar Port ASIO drivers, the program crashes!

If I try using the WDM or MME drivers, playback and the UI is very jerky.

The only way I can one of the demo songs to play back and the UI to work reasonable well, is by using the default MME drivers on the built in AC97 card.

I even tried using ASIO4ALL and that caused similar crashes, or bad playback.

Before I walk away from this thing, anyone have any ideas?


I have yet to get it to work with my GuitarPort as well, but I have yet to get the GuitarPort to work the way it should with any other app either. Don’t blame n-Tracks necessarily.

One trick to help is to use 48k only. The GuitarPort will work by itself at 44.1k or 48k, but it will not work at all period with another app when set to 44.1k. I was able to get it to sort of work a little when set to 48k. Of course, that’s a useless workaround since I record only at 44.1k. This is the sample rate as set in the the GuitarPort Console. I don’t remember if 16 bit or 24 made a difference. Of course any other apps need to be set to match.

I run both GuitarPort and n-Tracks at the same time so ther is no conflict there. I just have to use the analog I/O with it. It works flawless that way. It kind of defeats the purpose of having the GuitarPort show up as a device though.

WOOHOOO!! I just got the GuitarPort working with ASIO.

In Guitar Port Console - 44.1k 24 bits (only quicly checked 16 bits)
In n-Tracks
--INPUT ASIO CuitarPort
--OUTPUT ASIO GuitarPort
Recording audio format (clickthe hammer on th input VU meters)
Force to 16 bits was NOT checked, though tht needed to be checked if the GP Console was set to 16 bits.

These are pretty much the defaults.

I think the trick to getting it to work was selecting both Input and Output ASIO GuitarPort in n-Tracks. I don’t think I tried that before when I was having problems.

Regardless, I was able to record a full track with zero problems. I wasn’t abel to do that without using the audio out before.

Monitoring was fine, but playback goes out the GuitarPort analog output. That’s not much of a problem with my setup, but might cause problems for others that really need to monitor via their soundcard.

Thanks for the info, I will give that a try.

Are you using n-track 4.05? Are you using the 24-bit version of n-track? Did you have to tweak any of the buffer settings in n-track?


Yes, 4.05.1846 - 24 bits. No, I didn’t tweak any of the buffer settings. Since these are ASIO any tweaking will have to be done at the source - in GuitarPort.

EDIT: The Live option of n-Tracks does not work in this configuration. It makes the guitar sound like it’s got a ring modulator on it. It’s TOTALLY useless, but you don’t need it to monitor the guitar this way fortunately. Nothing I tried got rid of it. The first thought is some kind of feedback, but it sure didn’t sound like any feedback I’ve ever heard, and it’s not a runaway sound. It’s classic ring modulation. REALLY strange…