n-Track Newbie

Hi everybody,

I’m old to the world but new to n-Track so expect a lot of stoopid questions;-) I just bought/registered/installed it last night and am doing my best to read the manual (I hate reading manuals!) I’ve had some limited experience with Cubase and FL Studio but both were a bit of overkill for what I am looking for. Heard some good things about n-track so I thought I’d give it a whirl.

Stoopid Question #1: I haven’t come across any mention of how to use a USB MIDI controller keyboard in n-Track. All I found so far were references to a MIDI keyboard being plugged into the joystick/game port of the sound card. Is it possible to use a USB controller to run VST synths in n-Track?

Welcome to the forum Ed :slight_smile:

It’s possible, and likely someone here might use the same brand. Whatcha got?

The USB controllers install a driver package that should appear as “ports” when you look in Preferences in n-Track. Make sure your KB USB drivers are installed properly and check the MIDI Device settings in Preferences.

NOTE: Some USB devices use a Windows built-in driver. It should still appear in MIDI Devices though.

As Poppa said… “Whatcha’ got?” :)


Its an M Audio Keystation somethingorother (I’m at work right now & can’t remember exactly :)

If it’s a Keystation ## or Keystation ##es, you have to install a driver. You can get the latest at M-Audio’s website.


Regarding the keyboard problem; I haven’t had time to check out the advice you guys gave me (renovating a basement, life, etc.) but will definitely give it a try.

Last night, I had a few minutes free so I thought I’d fire up n-Track and record a couple of simple lines. Plugged in the guitar … Line in showing up on VU meters … Add Track … arm … record … nothing. I tried the same sequence again & when I stopped the recording, I had 8-10 tracks on the screen! The first 2 were normal level stereo, the next 3 pairs looked like the output of the previous tracks were being combined with my input signal (progressively higher level on each new pair).

After reading some messages around here, I gather that you can’t just add a track & record? The act of hitting the record button automatically adds a track? Can that function be shut off?

I was hoping n-Track was a straight-ahead, simple recording platform – am I off track? (pun)

Click the little hammer icon on the recording Vu meter. Disable any channels you do not want to record. Also, in Preferences there is an option to “Automatically add tracks when LIVE button is pressed” or similar. Un-check that.

As for the signal being looped back and added to the other tracks, check your soundcards control panel Recording controls section. You DO NOT want “Mono Mix”, “Stereo Mix” or “What you hear” enabled. You only want the input(s) enabled you are actually recording from.

I’m going from memory here so take this with a grain of salt. Also, if you tell us what sound card you are using, that would be helpful in troubleshooting.


Check out the tutorial at:


to get started with recording

M-Audio keystation 49e (I have one) requires no drivers for XP

Me again :wink:
OK, I’m finally home & have a couple of hours to read & try some things.
First off, thanks for all your patience.

I run a Creative Audacity 2 ZS soundcard.
I use it successfully in Fruity Loops Studio and an old version of CuBase, both overkill for me … I’m looking for something closer to my old Fostex 4-track.
Also, I’m running v6.0.2 Build 2425 of n-Track. (I see that there’s a newer version available but I’d like to get this one going first).

I watched the tutorial.
Actually, I watched it before I bought n-Track & that’s kinda why I bought it but I watched it again in case I missed something.
To test a few things, I started a blank project, plugged in the guitar again and checked for input levels.
Everything seemed OK so I hit record.
8 tracks recorded – similar to what I described before.

I think I figured out the basic record problem thanks to Dubious.
When I clicked on the hammer, I found a button marked ‘Select I/O channels’.
On the ‘Input’ side of the menu, everything was selected by default! (weird?) I deselected all except ‘Analog Mix R / Analog Mix R’ (I think that last part should read ‘Analog Mix L’ ?) and VIOLA! … only 1 stereo track recorded on my next test.
It looks to me like the default settings were for a 5.1 setup???

Anyway, I’m making progress, thanks to everybody’s help :slight_smile:

Tanks, tanks a lot,


Did I mention I drink rum while setting up programs?
Maybe this affects things???
nahhhhh :wink:

With your sound card which is similar to mine you might experience some track bleeding, thats when you record a new track, say a guitar and your older tracks say, bass and drums get recorded together into your new guitar track instead of just the guitar track being recorded as intended, this is track bleeding. If you experience this, try ASIO4ALL, way better than the Creative’s ASIO driver and it works well with SB brands of sound cards. I would recommend the ASIO4ALL drivers for any Creative Labs sound card because the Creative just sucks when it comes to it’s sound drivers.

Oh, by the way, Welcome!!! to the forums and the N-Track.


Haven’t had trouble in other programs with the Creative ASIO driver. I always heard that ASIO4ALL was a substitute to be used only when you didn’t have a proper ASIO driver for your card but you’re saying it is better than Creative’s? Worth trying I guess if I notice the bleeding you refer to.

Thanks for the welcome :)

I’ve got an older Audigy and the ASIO drivers are superb with every program
I have ever tried.
20msec or better latency.

set Ns prefs to 48000k and the Audigy will be in sync with N - at 44100k (default satting)it wont be -